When will we have Octoprint support?  

Page 3 / 3
  RSS
manousos.v
(@manousos-v)
Active Member

@finariel

Try a different cable. Maybe it's bad. I'm connected the same way. USB on the Pi to Micro USB on the Mini. Been working flawlessly for weeks.

FWIW I also toss a ferrite choke on my USB cables.

This post was modified 2 months ago by manousos.v
Posted : 05/02/2020 10:45 pm
fns720
(@fns720)
Active Member

@manousos-v

I have a Raspberry Pi 3A+ connected to the Prusa MINI (RPI: USB-A, Prusa Mini: Micro USB). Octoprint did not find /dev/ttyACM0 - what else did you configure on the Octoprint?

Posted : 06/02/2020 8:03 am
Oxygen
(@oxygen)
Estimable Member

have you enabled the serial port (option 2 from this page) enable serial port

Mini with FW:4.0.5-Final...
Posted : 06/02/2020 8:51 am
fns720
(@fns720)
Active Member

@oxygen

I don't have a Serial option in raspi-config. I have added enable_uart=1 to /boot/config.txt but Octoprint still does not recognise the port. 

Posted : 06/02/2020 9:02 am
fns720
(@fns720)
Active Member

Guys, I figured it out finally.

 

I'm using a Raspberry Pi 3A+. The Raspberry Pi's USB-A port is connected to the Prusa MINI's micro USB port using a standard micro USB cable with a ferrule coil on it.

If you have installed Octoprint 1.3.12 from the official image, run <code>sudo raspi-config</code> and in the Interfacing options / P6 Serial enable serial. If this does not help change the micro USB cable with one which has a ferrule coil on it.

In Octoprint serial settings, leave Serial Port and Baudrate on Auto and leave Additional serial ports field blank, and enable Request exclusive access to the serial port.

Posted : 07/02/2020 1:31 am
LittleNeutrino
(@littleneutrino)
Trusted Member

@fns720

I just tried this, no dice, and its the same USB cable I use for most things, never had an issue with it on other things. Any other suggestions?

Posted : 11/02/2020 3:00 pm
stevensmith
(@stevensmith)
Trusted Member

I've been having pretty good luck with Octoprint, but just ran into the following error and Octoprint eventually disconnected from my Mini.

The error reads "Error: Printer keeps requesting line 1419125 again and again. Communication stuck". Any ideas? This was 8 hours or so into a 10 hour print 🙁

 

Posted : 11/02/2020 3:32 pm
LittleNeutrino
(@littleneutrino)
Trusted Member

ok, i switched to a different pi and now its working without issue (connection anyway) so now i guess i will work on tweaking it to make it work with the mini.

Posted : 11/02/2020 11:01 pm
LittleNeutrino
(@littleneutrino)
Trusted Member

Anyone that has it working, can they post a dump of the Printer profile they setup for it as well as their GCODE preambles ect..  I tried to set it up but its printing 1mm or so above the print bed and just useless even when using the exact same GCODE that I have on the flash drive.

Posted : 12/02/2020 4:34 pm
bradmcgonigle
(@bradmcgonigle)
Eminent Member
Posted by: @littleneutrino

Anyone that has it working, can they post a dump of the Printer profile they setup for it as well as their GCODE preambles ect..  I tried to set it up but its printing 1mm or so above the print bed and just useless even when using the exact same GCODE that I have on the flash drive.

Here is my basic printer profile for my Mini copied right out of the PrusaSlicer printer settings:

Print bed & build volume

  • Form Factor - Rectangular
  • Origin - Lower Left
  • Heated Bed - Checked
  • Heated Chamber - Unchecked
  • Width (X) - 180mm
  • Depth (Y) - 180mm
  • Height (Z) - 180mm
  • Custom bounding box - Unchecked

Axes

  • X - 180mm/min
  • Y - 180mm/min
  • Z - 180mm/m
  • E - 80mm/min

Hotend & extruder

  • Nozzle Diameter - 0.4mm
  • Number of Extruders -1

 

I only have one GCODE Script which I got from https://github.com/prusa3d/PrusaSlicer/issues/1126 (End GCode).  I use it in the the 'after print job completes' script: https://gist.github.com/BradMcGonigle/601556da256c142c2ea25302a122cd12

I've tried Octolapse but haven't had any luck yet with the settings so if anyone has a nice working Octolapse setup, I'd love to know your settings for it with the Mini.

This post was modified 2 months ago 2 times by bradmcgonigle
Posted : 13/02/2020 2:41 pm
Strankler liked
Strankler
(@strankler)
Active Member

@littleneutrino

I just wanted to post my settings here, since you were asking for it in the waiting thread. But I saw bradmcgonigle already did it, and I just can confirm, that I 'm working with the same settings as he does. Except, I don't use the additional GCODE scripts (but worth trying).

All my additional GCODE script field are empty, only in "

Posted : 14/02/2020 10:24 am
LittleNeutrino
(@littleneutrino)
Trusted Member

So I used those settings, and it will print the first couple layers, and then it just stops extruding (not jammed just not spinning the extruder anymore) printing from USB still works fine.

Posted : 14/02/2020 1:30 pm
stevensmith
(@stevensmith)
Trusted Member

@bradmcgonigle

These mirror my settings (without your gcode scripts). I too have been unsuccessful with Octolapse. I have it configured and it snaps photos appropriately, but after the first layer, the Mini air prints. It's as if my octolapse settings retract too much filament without detracting the right amount. I posted about it in his facebook group.

I've only had one glitch with Octoprint as posted previously. On that print, I used PrusaSlicer's Variable Height feature and I think it confused Octoprint. Otherwise its running pretty well.

Posted : 14/02/2020 1:36 pm
joeri.s
(@joeri-s)
Active Member
Posted by: @littleneutrino

So I used those settings, and it will print the first couple layers, and then it just stops extruding (not jammed just not spinning the extruder anymore) printing from USB still works fine.

This is the same with Repetier server. Also you can't use the z-live and the screen of the mini is not showing the actual print info.

...
Posted : 01/03/2020 8:05 am
clemens.m
(@clemens-m)
Estimable Member

Is someone of you using "Bed visualizer" - would be very interested which settings are necessary to create an update of the mesh.

Best regards, Clemens

Posted : 01/03/2020 4:40 pm
clemens.m
(@clemens-m)
Estimable Member

Found it - it was "G28" for Autohome and "G29" for Meshbedleveling - there I found it:
https://forum.prusaprinters.org/forum/user-mods-octoprint-enclosures-nozzles/gcode-for-prusa-mesh-leveling-plugin/

Best regards, Clemens

Posted : 01/03/2020 5:27 pm
Page 3 / 3
Share:

Please Login or Register