Loading, unloading, and switching filament with Octoprint connected
 

Loading, unloading, and switching filament with Octoprint connected  

  RSS
jeff.p14
(@jeff-p14)
New Member

Obviously when you connect Octoprint, it takes over management of the printer, and you have very limited options on the LCD screen. But does anyone have a solution for how to load or unload filament with Octoprint connected to the Mini? Normally when printing via USB stick, the options are there and it works fine, but they're greyed out in "Octoprint mode."

'M701' and 'M702 C' commands do not seem to work.

Posted : 24/06/2020 6:25 pm
robee
(@robee)
Trusted Member

Have you tried the new RC1 firmware? It lets you disconnect without resetting the Mini now, and you can then change the filament as usual from the menu and then reconnect with Octoprint afterwards.

Posted : 25/06/2020 10:58 pm
jeff.p14
(@jeff-p14)
New Member

@robee

I have not, but I will do so immediately and report back.  Thanks for the tip! 👍 

Posted : 26/06/2020 2:35 pm
jeff.p14
(@jeff-p14)
New Member

So with the Buddy board, is there no way to allow filament control while Octoprint is connected?  Looks like 4.1 RC1 still locks out loading and unloading while under serial management.

Posted : 26/06/2020 3:09 pm
gordon.w
(@gordon-w)
Estimable Member

The original issue ( https://github.com/prusa3d/Prusa-Firmware-Buddy/issues/362 ) was closed as 'fixed in 4.1 RC1' but apparently it wasn't! See https://github.com/prusa3d/Prusa-Firmware-Buddy/issues/626

Posted : 26/06/2020 3:40 pm
robee liked
robee
(@robee)
Trusted Member
Posted by: @jeff-p14

So with the Buddy board, is there no way to allow filament control while Octoprint is connected?  Looks like 4.1 RC1 still locks out loading and unloading while under serial management.

Yes but you can disconnect, unload and load the filament, and reconnect in Octoprint now. Before you had to reset the Mini to do this, which meant it had no idea what the XYZ position was. I think this is fine since I'll have to open Octoprint again to do something next anyway.

Posted : 26/06/2020 7:32 pm
jeff.p14
(@jeff-p14)
New Member

@robee

I don't think this is fine, because it's really not even close to feature parity with the MK3.

Posted : 26/06/2020 9:54 pm
towlerg
(@towlerg)
Reputable Member

I believe there is a plugin for OctoPrint, something like Change_Filament, it might help.

Posted : 27/06/2020 4:42 pm
amim
 amim
(@amim)
Active Member

Thanks @jeff-p14 for addressing this. I face a similar problem with the Prusa MINI connected to Octoprint + filament sensor. Yesterday i tested, if the filament sensor works, when i print over Octoprint and run out of filament. Because i installed the filament sensor just a few days ago.

Now, when i was run out of filament, the filament sensor just didn't noticed it. The extruder pulled more and more filament as if nothing changed, but the filament was clearly already running through the filament sensor. So now i have the question, is someone facing the same problem? I did not have the time to test the filament sensor by using the normal USB stick and print from there and test if it works without Octoprint.

This post was modified 1 month ago 2 times by amim
Posted : 27/06/2020 5:23 pm
robee
(@robee)
Trusted Member
Posted by: @amim

Now, when i was run out of filament, the filament sensor just didn't noticed it. The extruder pulled more and more filament as if nothing changed, but the filament was clearly already running through the filament sensor. So now i have the question, is someone facing the same problem? I did not have the time to test the filament sensor by using the normal USB stick and print from there and test if it works without Octoprint.

Can you check that the filament sensor option is enabled in the Mini options menu?

Posted : 27/06/2020 5:58 pm
amim
 amim
(@amim)
Active Member

Can you check that the filament sensor option is enabled in the Mini options menu?

Ok, i've checked and it was off, thanks! Also updated the firmware to 4.1.0-RC1 now. Should it work now?

Posted : 27/06/2020 6:14 pm
robee
(@robee)
Trusted Member
Posted by: @amim
 
Ok, i've checked and it was off, thanks! Also updated the firmware to 4.1.0-RC1 now. Should it work now?

The filament sensor being off means the Mini ignores it, so yes just enabling that should fix your filament sensor problem. 4.1.0-RC1 adds an option to disconnect from Octoprint which lets you change filaments (or do anything you like normally) and then you have to reconnect with Octoprint manually when you are done.

Posted : 27/06/2020 6:17 pm
amim liked
Share:

Please Login or Register