Notifications
Clear all

Anyone have successful Octolapse settings?  

Page 1 / 3
  RSS
bradmcgonigle
(@bradmcgonigle)
Eminent Member
Anyone have successful Octolapse settings?

I've been trying to get Octolapse working successfully with my Mini but can't get the settings right.  The nozzle keeps getting blocked after the first layer no matter what 'Stabilization' setting I use.

Posted : 21/02/2020 8:52 pm
Texy
 Texy
(@texy)
Reputable Member
RE: Anyone have successful Octolapse settings?
Posted by: @bradmcgonigle

I've been trying to get Octolapse working successfully with my Mini but can't get the settings right.  The nozzle keeps getting blocked after the first layer no matter what 'Stabilization' setting I use.

I don't understand what 'blocked nozzle' has to do with the camera? Do you mean blocking the camera view ?

Texy

Posted : 24/02/2020 10:51 am
LittleNeutrino
(@littleneutrino)
RE: Anyone have successful Octolapse settings?

@texy

For some reason when using Octolapse it messes with the retraction settings of the printer. So what happens is about 2-3 layers into the print, the printer will "jam" in reality it just stops extruding and just keeps moving around but not extruding.

Posted : 24/02/2020 2:38 pm
bobstro
(@bobstro)
Illustrious Member
RE: Anyone have successful Octolapse settings?
Posted by: @littleneutrino

[...] For some reason when using Octolapse it messes with the retraction settings of the printer. So what happens is about 2-3 layers into the print, the printer will "jam" in reality it just stops extruding and just keeps moving around but not extruding.

Success with Octolapse is very dependent on getting your settings to match your printer's retraction settings exactly. Octolapse works by intercepting the gcode stream and injecting the gcode to position the camera to the appropriate positions and exactly back into position for the next print commands. If you don't have it set properly, it can contribute to stringing and any of the other problems commonly encountered when tuning retraction.

There are a bunch of YouTube videos on the topic. IIRC, the Teaching Tech video did a pretty good job explaining the details.

 

My notes and disclaimers on 3D printing and miscellaneous other tech projects
He is intelligent, but not experienced. His pattern indicates two dimensional thinking. -- Spock in Star Trek: The Wrath of Khan...
Posted : 24/02/2020 3:07 pm
bradmcgonigle
(@bradmcgonigle)
Eminent Member
Topic starter answered:
RE: Anyone have successful Octolapse settings?

@texy yeah...exactly what @littleneutrino said.  I did a bad job of explaining my issue but that is exactly it.

There are adjustable settings for the printer including retraction settings but I've copied exactly what is in PrusaSlicer (as the Octolapse docs suggest) but haven't had any luck yet.

Posted : 24/02/2020 3:13 pm
SS220
(@ss220)
Estimable Member
RE: Anyone have successful Octolapse settings?

Yep, something's up with Octolapse and the mini. I've got 3 other printers working with Octolapse (2 direct drive and 1 bowden). The setup was easy and they all work well. However, the Mini seems to have a retraction issue with Octolapse. I've made sure all of the retraction settings mirror Prusaslicer exactly, but it still stops printing after the first layer or two. I have not tried it with FW 4.0.3 yet. 

Posted : 24/02/2020 3:16 pm
LittleNeutrino
(@littleneutrino)
RE: Anyone have successful Octolapse settings?

@stevensmith

4.0.3 does not resolve the issue. So when using OctoPrint i just dont use OctoLapse and it works fine.

Posted : 24/02/2020 3:18 pm
bradmcgonigle
(@bradmcgonigle)
Eminent Member
Topic starter answered:
RE: Anyone have successful Octolapse settings?

@stevensmith I've tried on 4.0.3 and I still get the same results with extrusion stopping after the first 1-3 layers.

Posted : 24/02/2020 3:18 pm
Texy
 Texy
(@texy)
Reputable Member
RE: Anyone have successful Octolapse settings?

OK - thanks for the explanation. I occasionally use octolapse on my mk3, and I hadn't thought about it causing print issues, as for me, it 'just works'. I'm still waiting on delivery of my Mini. I'll be sure to keep away from using it until it is sorted.

Texy

Posted : 24/02/2020 4:00 pm
formerlurker
(@formerlurker)
Active Member
RE: Anyone have successful Octolapse settings?

Perhaps someone with a mini would be willing to create an issue on the Octolapse github? I have been wanting to create a profile for the Prusa Mini anyway, so this might be a good opportunity.  I'm not going to fix any problems in V0.3.4 (the current master release) since I'm so close to releasing V0.4, so working on this issue would require using the pre-release version of Octolapse.  I'll need a gcode file sample (something small, like a calibration cube) as well as any other information you can give me about the printer, like min and max XYZ coordinates.  Thanks!

Posted : 24/02/2020 8:08 pm
bradmcgonigle
(@bradmcgonigle)
Eminent Member
Topic starter answered:
RE: Anyone have successful Octolapse settings?

@formerlurker I opened a ticket but let me know if you need any more details.  I'd be happy to provide whatever you need or run some tests for you. https://github.com/FormerLurker/Octolapse/issues/462

Posted : 26/02/2020 9:39 pm
formerlurker
(@formerlurker)
Active Member
RE: Anyone have successful Octolapse settings?

@bradmcgonigle, thanks for the report!  I'll look into this right after work.  I'm going to send you some info via github for upgrading to the latest pre-release of Octolapse, since I don't plan to add any regressions to the version you are using (v0.3.4).  I'll also add a profile for the prusa mini to the profile repository so that it is available to all users.

FYI, my initial thoughts about your issue (no extrusion after the first layer) are that the mini must respond differently to the G90/G91 commands.  Do you know if changing the axis mode via G90/G91 affects the extruder axis mode?  It would be possible to run a test of this via the OctoPrint terminal interface.  The MK2 and MK3 do not change the extruder axis mode (relative vs absolute) when a G90/G91 is sent, and that could definitely cause the issue you were seeing.

Posted : 26/02/2020 9:53 pm
bradmcgonigle
(@bradmcgonigle)
Eminent Member
Topic starter answered:
RE: Anyone have successful Octolapse settings?

I've successfully created my first Octolapse with the Mini thanks you @formerlurker.

https://forum.prusaprinters.org/wp-content/uploads/2020/02/3dbenchy_0.2mm_PLA_MINI_1h31m.mp4

It required me to install the 0.4.0 pre-release version of Octolapse and follow a few additional steps @formerlurker provided in https://github.com/FormerLurker/Octolapse/issues/462#issuecomment-591669600

  1. Read this guide for installing and configuring the pre-release version of Octolapse. Pay extra attention to the bits about PrusaSlicer (enable verbose gcode).
  2. Then, install the latest pre-release version of Octolaspe by using the plugin manager and pasting this into the from url... box after clicking get more: https://github.com/FormerLurker/Octolapse/archive/devel.zip

Let me know if you have any issues following the above steps. Once you have the new version installed, you might want to test out my hunch about G90/G91 by changing this setting in your printer profile:

image

This post was modified 2 years ago 3 times by bradmcgonigle
Posted : 28/02/2020 8:49 pm
formerlurker
(@formerlurker)
Active Member
RE: Anyone have successful Octolapse settings?

I've added a default profile for the mini that is currently available in 0.4.0rc1.dev3+.  I am hard at work on the next (and hopefully last) dev version (dev5), so hopefully these changes make it to the master soon.

I've asked @bradmcgonigle about this, but figured it's not a bad idea to ask here too.  What are the printable coordinates for the mini exactly?  From looking at the gcode it seems like it should be:

X: 0 to 180
Y: -2 to 180
Z: 0 to 180

But when I look through the mini's firmware source, I can't find anything positively defined.  I do see an X manual homing position of 180.4.  Basically I'm trying to figure out the max and min absolute coordinates for all axes.

If anyone else wants to try it out, shoot me a message or check out the issue @bradmcgonigle created on github.

Posted : 29/02/2020 5:08 pm
SS220
(@ss220)
Estimable Member
RE: Anyone have successful Octolapse settings?

@formerlurker

@bradmcgonigle

Thanks for your efforts on this.  I had tried changing the G90/91 behavior under the current version without effect.  I'll try installing the latest release candidate shortly!

 

Posted : 29/02/2020 8:48 pm
SS220
(@ss220)
Estimable Member
RE: Anyone have successful Octolapse settings?

Seems to be working!

 

Posted : 01/03/2020 12:03 am
formerlurker
(@formerlurker)
Active Member
RE: Anyone have successful Octolapse settings?

@stevensmith, excellent!  Did you use the pre-configured mini profile I made?  I'm hoping to verify that the profile is correct before the next release of Octolapse.

Posted : 01/03/2020 3:24 pm
pmu liked
SS220
(@ss220)
Estimable Member
RE: Anyone have successful Octolapse settings?

@formerlurker

Yes, I reset Octolapse and loaded your Mini profile. The only wonkiness I've seen with the RC is that when I set a manual focus on my webcam, the setting is not 'sticky.' All of the others are (exposure, color temp, sat, etc.). When I go back in to adjust any of the settings, the focus is reset to auto and I have to remember to adjust it to manual again before saving. Everything else seems to be working great!

 

Posted : 01/03/2020 7:16 pm
bradmcgonigle
(@bradmcgonigle)
Eminent Member
Topic starter answered:
RE: Anyone have successful Octolapse settings?
Posted by: @stevensmith

Seems to be working!

 

Nice, looks amazing.  What camera are you using? The quality blows mine away!

Posted : 02/03/2020 1:50 am
SS220
(@ss220)
Estimable Member
RE: Anyone have successful Octolapse settings?

@bradmcgonigle

I'm using a Logitech C920c.  Big difference between that one and the C270 on my other printer. 

Posted : 02/03/2020 5:24 am
Page 1 / 3
Share: