Notifications
Clear all

Where's the Orange Ball?  

Page 1 / 2
  RSS
JacktheRipper
(@jacktheripper)
Trusted Member
Where's the Orange Ball?

I just tried doing a color change using PrusaSlicer 2.2.0, and didn't see any Orange Ball, like there used to be, I thought. How do you change colors now? I slice, then drag the layer slider, which is now split into two halves, but no Orange Ball appears.

...there are only 10 kinds of people in this world--those who know binary and those who don't......
Posted : 07/07/2020 7:53 pm
towlerg
(@towlerg)
Noble Member
RE: Where's the Orange Ball?

Right click or the padlock

Posted : 07/07/2020 10:53 pm
JacktheRipper
(@jacktheripper)
Trusted Member
Topic starter answered:
RE: Where's the Orange Ball?

Right click or the padlock

Yes, that's what I remember, but nothing happens with a right click now. Specifically,

(1) I'm operating in Expert mode.

(2) I open a stl and slice it.

(3) Left clicking the padlock toggles it, but it always says "One layer mode". Right clicking padlock does nothing.

(4) I drag the orange ball to the layer where I want a filament change. Left or right clicking the orange ball does nothing. As I recall this used to give me a layer change.

So, I'm still stuck

 

This post was modified 1 year ago by JacktheRipper
...there are only 10 kinds of people in this world--those who know binary and those who don't......
Posted : 08/07/2020 6:29 pm
Pedroid
(@pedroid)
Eminent Member
RE: Where's the Orange Ball?

I drag the slider and left click on that plus. Right clicking on the bar offers the change colour dialog. I just made a video:

Colour change video

(Prusaslicer german edition, sorry)

This post was modified 1 year ago 2 times by Pedroid
Posted : 09/07/2020 6:19 am
Neophyl
(@neophyl)
Famed Member
RE: Where's the Orange Ball?

It may be that something in your install/profiles has gotten corrupted.  That can cause issues like this.

Backup all your profiles by using File>Export>Save Config Bundle.  Then find where the user data is stored (will vary depending on your system).  Rename the folder so it can be restored or if corrupted can be attached to a github issue (the devs are always interested in corrupted profiles as they need them to track down potential causes).  

Then re-install from scratch and see if the colour change function works again.  If not then its something else and you can always restore the user data folder or import your previously exported config bundle to reset all your profiles.

Posted : 09/07/2020 6:24 am
JacktheRipper
(@jacktheripper)
Trusted Member
Topic starter answered:
RE: Where's the Orange Ball?

Indeed, as I stated at the top of this thread, I was using PrusaSlicer 2.2.0, but I had already installed 2.3.0 on top of it, so  both were installed apps. Old, obsolete shortcut in my task bar was the explanation. I uninstalled 2.2.0, and now 2.3.0 works correctly. I did not have to do any purge/restall of 2.3.0 to get it to work, but I'll probably take that step just in case. Thanks to all for your quick help.

...there are only 10 kinds of people in this world--those who know binary and those who don't......
Posted : 10/07/2020 9:04 pm
JacktheRipper
(@jacktheripper)
Trusted Member
Topic starter answered:
RE: Where's the Orange Ball?

It may be that something in your install/profiles has gotten corrupted. That can cause issues like this.

But, wait, it's back!!! Well, I got confused by PrusaSlicer 2.2.0 being delivered in Software Download 2.3.0, So this is still a problem for me using the latest version of PrusaSlicer 2.2.0. Previous versions of PrusaSlicer worked correctly (PrusaSlicer 2.1.0 alpha, as I recall).

...there are only 10 kinds of people in this world--those who know binary and those who don't......
Posted : 11/07/2020 11:34 pm
JacktheRipper
(@jacktheripper)
Trusted Member
Topic starter answered:
RE: Where's the Orange Ball?

So I have reinstalled PrusaSlicer 2.1.0, and confirmed that it works as expected. So I believe this is a bug in 2.2.0. Has anyone out there actually used 2.2.0 with a layer change successfully?

...there are only 10 kinds of people in this world--those who know binary and those who don't......
Posted : 13/07/2020 9:30 am
Neophyl
(@neophyl)
Famed Member
RE: Where's the Orange Ball?

@jack

Yes, I have used it several times on actual prints.  Most recently last week on some very small 2 colour logo prints.

As I said before I suspect there is some corruption in your profiles somewhere.  When you clean install 2.2.0 do you still have the problem ?  That is rename all the folders and then add a new object to a fresh project  and try the single extruder colour change ?

Also could you save a project file that has the problem (save project as) and then take the resulting *.3mf file, zip it up and attach it here please.  That way we can load it in and see if it allows it on our installs.  

Posted : 13/07/2020 9:57 am
JacktheRipper
(@jacktheripper)
Trusted Member
Topic starter answered:
RE: Where's the Orange Ball?

As I said before I suspect there is some corruption in your profiles somewhere.

I uninstalled 2.1.0 and downloaded a fresh copy of 2.2.0 and installed it. This time I ran the Configuration Wizard--the previous times I had not. And now it works as expected, so you've pointed me in the right direction, and it worked. Thanks very much. I can't say for sure if the Wizard corrected a problem, but I will always run it in the future when upgrading. Lesson learned. Thanks again....Jack

...there are only 10 kinds of people in this world--those who know binary and those who don't......
Posted : 14/07/2020 11:39 pm
JacktheRipper
(@jacktheripper)
Trusted Member
Topic starter answered:
RE: Where's the Orange Ball?

So this problem has come back after working for a few months. Removing and then re-installing 2.2.0 (from a package called prusa3d_win_2_2_9_1) and running the Wizard has not fixed it this time. Again, I believe it's a bug in 2.2.0, and I'm going to go back to 2.1.0 if I can find it.

...there are only 10 kinds of people in this world--those who know binary and those who don't......
Posted : 18/11/2020 12:11 pm
Neophyl
(@neophyl)
Famed Member
RE: Where's the Orange Ball?

All versions are available on Github.  https://github.com/prusa3d/PrusaSlicer/releases

I think you are the only person experiencing this issue as I have never seen any mention of it anywhere else either here or on github where defect issues are reported.  

I suggest again that if you save a zipped up 3mf project here that we may be able to look at the contents and possibly find something.  

You could also raise a bug report over on github and see if the developers can help you.

Posted : 18/11/2020 2:21 pm
JacktheRipper
(@jacktheripper)
Trusted Member
Topic starter answered:
RE: Where's the Orange Ball?

Well, it's back again! This time with PrusaSlicer 2.3.0. Earlier I had problems with 2.2.0 and got that fixed by wiping clean and reinstalling. I moved on to 2.3.0 it worked fine initially, but now it is broken again: There is no Orange Ball after slicing to do a filament change at a given layer.

It's not credible I'm the only one experiencing this issue--I'm just the only one that's mad about it. I'm a very vanilla user, running Windows 10 64 with all the updates installed on a very capable Alienware machine. Hard for me to believe my installation is getting "corrupted". Corrupted by what? More than likely it's corrupted by PrusaSlicer itself. That's called a bug.

Where, exactly, do you report bugs? I'll be glad to post one on this issue.

This post was modified 5 months ago by JacktheRipper
...there are only 10 kinds of people in this world--those who know binary and those who don't......
Posted : 05/05/2021 1:57 am
--
 --
(@)
Illustrious Member
RE: Where's the Orange Ball?

It's just hard to find ... you know - memory being what it is - we forget exactly what we did months back.  lol.

But, what I just found is that you can make the ball disappear (well, it isn't there to start with). But it comes back if you move the layer slider down a notch.

When the slider is at the top layer - I think is is "above" the part, so no layer change is possible. Once you move the slider, it forgets that is it above the part and stays on. So really - the second image shows the real defect.

This post was modified 5 months ago 3 times by --
Posted : 05/05/2021 2:17 am
--
 --
(@)
Illustrious Member
RE: Where's the Orange Ball?

Bug reports go here: https://github.com/prusa3d

Posted : 05/05/2021 2:22 am
Swiss_Cheese
(@swiss_cheese)
Noble Member
RE: Where's the Orange Ball?

it's not a bug, it will disappear if your all the way up with the up arrow selected, and if you have the up arrow selected and then select the down arrow in its full down position it will also go away and will move back and forth between the two if they are anywhere in the center range.

 

I think you are simply confused by this behavior.

 

hopefully this will help clarify,

 

Swiss_Cheese

The Filament Whisperer...
Posted : 05/05/2021 3:53 am
--
 --
(@)
Illustrious Member
RE: Where's the Orange Ball?

The action of the selector is bugged. As you can see in my second image, the change pointer - that thin orange bar just below the arrow - is above the part yet it "might" allow me to enter a filament change (I haven't tested it by pressing the octagon +).   But the UI is suggesting I can press the + and do something. 

The pointer is not there when you start the app; it appears only after you move the preview layer selector. Returning the selector to the top of the part the pointer does not disappear nor return to the same state it was in when you start the app and finish a slice.  It is difficult to say which state is the defect, but defect it is. 

And yes, the behavior is confusing - that is why it is a UI defect.

Posted : 05/05/2021 5:03 am
Swiss_Cheese
(@swiss_cheese)
Noble Member
RE: Where's the Orange Ball?

It doesn't appear at first because there is not a presumed selection, you have a choice of what arrow to select first. If you were to select the bottom arrow first after slicing you would still see no orange ball, until you move the slider if you select the top it will appear. this being confusing for some does not make it a defect or bug, as for the ball showing up at the very top layer you can add commands and it can be useful to do so.

The Filament Whisperer...
Posted : 05/05/2021 5:24 am
Neophyl
(@neophyl)
Famed Member
RE: Where's the Orange Ball?

One other possible reason this could be confusing for some is that there is also a reported issue on github about which of the layer slider arrows is automatically selected.  According to the devs the up/top arrow should be but for at least one person it is automatically selecting the down/bottom arrow.  If the Insert gcode icon is tied to this functionality then its behaviour could be different depending on if they are suffering the other issue.

Posted : 05/05/2021 6:35 am
--
 --
(@)
Illustrious Member
RE: Where's the Orange Ball?
Posted by: @swiss_cheese

... this being confusing for some does not make it a defect or bug ...

As a retired product manager for expensive complex rather high-tech software - I can state with confidence it qualifies as a UI defect. My team would agree with me. The severity of defect is debatable.

Posted : 05/05/2021 7:04 am
Page 1 / 2
Share: