Slicing woes - flat bottom isn't flat
 

Slicing woes - flat bottom isn't flat  

  RSS
hawai
(@hawai)
Estimable Member

Hello everybody,

I've got a rather annoying problem: something that is supposed to have a flat bottom is sliced with a one layer step in it.

 

The .stl is an export from Blender 2.90.1. There the base is made up of a cube object that sits completely flat (zero degrees rotation along all three axis). Importing it into Slicer 2.3.0 (as well as previous versions) generates a one layer step. This is most likely already a flaw in the .stl and I have asked in the Blender Artists Forum for help as well, but maybe somebody here has any helpful ideas how to fix this.

 

Thanks in advance for any help.

 

Cheers

Hansjoerg

Posted : 17/01/2021 9:03 pm
Neophyl
(@neophyl)
Noble Member

Could you post either your stl or the blend file. I use blender all the time so could take a look. 
Also have you tried the place to bed tool available in Slicer ?

must zip up the files to be able to attach them here. 

Posted : 17/01/2021 9:15 pm
Zedsquared
(@zedsquared)
Active Member

Place to bed might just move the step to upper surfaces. If that's the case and your use can tolerate it, try using the cut tool to slice the bottom flat perhaps?

Posted : 17/01/2021 10:07 pm
hawai
(@hawai)
Estimable Member

ooops, forgot the .3mf...

 

and the .blend is here: https://pasteall.org/blend/85191706497d4e399e9b8d7a3eb9672a

Unless there is another "place on bed" tool than the one accessible via the icons on the left, yes I have done that

Posted : 17/01/2021 10:16 pm
hawai
(@hawai)
Estimable Member

actually wrong link: https://pasteall.org/blend/739d0a8964264a8a9072085e91df0f57

 

and this one slices correctly, I got lost in inconsistent file naming, this one has only the problem og the not properly joining objects...

 

big apology, those things happen when you put a project on the back burner for too long 🙁

Posted : 17/01/2021 10:27 pm
JoanTabb
(@joantabb)
Moderator

Unfortunately I don't have Blender, and there is no .3mf...  

anyway. In my experience, Sometimes the Place on surface tool fails... Especially if the surface is Almost parrallel with the build plate, 

try 'Alternative Logic'...   
use the rotate tool to make sure your chosen flat surface is nowhere near parallel to the build plate... (Go on, humour me! Please)
now try the place on face tool again, and it will probably work for you!

Good luck, regards Joan

I try to make safe suggestions,You should understand the context and ensure you are happy that they are safe before attempting to apply my suggestions, what you do, is YOUR responsibility. Location Halifax UK...
Posted : 18/01/2021 3:21 am
Neophyl
(@neophyl)
Noble Member

I take it the cube is the object with the visibility turned off in the blend file ?  Is there an issue now or not ?  I'm a bit confused as to if there is anymore as you say the second one slices fine ?

Also you must have to scale your models down a lot for slicer ?  With the units that blend opens up with the cube is 100 metres long.  Why not set your scale in millimetres and that way the scale is correct when imported into PS.

 

Posted : 18/01/2021 7:24 am
hawai
(@hawai)
Estimable Member

apologies for the silence, I was busy with the day job...

 

@Joan: it's reassuring that you support my thinking, I did exactly as you suggested multiple times because I had the suspicion that the tool might need a few attempts to get it right. So I tried both the rotate the object randomly as well as clicking on different offered surface areas before using the assumed bottom. Works most of the time, but didn't work with this object. I finally made the base plate a bit thicker than I wanted and simply cut the bottom away using the tool in Slicer - this finally worked.

 

@neophyl: sorry for the initially wrong file, the second link is the latest iteration. And yes the visibility turned off object is the cube in question. A few explanations: The whole model is made up of originally individual .obj files that come from a human body parts database out of Japan (BodyParts3D). After "assembly" I used the join command in Blender to have a single object. This actually worked well for all but one object. The original object of the trachea (windpipe, the corrugated tube at one end, apologies if I'm over simplifying the anatomical names). The original object didn't have any "thickness to it. It was basically only 2D polys and I had to add thickness to it to get something printable. But it still behaves somehow different to the rest once it is joined up.

While everything else slices as one continuous object the trachea part slices individually where it intersects with the base plate. Using an add modifier instead of the join command made it slice somewhat better (as in the current version) but still not as one model.

 

 

In regards to the unusual dimensions/scale the 100m size of the object stems from the original files from the BodyParts3D database. Although Blender says it is 100m long, when imported as .stl into Slicer it is 100mm and thus exactly the size it needs to be. I have decided to ignore this odd behaviour as it works for me.

 

I have attached the version of the .3mf I am currently working with.

 

Cheers

Hansjoerg

Posted : 20/01/2021 7:56 pm
JoanTabb
(@joantabb)
Moderator

@hawai

If at first you don't succeed, cheat...   Lol... 

I would probably  have done something similar

regards Joan

I try to make safe suggestions,You should understand the context and ensure you are happy that they are safe before attempting to apply my suggestions, what you do, is YOUR responsibility. Location Halifax UK...
Posted : 21/01/2021 12:30 am
Share:

Please Login or Register