slicer gives me too low print speed no matter how I configure it
 
Notifications
Clear all

slicer gives me too low print speed no matter how I configure it  

  RSS
Mcarson
(@mcarson)
Active Member
slicer gives me too low print speed no matter how I configure it

Version 2.3.1, Windows 10

Not only are all of the printing speeds set well above 20, I've set in the cooling settings a minimum speed of 30 and a 'slow down' threshold of 1 second, no difference, the entire perimeter is at 20mm/sec. (I'm running a single-extrude square wall to calibrate extrusion width)

This may be related to another annoying factor I've had with Prusaslicer that I have never had using slic3r for years. I can change fans and other things and it won't let me reslice; I haven't worked out when what change cause it to happen because it only happens sometimes.  If I to go back to the object window and shift its position a hair, THEN the 'Slice Now' button appears again (but that doesn't seem to make a difference).

Since this issue shows up in the slicer itself, it does not matter what machine I have (it's custom anyway)

thanks, hope you can

This topic was modified 4 months ago 2 times by Mcarson
Posted : 10/06/2021 4:44 am
towlerg
(@towlerg)
Noble Member
RE: slicer gives me too low print speed no matter how I configure it

I haven't experienced anything like you describe but if it help Ctl+R will reslice.

Posted : 10/06/2021 8:46 am
Neophyl
(@neophyl)
Famed Member
RE: slicer gives me too low print speed no matter how I configure it

If you wouldn't mind saving your project (file>Save Project as) and then zip up the saved .3mf file and attach it here we can take a look at your settings.  Without it there not much we can do but guess.

Posted : 10/06/2021 11:42 am
Diem
 Diem
(@diem)
Noble Member
RE: slicer gives me too low print speed no matter how I configure it

@mcarson you will normally only see max speed changes in larger parts, ones where there is room for the nozzle to get up to speed.  You will see more effect on most parts by altering acceleration and jerk-limit settings.

Cheerio,

Posted : 10/06/2021 3:57 pm
bobstro
(@bobstro)
Illustrious Member
RE: slicer gives me too low print speed no matter how I configure it

Any chance layers are printing at speeds below your cooling thresholds? If you have Enable auto cooling enabled, any layer that prints faster than your Slow down if layer print time is below setting will have the printing speed reduced proportionally down to the Min print speed setting.

I've been bitten by this several times when designing small test prints and forgetting to verify print speeds in slicer Preview mode.

As @Neophyl suggests, save your current  3MF project file, zip it up, and attach it to a reply here so we can see your part & settings and give better recommendations.

My notes and disclaimers on 3D printing and miscellaneous other tech projects
He is intelligent, but not experienced. His pattern indicates two dimensional thinking. -- Spock in Star Trek: The Wrath of Khan...
Posted : 10/06/2021 5:35 pm
Mcarson
(@mcarson)
Active Member
Topic starter answered:
RE: slicer gives me too low print speed no matter how I configure it

sorry, I posted gcode earlier instead of the .3mf file attached now.

Block_25x25x15

Also wanted to point out that even if I turn off auto-cooling nothing changes.

This post was modified 4 months ago by Mcarson
Posted : 10/06/2021 10:11 pm
Ringarn67
(@ringarn67)
Reputable Member
RE: slicer gives me too low print speed no matter how I configure it

@mcarson

A square, 25 by 25 is 100mm print line in total per layer, you have "Enable Auto Cooling" on and "Slow Down if Layer Time Is Below" set to 5s.
The result is 20mm/s to keep minimum layer time more then 5s. 20mm/s for 5s is 100mm.

Also wanted to point out that even if I turn off auto-cooling nothing changes.

If I disable "Enable Auto Cooling" in your 3mf the speed goes from 20 to 30mm/s!
How and where do you see that nothing changes?

 
Prusa I3 MK3S+ (kit dec -20), PrusaSlicer, Fusion 360, Windows 10...
Posted : 10/06/2021 11:44 pm
bobstro
(@bobstro)
Illustrious Member
RE: slicer gives me too low print speed no matter how I configure it
Posted by: @mcarson

sorry, I posted gcode earlier instead of the .3mf file attached now.

Block_25x25x15

Also wanted to point out that even if I turn off auto-cooling nothing changes.

Set Filament Settings->Cooling->Cooling thresholds->Slow down if layer print time is below to 0. The 3MF you provided clearly has these options set:

It is a small print. If a layer prints in less time than those threshold settings, it will slow down the print if Enable auto cooling is enabled. Prove it to yourself by rescaling the print up 300% and slicing again. Then disable Enable auto cooling, set Slow down if layer print time is below to 0, or otherwise manipulate the settings to match the size of your print and try again.

 

 

My notes and disclaimers on 3D printing and miscellaneous other tech projects
He is intelligent, but not experienced. His pattern indicates two dimensional thinking. -- Spock in Star Trek: The Wrath of Khan...
Posted : 11/06/2021 2:24 am
Mcarson
(@mcarson)
Active Member
Topic starter answered:
RE: slicer gives me too low print speed no matter how I configure it

Not sure why those values were in that file; I worked with those before but they are now supposed to match what I've been describing.  Anyway, I just saved and attach the project again with a screenshot of the cooling settings.

These settings should block any slowdown to 20mm/s, correct? With these settings I see just 20 mm/s. If I turn off auto-cooling, it doesn't even allow me to reslice it.  If I turn off the auto-cooling, still won't allow a reslice and if I force one, the result is still 20mm/s.

I did the scale up to 3x and the perimeters jumped to 30mm/s that was set in the 'Print Settings' tab, so that 'slow down..' setting is getting referenced, just not acting on it appropriately.

I'm going to attempt a re-install because I am becoming less and less dense about how this all works but the problem stays the same.

 

Posted : 11/06/2021 3:37 am
Mcarson
(@mcarson)
Active Member
Topic starter answered:
RE: slicer gives me too low print speed no matter how I configure it

As you can see here, I recreated a minimum speed of 30mm/s in Slic3r and only 1 second before slow-down is triggered.  Slic3r exports as expected.

I recreated the exact cooling settings in Prusaslicer and still get 20mm/s walls.

(still haven't re-installed yet, wanted a definitive picture of the problem first)

Posted : 11/06/2021 4:58 am
Mcarson
(@mcarson)
Active Member
Topic starter answered:
RE: slicer gives me too low print speed no matter how I configure it

addendum to my last post:

when I imported the .3mf file I sent to you, it still sliced badly but the settings were wrong and when I correct them to 1 sec lag and 30 mm/s min speed the problem persisted.

I closed and restarted the software and now it configures correctly, (headslap).  Must have had it open too long and some internal parameter got corrupted.  Hopefully it doesn't come back, I will come back here if my good fortune is short-lived.

thanks for all the suggestions

edit:

3 minutes later:  that luck had no life at all!  NOW I'm going to re-install.

This post was modified 4 months ago by Mcarson
Posted : 11/06/2021 5:10 am
Share: