Slicer Connect to OctoPrint on HomeAssistant
 

Slicer Connect to OctoPrint on HomeAssistant  

  RSS
matgriffin
(@matgriffin)
New Member

I run a Rpi for HomeAssistant and added Octoprint from the Supervisor>Add-on store. It works fine, connects to my Mini etc.

However when I try to connect Prusa Slicer to Octoprint using the IP address of the Rpi it does not connect, for example to access HomeAssistant I go to 192.168.1.50:8123, adding this in fails, tried with and without port (so port 80) also tried the network search but it fails.

I guess its more of the Add-on/HomeAssistant issue of how its exposing Octoprint to the network but just want to see if any one else has come across this.

Posted : 20/10/2020 12:11 pm
karl-herbert
(@karl-herbert)
Famed Member
Posted by: @matgriffin

I run a Rpi for HomeAssistant and added Octoprint from the Supervisor>Add-on store. It works fine, connects to my Mini etc.

However when I try to connect Prusa Slicer to Octoprint using the IP address of the Rpi it does not connect, for example to access HomeAssistant I go to 192.168.1.50:8123, adding this in fails, tried with and without port (so port 80) also tried the network search but it fails.

I guess its more of the Add-on/HomeAssistant issue of how its exposing Octoprint to the network but just want to see if any one else has come across this.

Hello and welcome to the Prusaforum!

Did you generate an API via Octoprint and register it in PrusaSlicer?

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 20/10/2020 12:57 pm
matgriffin
(@matgriffin)
New Member

@karl-herbert

Hello.

Yes I added the API as well, but reading and viewing online videos it should find Octoprint before the API code is added in.

Posted : 20/10/2020 1:00 pm
Gordon W
(@gordon-w)
Reputable Member

Apologies if I'm misunderstanding what you have written but installing the HA addon doesn't install Octoprint, it just adds the ability for HA to monitor Octoprint and report on progress. Slicer needs to point to the IP address where you have installed Octoprint (The HA addon will also need to be pointed to that address.)

Posted : 20/10/2020 2:00 pm
matgriffin
(@matgriffin)
New Member

@gordon-w

its full Octoprint in HA, its not a card that monitors Octoprint. Its really Octoprint in an iframe and an icon in the HA nav to get to itoctoprint in HA

This post was modified 1 month ago by matgriffin
Posted : 20/10/2020 2:18 pm
Gordon W
(@gordon-w)
Reputable Member

I'd never seen that addon before! I use the official Octoprint integration to break out sensors to monitor Octoprint. Have you tried entering port no 5000 (which Octoprint uses) rather than 8123 which HA uses?

Posted : 20/10/2020 6:12 pm
matgriffin
(@matgriffin)
New Member
Posted by: @gordon-w

I'd never seen that addon before! I use the official Octoprint integration to break out sensors to monitor Octoprint. Have you tried entering port no 5000 (which Octoprint uses) rather than 8123 which HA uses?

Thanks, found I had to set the 5000 port in the Add-on config 

Now working.
👍

Posted : 20/10/2020 7:54 pm
Gordon W liked
Share:

Please Login or Register