Slicer 2.2 is extremely slow to export gcode
 

Slicer 2.2 is extremely slow to export gcode  

  RSS
jalfeld
(@jalfeld)
New Member

I am having an issue with version 2.2, exporting gcode after slicing is extremely slow for some reason. I just tested it and to export the gcode for a single layer 40mmx40mm object too over 4 minutes. Obviously this is not a complex model that requires megabytes of gode being written to disk. The computer this is running on is a workhorse with a Core I7-8700K at 3.&Ghz with 32GB of RAM. It is writing to a M.2 SSd so drive speed should not be an issue.

Is there a setting someplace that I need to adjust or what is going on here?

Posted : 01/04/2020 3:39 pm
jalfeld
(@jalfeld)
New Member

Five days and zero interest.... Wonderful.....

This is clearly an issue in PrusaSlicer, it is the only piece of software on my system that has any issues with performance or write speeds, and is exactly some of the behaviors seen during beta that were "fixed".....

Posted : 06/04/2020 12:08 pm
Area51
(@area51)
Honorable Member

The help in this forum comes from other users, only rarely from Prusa.

If this is an error you would like to report to Prusa, you must create an issue under Prusa Slicer, here: https://github.com/prusa3d/PrusaSlicer/issues

It would help a lot if you post the problematic PrusaSlicer .3mf project file (in .zip file) in the forum, so that others can see your setup and test if they can see the problem as well.

Have a look at my designs on Thingiverse or on PrusaPrinters ;)...
Posted : 06/04/2020 4:16 pm
dario3design
(@dario3design)
Active Member

@jalfeld

Do you have PrintSetting --> Layers&Perimeters --> Quality --> AvoidCrossingPerimeters option active?

I had the same issue when clicking on this option. When it is is disabled it slices as fast as Cura does.

Posted : 06/04/2020 4:33 pm
jalfeld
(@jalfeld)
New Member

@dario3design

No avoid crossing perimeters is turned off. Tried messing with that and it has made no difference.

Posted : 07/04/2020 12:45 pm
jalfeld
(@jalfeld)
New Member

@area51

Here is an example, when I click on export gcode PrusaSlicer became completely unresponsive for 4 and a half minutes. This seems a little extreme for on object that is 40mmx40mmx.2mm, it is literally one layer....

0.2mm_layer_height

Posted : 07/04/2020 12:54 pm
gkas
(@gerrykaslowski)
Active Member

My Windows 10 computer exports it almost instantly.....

Posted : 07/04/2020 8:41 pm
Neophyl
(@neophyl)
Noble Member

Do you have anything besides your computer on a network ?  The reason I ask is that Prusa Slicer scans for various locations to export files to, such as usb drives, sd cards etc. If you have something on the network it’s remotely possible that it’s pinging that device, not getting a response and it’s the timeout that has to expire before it continues with the actual export. 

I get something similar with ALL file operations , like saving from Blender or even just file manager if I’ve accessed a location that I then later turn off, such as my printer for example. Bloody Windows 10, as it never happened on Win7. 

anyway back to the point, it may be waiting for a response from the Operating system. 

Posted : 07/04/2020 9:12 pm
cwiszowaty
(@cwiszowaty)
New Member

I am having same issues with slow slicing an now it wont export directly to octopi it worked fine before.

Connection to octopi works correctly 

 

when i test it

Error uploading to print host:
HTTP 403: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
<title>403 Forbidden</title>
<h1>Forbidden</h1>
<p>You don't have the permission to access the requested resource. It is either read-protected or not readable by the server.</p>

Posted : 12/05/2020 4:09 am
Share:

Please Login or Register