Notifications
Clear all

Settings have all disappeared  

Page 1 / 2
  RSS
tre4b
(@tre4b)
Eminent Member
Settings have all disappeared

Went to use my slicer and all of the options are default.  When I use the option to go to the configuration file everything is there, however when using the slicer I have no materials, settings or anything.  The only thing that has been retained is my Printer setup.

 

Any ideas what is going on here?  Feels like it may be looking for the files in the wrong directory (using version 2.2.0+win64)

Posted : 26/03/2020 11:00 am
Neophyl
(@neophyl)
Famed Member
RE: Settings have all disappeared

What printer do you have installed ?

From 2.2 theres a new Vendor space system and the default filaments and print profiles are part of a vendor space now.  If you have a custom printer then you have to have filament and print profiles that are no longer tied to a vendor (unless your printer is part of that vendor space).

While using the alphas/betas I had the same issue where my customised printer profiles (derived from a MK3 ages ago) werent part of the new prusa vendor space so the filaments and print profiles just werent there anymore as they didnt match.

On the filaments and Print profiles pages theres a new detach from vendor button (on the dependencies page so iirc you have to be in advanced/expert to see it) .  If you click that and save a copy of that profile it will then be detached and so should show up for custom/non prusa printers.  It was a 'breaking change' made to make future stuff easier.  Unfortunately its caused a few issues for those already using non prusa profiles.

Posted : 26/03/2020 2:37 pm
tre4b
(@tre4b)
Eminent Member
Topic starter answered:
RE: Settings have all disappeared

I have Prusa mk3S with an MMU2s, hence why I was kinda surprised to end up with a useless slicer when I opened it this morning 😉  I actually have zero filaments listed they all just say Default with no options or anything else.

Posted : 26/03/2020 4:08 pm
Vojtěch Bubník
(@vojtech-bubnik)
Admin
RE: Settings have all disappeared

Please read the section

Changes in handling of system vs. user profiles

of

https://github.com/prusa3d/PrusaSlicer/releases

...
Posted : 26/03/2020 4:26 pm
tre4b
(@tre4b)
Eminent Member
Topic starter answered:
RE: Settings have all disappeared

@bubnikv

It was all working fine on Tueday, today I opened it and it is blank.  The slicer version is the same so I'm pretty sure this is not to do with the slicer version, feels like something else has gone wrong here.

Posted : 26/03/2020 4:36 pm
tre4b
(@tre4b)
Eminent Member
Topic starter answered:
RE: Settings have all disappeared

Ah now I get it.  I have to copy the printer setup again so that it points at the right place...

Posted : 26/03/2020 4:38 pm
tre4b
(@tre4b)
Eminent Member
Topic starter answered:
RE: Settings have all disappeared

It occurs to me that the only reason I need a customised version of this is because I am sending data using Octoprint.  Maybe if the Octoprint connection was an application level setting rather than a printer based one this would not be necessary?

Posted : 26/03/2020 5:05 pm
Vojtěch Bubník
(@vojtech-bubnik)
Admin
RE: Settings have all disappeared

@trevor-b8

: It occurs to me that the only reason I need a customised version of this is because I am sending data using Octoprint.  Maybe if the Octoprint connection was an application level setting rather than a printer based one this would not be necessary?

Octoprint connection should be at a physical printer level, which we don't have yet. We may implement it for the next version if we manage to squeeze it into this release cycle.

...
Posted : 26/03/2020 5:12 pm
tre4b liked
Darrell
(@darrell)
Eminent Member
RE: Settings have all disappeared

I liked the system presets, and now they are all gone.  What's the process for restoring them?

Thanks

Posted : 28/03/2020 9:33 pm
bobstro
(@bobstro)
Illustrious Member
RE: Settings have all disappeared
Posted by: @thetipgiver

I liked the system presets, and now they are all gone.  What's the process for restoring them?

I believe running through the Configuration->Configuration Assistant will restore them. Busy on other stuff, so can't confirm for you at the moment. Do a snapshot before trying this to be safe!

 

My notes and disclaimers on 3D printing and miscellaneous other tech projects
He is intelligent, but not experienced. His pattern indicates two dimensional thinking. -- Spock in Star Trek: The Wrath of Khan...
Posted : 28/03/2020 9:57 pm
Darrell
(@darrell)
Eminent Member
RE: Settings have all disappeared

@bobstro

Tried that, and while it looks like it should work, it didn't.

Posted : 28/03/2020 10:25 pm
bobstro
(@bobstro)
Illustrious Member
RE: Settings have all disappeared
Posted by: @thetipgiver

[...] Tried that, and while it looks like it should work, it didn't.

Just to confirm: Are you using a Prusa printer?

 

My notes and disclaimers on 3D printing and miscellaneous other tech projects
He is intelligent, but not experienced. His pattern indicates two dimensional thinking. -- Spock in Star Trek: The Wrath of Khan...
Posted : 28/03/2020 10:29 pm
Darrell
(@darrell)
Eminent Member
RE: Settings have all disappeared

@bobstro

Yes.  Prusa I3 MK3S

Posted : 28/03/2020 10:31 pm
Neophyl
(@neophyl)
Famed Member
RE: Settings have all disappeared

@thetipgiver

I detailed in post 2 what you now have to do.  That was the decision made.  You now have to copy all the ones you want and detach them from system profiles.
The only other alternative is to save your printer profile, manually edit it to add your printer into the prusa vendor space and then import it back in.  That way the system thinks your printer is a prusa one.  
I had an older profile that was based on a normal MK3 that predated the new system and I lost them all too.  So I added a new Prusa printer, saved them all out, did a comparison and edited my old one to add the vendor details.  The prusa ones then reappeared.

 

Posted : 28/03/2020 10:35 pm
Darrell
(@darrell)
Eminent Member
RE: Settings have all disappeared

Went through and deleted anything that didn't seem useful.  Restarted the slicer, and it automatically put me through the setup again.  All of the defaults are back!

Posted : 28/03/2020 11:05 pm
Vojtěch Bubník
(@vojtech-bubnik)
Admin
RE: Settings have all disappeared

: Went through and deleted anything that didn't seem useful.  Restarted the slicer, and it automatically put me through the setup again.  All of the defaults are back!

 

Is it good or bad? Are you happy now? It is difficult to me to interpret the discussion.

...
Posted : 29/03/2020 10:01 am
Darrell
(@darrell)
Eminent Member
RE: Settings have all disappeared

It’s good. I’m happy now. I can’t speak for others in this thread, but that’s what worked for me. 

Posted : 29/03/2020 12:20 pm
tre4b liked
marcottt
(@marcottt)
Trusted Member
RE: Settings have all disappeared

hi all, i have lost all my material profile, less 3 (i don't know why when moved to 2.2 release. every previous version did not loose anything. How i can recover my custom material ? i don't have a prusa printer.

I also tried to make configuration wizard but is very buggy and did not complete if i not select some prusa printer and some sla material... i did not have prusa printer and no sla printer... but anyway my custom did not came back.

 

Anyone can tell me how to restore my material ? thanks

Posted : 31/03/2020 8:10 am
Neophyl
(@neophyl)
Famed Member
RE: Settings have all disappeared

If your previous customs were created from one of the defaults then they might be part of the prusa vendor space so they will only be available to a prusa printer under the new vendor space functionality.  You could try enabling the show incompatible profiles flag

 

 

 

If that doesnt work then I think you will need to create a new bug report over on github.  https://github.com/prusa3d/PrusaSlicer/issues

and then if that makes your missing profiles visible again you can then use the detach from system profile button on the dependencies tab to remove it from the vendor space.

 

 

 

Posted : 31/03/2020 8:21 am
marcottt
(@marcottt)
Trusted Member
RE: Settings have all disappeared

i partially solved in this way:
a) made a bundle configuration

b) restored an old bundle configuration (loose some printer config for example recent edit start code)

b1) now i have some fo my materials (50% i think)

c) restored bundle configuration from a)

c1) now i have 50% my materials and the recent printer config change.

this is bad... also i selected some material from profiles but did not appear...

Posted : 31/03/2020 8:34 am
Page 1 / 2
Share: