really fast z move after mesh bed leveling skips steps and print fails.
 

really fast z move after mesh bed leveling skips steps and print fails.  

  RSS
tmophoto
(@tmophoto)
New Member

when i slice with prusaslicer 2 (through repetier host)  i get a really fast z move that loses steps and does not make it back down to the print bed to start the print.  I cant figure out where its coming from or how to adjust that speed.  Is this value coming from repetier host or prusaslicer gcode?

Does anyone know where i can change this value in prusa slicer so i dont have to manually edit the gcode every time?  I just added the mesh bed leveling yesterday and this issue came up.

example gcode with the suspect line starred out.  if i change the F1200 move to something the z can easily handle the print works fine.

; generated by PrusaSlicer 2.0.0+win64 on 2019-12-04 at 11:23:51

M201 X2000 Y2000 Z50 E4000 ; sets maximum accelerations, mm/sec^2
M203 X150 Y150 Z35 E120 ; sets maximum feedrates, mm/sec
M204 P1500 R1500 T1500 ; sets acceleration (P, T) and retract acceleration (R), mm/sec^2
M205 X10.00 Y10.00 Z0.20 E2.50 ; sets the jerk limits, mm/sec
M205 S0 T0 ; sets the minimum extruding and travel feed rate, mm/sec
M107
G28 ; home all axes
M140
M104
M190
M109
G29
M420 S1

; Filament gcode
G21 ; set units to millimeters
G90 ; use absolute coordinates
M82 ; use absolute distances for extrusion
G92 E0
******G1 Z0.330 F1200.000******** this is the line the printer chokes on and the steppers skip lots of steps.
G1 E-0.75000 F240.00000
G92 E0
G1 X31.310 Y52.810 F1200.000
G1 E0.75000 F240.00000
G1 F840
G1 X32.498 Y51.076 E0.82399
G1 X33.840 Y49.663 E0.89261
G1 X68.479 Y19.954 E2.49935

This topic was modified 11 months ago by tmophoto
Posted : 04/12/2019 6:30 pm
Tim
(@tim-m30)
Illustrious Member

The commands to set limits (M20x) are setting what the printer should use.  In Prusa printers the firmware then limits speeds.

But if those firmware limits aren't aren't working for your printer, not sure what to recommend except to note Prusa MK3 is limited to 12mm/s for Z moves, your 50mm/s setting seems a bit excessive.

It is always wise to get more than one opinion......
Posted : 04/12/2019 6:41 pm
tmophoto
(@tmophoto)
New Member

thanks I will try that out.  do you know what the maximum speed of Z is on a MK3?  I resurrected an old frankenstein prusa mendel and have no idea where to really start.

This post was modified 11 months ago by tmophoto
Posted : 04/12/2019 7:03 pm
tmophoto
(@tmophoto)
New Member

that didnt work, no matter how low i put the z speed (acceleration and feedrate) it still chokes on that command. 

Any idea where i can change that in the gcode to a set value that works every time i slice a model?

Posted : 04/12/2019 7:59 pm
Tim
(@tim-m30)
Illustrious Member

As stated: maximum feedrate in Prusa Slicer for the MK3 is 12mm/s.

It is always wise to get more than one opinion......
Posted : 05/12/2019 3:06 am
Share:

Please Login or Register