Prusa Slicer crashes on start up
 

Prusa Slicer crashes on start up  

  RSS
BearFanks
(@bearfanks)
New Member

When I open PrusaSlicer it closes in a few seconds after starting up with out any error prompt showing up.  I have reinstalled the program, updated my graphics card drivers, restarted my computer and have run out of other fixes to try.  Is this a common problem? Please reply if you all have any solutions or need any additional information. Thank you for the helps

 

My PC is a desktop with GPU: AMD RX580  CPU: Ryzen 2600x with RAM 16gb.  I am new to 3D printing and have a PRUSA I3 MK3S+. 

Posted : 09/05/2021 9:39 pm
SlackerSteve
(@slackersteve)
New Member

Same experience. I haven't used it in a while. Updated to 2.3.1+win64 and I can no longer use it. Once it crashed my AMD graphics drivers and set up the radeon report box. My graphics drivers are from 4/30/2021.

It shows the main screen with the grid, doesn't load in the bed and everything is not clickable and the program  closes.

 

Hardware: Radeon 5800xt, Ryzen 3700x, 32gbs of ram.

 

** Update: I have a feeling this is a graphics drivers issue as I need to print something I dl cura and it behaves the same way. Crash on start up.

This post was modified 1 month ago by SlackerSteve
Posted : 10/05/2021 1:03 am
--
 --
(@)
Illustrious Member

Check your graphics card OpenGL support.

Posted : 10/05/2021 1:51 am
BearFanks
(@bearfanks)
New Member

I think I have figured out my issue.  The issue appeared to stem from my GPU workload being in compute mode instead of graphics mode.  I had been mining cryptos a while back and accidently left it on (this may be part of my recent poor gaming performance too...). I was able to recreate the crashing by switching back to compute workload.  If the issue reappears I will update. Thank you for the responses. (RX580 does support OpenGL)

 

You can get to this setting by opening the AMD Radeon Software, pressing settings in top right, go to graphics tab, open advanced dropdown and then option is there.  Another setting I saw was OpenGL triple Buffering that I might mess around with later.

Posted : 11/05/2021 2:52 am
SlackerSteve
(@slackersteve)
New Member

@tim-2

OpenGl is supported: Radon software is reporting OpenGL® Version 29.20.11000.14831

Ranamed c:\users\username\appdata\roaming\prusaslicer  and went through the startup wizard. It didn't crash through it, I then tried to add an object and when I clicked Add it crashed. When I run PrusaSlicer after that it returns to the same behavior and crashes within seconds of start up with no input.

Am going to try and build it from source when i get the chance.

This post was modified 1 month ago by SlackerSteve
Posted : 11/05/2021 3:50 am
SlackerSteve
(@slackersteve)
New Member

Okay something is wrong with the driver and OpenGL. Installed OpenGL Extentions View and ran the render tests. It fails when it tries to run the test with API 4.5 and crashes the program. This would make sense why other slicers are not working either.

Posted : 11/05/2021 4:02 am
SlackerSteve
(@slackersteve)
New Member

**Fixed

Uninstalling the graphics drivers worked for me.

In windows -> open device manger -> display adapter -> right click your graphics card -> Uninstall driver.

Posted : 11/05/2021 4:21 am
Share:

Please Login or Register