Pause on layer height M601 issue
 
Notifications
Clear all

Pause on layer height M601 issue  

  RSS
Travman13
(@travman13)
New Member
Pause on layer height M601 issue

Trying to print a GoPro tripod mount that has an embedded nut.  The M601 feature for pausing at a specific layer height works fine up to the pausing point, but when resuming the print, it pauses again, and when resume again, it pauses again into a loop.  It seems to never leave the paused layer height.  This started on 2.2.0-alpha2, then installed 2.2.0-rc and still the same problem.  On 2.2.0-alpha2 the M600 color change works perfectly but have not tried this on 2.2.0-rc yet.  Would like to get this corrected.  Thanks.

 

Chris

Posted : 29/02/2020 6:48 pm
Sembazuru
(@sembazuru)
Prominent Member
RE: Pause on layer height M601 issue

The behavior is describing how your printer's firmware is responding to the M601 code, not how Plicer is generating it. What firmware are you running in your printer?

See my (limited) designs on:
PrusaPrinters - https://www.prusaprinters.org/social/1448-sembazuru/prints
Thingiverse - https://www.thingiverse.com/Sembazuru/designs...
Posted : 29/02/2020 6:57 pm
Travman13
(@travman13)
New Member
Topic starter answered:
RE: Pause on layer height M601 issue

@sembazuru

the printer's firmware is 3.8.1-2869

Posted : 29/02/2020 7:17 pm
Travman13
(@travman13)
New Member
Topic starter answered:
RE: Pause on layer height M601 issue

@sembazuru

Found out someone else posted the same issue on GitHub and they say the same thing about being a printer firmware issue and will be addressed on the upcoming 3.9.0 version.  Thanks.

Posted : 29/02/2020 8:05 pm
Sembazuru liked
Sembazuru
(@sembazuru)
Prominent Member
RE: Pause on layer height M601 issue
Posted by: @ctravis13

@sembazuru

Found out someone else posted the same issue on GitHub and they say the same thing about being a printer firmware issue and will be addressed on the upcoming 3.9.0 version.  Thanks.

There is a release candidate available for 3.9.0 available on github. I have that installed and haven't run into any problems with it. (It is, after all, a release candidate so one hopes that most of the critical bugs have been eradicated by now. Plus it has been available for 12 days now without any commits so either it is about to be re-tagged as stable, or no one has gotten around to submitting any commits for it... No real way to tell w/o being part of the firmware team.) I jumped on installing it mostly to take advantage of the lowered MINTEMP setting (down to 10°C from 15°C) because my basement where the printer is seems to be hovering between 15° and 16° now that it is winter time where I live.

If you are feeling adventurous, you can get it here: https://github.com/prusa3d/Prusa-Firmware/releases Keep a copy of the 3.8.1 firmware file on hand in case you find a problem and need to down grade back to the current stable version.

See my (limited) designs on:
PrusaPrinters - https://www.prusaprinters.org/social/1448-sembazuru/prints
Thingiverse - https://www.thingiverse.com/Sembazuru/designs...
Posted : 01/03/2020 3:02 am
Ben V liked
cevabin618
(@cevabin618)
New Member
RE: Pause on layer height M601 issue

I'm currently testing the new "insert pause" implementation in slicer 2.2.0 alpha 2. I think one nice thing to have would be a time estimate to each pause just as you get when you insert color changes.

Posted : 08/03/2020 3:56 pm
DC
 DC
(@dc-2)
Active Member
RE: Pause on layer height M601 issue

I just got this issue on my MK3S with the older 3.8.0 firmware.  I had to restart it 10-15 times and then it kept printing like normal.  I think I'm going to stick to using the "color change" function instead of pause till there's a newer firmware.  Also I'm using a beta of Prusaslicer so that add more things that could be causing the issue.

Posted : 13/03/2020 10:55 pm
Ben V
(@ben-v-2)
New Member
RE: Pause on layer height M601 issue

@sembazuru

I can confirm the same - I had the issue with the 3.8 family and just flashed the 3.9.0 RC1 from 4/9 on github and the issue was resolved. 

 

-ben

-ben...
Posted : 10/04/2020 12:24 am
NickRno77
(@nickrno77)
Trusted Member
RE: Pause on layer height M601 issue

i've just done a long print, paused to insert magnet.......................... the same problem. For now, I'll do a colour change which I know will work. 

Posted : 17/04/2020 9:28 pm
kropexx
(@kropexx)
Eminent Member
RE: Pause on layer height M601 issue

The pause function also does not work on my Prusa Mini, I get the message but the printing continues as normal.

The firmware is up to date 😕 

Posted : 19/04/2020 8:38 pm
Area51
(@area51)
RE: Pause on layer height M601 issue

@kropexx

On the Mini the problem seems to be in the firmware 4.0.5 like the problem with MK2/3 firmware 3.8.0.

Have a look at my designs on Thingiverse or on PrusaPrinters ;)...
Posted : 19/04/2020 10:55 pm
Share: