Notifications
Clear all

OSX "Open new instance"  

  RSS
JMcK
 JMcK
(@jmck)
Reputable Member
OSX "Open new instance"

I'm using PrusaSlicer 2.3.0+ and per issue 2929 I have the "Open new instance" option on the "Window" menu, but it's always disabled. 

How do I activate this feature so I can have multiple windows?

 

 

When someone asks you if you're a god, you say, "YES!"...
Posted : 16/04/2021 7:02 pm
bapski
(@bapski)
Trusted Member
RE: OSX "Open new instance"

im also interested with inputs in regards to your inquiry.  i can't help but notice your PS version is 2.3.0 and also wondering if you'd had slicing issues. If so, you may want to try 2.3.1 RC that resolved my slicing issues. 

 

 

Posted : 16/04/2021 7:08 pm
bobstro
(@bobstro)
Illustrious Member
RE: OSX "Open new instance"

I'm able to open multiple instances running PrusaSlicer 2.3.1-rc on MacOS 10.14.6 Mojave.

My notes and disclaimers on 3D printing and miscellaneous other tech projects
He is intelligent, but not experienced. His pattern indicates two dimensional thinking. -- Spock in Star Trek: The Wrath of Khan...
Posted : 16/04/2021 8:42 pm
JMcK
 JMcK
(@jmck)
Reputable Member
Topic starter answered:
RE: OSX "Open new instance"

I'm on 10.15.7 Catalina.

Seeing same behavior in PrusaSlicer 2.3.1-rc.

I have been having slicing issues too, but I'm not sure if it's PrusaSlicer or OpenSCAD. They are also unchanged in 2.3.1-rc

When someone asks you if you're a god, you say, "YES!"...
Posted : 17/04/2021 6:04 pm
JMcK
 JMcK
(@jmck)
Reputable Member
Topic starter answered:
RE: OSX "Open new instance"

SOLVED!!!

"Allow just a single PrusaSlicer instance" in preferences.

<facepalm> at myself

When someone asks you if you're a god, you say, "YES!"...
Posted : 01/05/2021 2:34 pm
Neophyl
(@neophyl)
Famed Member
RE: OSX "Open new instance"

Slicing issues and OpenScad go hand in hand with PS.  Most of the problem models we see are generated from OpenScad.  Its very easy to get issues with that software if you dont set up your code and settings right.  

PS seems to have more trouble automatically fixing the model than Cura at the moment but I know the devs are looking at that due to the number of issues raised on github about 'bad slicing' or 'slicing bugs'.  In every instance, once the model is repaired or fixed at source PS slices them fine.

Posted : 01/05/2021 4:05 pm
JMcK
 JMcK
(@jmck)
Reputable Member
Topic starter answered:
RE: OSX "Open new instance"

Yea, I've been having tons of issues lately slicing my models out of OpenSCAD. I've generally been laying the blame on OpenSCAD though and not PS. Often when an exported STL fails, if I re-export as 3MF it's fine, or failing that I repair the STL with Microsoft's 3D Tools and it works fine.

While I hope OpenSCAD is fixing their render/export, upgrading the STL repair capabilities of PS would be a welcome workaround.

When someone asks you if you're a god, you say, "YES!"...
Posted : 09/05/2021 4:33 pm
Share: