Notifications
Clear all

Only lift Z above not working  

  RSS
xnaron
(@xnaron)
Active Member
Only lift Z above not working

Prusaslicer 2.3.3.

 

Only lift Z above set to 0.2 and below set to 0

It still lifts below 0.2.  I don't want the lift on the first layer.  No overrides set in filament.  What else could cause this?

Thanks

 

Posted : 27/08/2021 3:33 pm
bobstro
(@bobstro)
Illustrious Member
Only lift Z should specify a range (e.g., 0.2-209mm)

Below should be set to your maximum Z height. The two values should specify a range. 

That said, PrusaSlicer does insert a "safety" initial Z height of either 0.2mm OR your specified z-lift increment to attempt to protect against  dragging the nozzle across the bed.

If you're interested, we just had an in-depth discussion on this topic. You can see the testing & results here.

My notes and disclaimers on 3D printing and miscellaneous other tech projects
He is intelligent, but not experienced. His pattern indicates two dimensional thinking. -- Spock in Star Trek: The Wrath of Khan...
Posted : 27/08/2021 4:34 pm
xnaron
(@xnaron)
Active Member
Topic starter answered:
Only lift Z should specify a range (e.g., 0.2-209mm)

Thank you.  I will try that and checkout the details in the thread you linked.

Posted by: @bobstro

Below should be set to your maximum Z height. The two values should specify a range. 

That said, PrusaSlicer does insert a "safety" initial Z height of either 0.2mm OR your specified z-lift increment to attempt to protect against  dragging the nozzle across the bed.

If you're interested, we just had an in-depth discussion on this topic. You can see the testing & results here.

 

Posted : 27/08/2021 4:40 pm
Neophyl
(@neophyl)
Famed Member

You have them reversed.  Please read the tooltips .

Posted : 27/08/2021 4:42 pm
xnaron
(@xnaron)
Active Member
Topic starter answered:
I don't think so...

You are mistaken.  I did read the tool tips.  Above Z = if you set this to a positive value z lift will only take place above this.  Below Z = if you set this to a positive value Z lift will only take place below this.

Posted by: @neophyl

You have them reversed.  Please read the tooltips .

 

Posted : 27/08/2021 4:53 pm
xnaron
(@xnaron)
Active Member
Topic starter answered:
RE: This

What I did not do was set below z to a value to below z as I did not know that was required.

 

You are mistaken.  I did read the tool tips.  Above Z = if you set this to a positive value z lift will only take place above this.  Below Z = if you set this to a positive value Z lift will only take place below this.

Posted by: @neophyl

You have them reversed.  Please read the tooltips .

 

Posted by: @xnaron

You are mistaken.  I did read the tool tips.  Above Z = if you set this to a positive value z lift will only take place above this.  Below Z = if you set this to a positive value Z lift will only take place below this.

Posted by: @neophyl

You have them reversed.  Please read the tooltips .

 

 

This post was modified 3 months ago by xnaron
Posted : 27/08/2021 5:02 pm
Neophyl
(@neophyl)
Famed Member

You say you have below set to zero.  That should be set to the largest height that you want the z hop to work up to.  Setting that to zero is almost certain to cause the software issues as the RANGE you have defined is reversed, ie its going from a larger to a smaller number rather than the other way around.

Try setting Above Z to your 0.2 but Below Z to just below your maximum print height if you don't want to it z hop on the first layer but do on the rest.

Posted : 27/08/2021 5:05 pm
xnaron
(@xnaron)
Active Member
Topic starter answered:
Thanks

Yes thanks.  Bobstro pointed that out above.  Will try the range.

Posted by: @neophyl

You say you have below set to zero.  That should be set to the largest height that you want the z hop to work up to.  Setting that to zero is almost certain to cause the software issues as the RANGE you have defined is reversed, ie its going from a larger to a smaller number rather than the other way around.

Try setting Above Z to your 0.2 but Below Z to just below your maximum print height if you don't want to it z hop on the first layer but do on the rest.

 

Posted : 27/08/2021 5:07 pm
Neophyl
(@neophyl)
Famed Member

Sorry, I just tried it and if you don't want it to happen on your first layer then you have to set a value greater than the first layer height.  So for example if your layer height is 0.2mm and your first layer is also 0.2 then you need to set 0.4 for only above as a minimum for it not to z hop.

Posted : 27/08/2021 5:15 pm
xnaron
(@xnaron)
Active Member
Topic starter answered:
Thanks

Ok that is really good to know.  I'll try it.  Just in the middle of a 4 hour print.

Posted by: @neophyl

Sorry, I just tried it and if you don't want it to happen on your first layer then you have to set a value greater than the first layer height.  So for example if your layer height is 0.2mm and your first layer is also 0.2 then you need to set 0.4 for only above as a minimum for it not to z hop.

 

Posted : 27/08/2021 5:38 pm
bobstro
(@bobstro)
Illustrious Member
Clarification on 1st layer z height

Just to clarify what I wrote above:

"That said, PrusaSlicer does insert a "safety" initial Z height of either 0.2mm your set 1st layer height OR your specified z-lift increment to attempt to protect against dragging the nozzle across the bed."

The initial layer height inserted by PrusaSlicer after homing and before printing on the 1st layer will be EITHER your set 1st layer height OR your set z-lift height (not 1st layer height plus z-lift). Final adjustment to the 1st layer print height is made after the XY move.

 

My notes and disclaimers on 3D printing and miscellaneous other tech projects
He is intelligent, but not experienced. His pattern indicates two dimensional thinking. -- Spock in Star Trek: The Wrath of Khan...
Posted : 27/08/2021 8:30 pm
Share: