Memory/Ram running out when it's not even going up significantly?
 
Notifications
Clear all

Memory/Ram running out when it's not even going up significantly?  

  RSS
aztravis1
(@aztravis1)
Eminent Member
Memory/Ram running out when it's not even going up significantly?

Hi all,

So I've been getting this error when I'm trying to slice a helmet with prusaslicer (with a Creality CR-10 V3 printer profile if it matters):

"PrusaSlicer has encoutered an error. It was likely caused by running out of memory. If you are sure you have enough RAM on your system, this may also be a bug and we would be glad if you reported it. bad allocation"

It's pretty infuriating to say the least. I definitely have enough RAM (16GB), the file isn't even that big (25mb, I've sliced lithophanes 8x that size before just fine), so I can only assume this is some sort of bug. I brought up the task manager while attempting to slice it just to see what is being used and it never goes past 8 or so GB of RAM. I'm on the latest release (2.3.3), and outside of trying the Alpha 2.4.0 build, I really don't know what else to do. As this is a helmet, I greatly want to print it in one piece instead of cutting the .stl into smaller ones that can print, I've done that before and it's just a pain in the butt gluing and doing extra finishing work to get rid of seams. Any suggestions?

This topic was modified 4 months ago by aztravis1
Posted : 02/10/2021 7:29 am
Neophyl
(@neophyl)
Famed Member

Are you using the 32 or 64 bit software ?  Also which OS ?  I usually slice and print helmets as one piece too and so far I've not had an issue (both windows 7 and 10 with the 64 bit using versions from 1.47 on up.  I have seen a couple of github issues raised for the 32 bit software having out of memory issues.

I will say the current alphas slice way faster than 2.3.x though so certainly give them a try.  They use a different config folder location so you can run both in parallel without them effecting each other.  Just save your 2.3 config bundle out and then import it into the alpha to copy any custom profiles over.

Posted : 02/10/2021 11:17 am
aztravis1
(@aztravis1)
Eminent Member
Topic starter answered:
reply

 

Posted by: @neophyl

Are you using the 32 or 64 bit software ?  Also which OS ?  I usually slice and print helmets as one piece too and so far I've not had an issue (both windows 7 and 10 with the 64 bit using versions from 1.47 on up.  I have seen a couple of github issues raised for the 32 bit software having out of memory issues.

I will say the current alphas slice way faster than 2.3.x though so certainly give them a try.  They use a different config folder location so you can run both in parallel without them effecting each other.  Just save your 2.3 config bundle out and then import it into the alpha to copy any custom profiles over.

Thanks for the info, I double checked my prusaslicer and saw that both it was a 32 bit build (which made no sense since the PC is 64 bit, so no clue why it installed the other one) and that there was also a newer version for 2.3.3 that my older slicer version didn't bother mentioning as an update. So yeah, installed 2.3.3 and it slices fine now. Thanks!

Posted : 05/10/2021 5:49 am
Share: