incorrect slicing PrusaSlicer 2.3.0
 

incorrect slicing PrusaSlicer 2.3.0  

  RSS
Knaz
 knaz
(@knaz)
Active Member

Good day. The slicing process fails. One of the legs is 100% full. If I change the "perimeter" parameter from 4 to 3, then the model is sliced correctly.

This topic was modified 3 days ago by Knaz
Posted : 13/01/2021 9:06 am
Neophyl
(@neophyl)
Noble Member

How exactly does the slicing process fail, I cant make out what your actual issue is from your picture.  You don't provide what the original model is supposed to look like or anything else.  Is it missing parts ? have holes filled that aren't on the model ?   We would need a lot more information to figure out what the problem is.

Please save your project (File>Save as) as a 3mf file.  Then take the 3mf file produced and zip it into an archive and attach it here.  You MUST zip the file or the forum will not accept the file type.

Once we have your project we can slice it with exactly the same settings you are using.  Its the best way to debug issues like this.  I may have an idea of what's happening but need the 3mf to confirm.

Posted : 13/01/2021 9:26 am
Knaz
 knaz
(@knaz)
Active Member

@neophyl

one of the 4 legs inside the box is 100% full when cutting.

Posted : 13/01/2021 9:30 am
Neophyl
(@neophyl)
Noble Member

First of all, thank you for attaching the project.

It was as I suspected.  You have a solid infill threshold area value set.  It is set to 20mm/2.  For some reason slicer is picking up that feature out of the 4 as being below that value.  Why its not picking up the other 3 I don't know.  Its possible that the feature out of the 4 is fractionally smaller.  Without going into a lot more detailed analysis of the model itself I cant tell.  

Setting it to 19.9 and all 4 get normal infill.  Setting it to 19.95 and that one gets the solid infill again. 19.92 seems to be the tipping point.  The interesting thing is changing the parts placement rotation on the bed seems to effect the tipping point where it determines the area.

Posted : 13/01/2021 9:54 am
misan and Knaz liked
misan
(@misan)
Moderator

I have tested the area of your features. The values I get for the area of each is: 1.531, 1.528, 1.519, 1.529 cm^2. The third one is the smaller and the one the slicer closes with 100% infill when there are 4 perimeters. Even if you designed the four of them the same, the export to STL process created features that are not exactly the same. In order to do that I used Netfabb to create a slab so each feature is a different shell so its surface can be measured.

Posted : 13/01/2021 11:17 am
Neophyl
(@neophyl)
Noble Member

That would explain the difference is the threshold for the original issue. I've been bitten by the old default which was 70mm/2 which is why on my profiles I set it to zero.  Its why I looked for that value first too in the 3mf.

What I found interesting though is if you drop the solid infill point down to 19.92 the part gets normal infill so its evaluating it to be larger than that threshold.  But if you then rotate the part 90 degrees CCW it gets filled in will solid infill again.  The conclusion is rotating the part causes the area to be calculated differently. 

Posted : 13/01/2021 12:05 pm
Knaz
 knaz
(@knaz)
Active Member

Thanks everyone. Yes, the area can be different. If I change the "perimeter" value in the settings from 4 to 3, then the filling is the same for everyone. So is this the norm?

Posted : 13/01/2021 6:31 pm
misan
(@misan)
Moderator

@knaz

 

As more perimeters are placed, the inner hole shrinks, if it reaches a certain threshold, 100% infill is chosen instead of your selected value. The purpose of that is to make small features strong. That threshold is something you can change. Your assumption was the program was doing something odd. It is not, once you realize these features are of different sizes. If you want the four of them to get the same infill you can just select a value of 19 for the solid infill threshold and it will work with 4 perimeters as you expected.

Posted : 13/01/2021 6:55 pm
Knaz
 knaz
(@knaz)
Active Member

Very strange. This was not the case before.
I set it to 19% and the result is the same. 3 of 4. Some strange algorithm

Posted : 14/01/2021 4:41 am
misan
(@misan)
Moderator

@knaz

I am afraid you are changing the wrong setting. We are talking about the setting called "solid infill threshold area" which is measured in millimeters squared (not as a %, that suggests to me you are changing the infill instead).  Please note that the parameter only shows up in Expert mode (inside the 'Advanced' infill parameters section).

And the value can be zero, as in the image above.

This post was modified 2 days ago by misan
Posted : 14/01/2021 8:34 am
Knaz
 knaz
(@knaz)
Active Member

@misan

Thank you!

Posted : 14/01/2021 8:48 am
misan liked
Share:

Please Login or Register