Errors Building 2.3.0-alpha0 on Linux
 

[Solved] Errors Building 2.3.0-alpha0 on Linux  

  RSS
sdooweloc314
(@sdooweloc314)
Active Member

I am trying to build the latest alpha on Linux but am stuck on an error that I havent been able to find anything on. I have been working through dependency errors but seem to have gotten those taken care of. Now I am getting an error when it is trying to work with CGAL. I do see there is a CGAL.cmake file included but that doesnt seem to be what it is looking for. Any assistance would be appreciated. Or if more information is needed please let me know. I am on Ubuntu 20.04 LTS

-- SLIC3R_ASAN: OFF

-- SLIC3R_BUILD_SANDBOXES: OFF
-- SLIC3R_BUILD_TESTS: ON
-- SLIC3R_FHS: OFF
-- SLIC3R_GTK: 2
-- SLIC3R_GUI: ON
-- SLIC3R_MSVC_COMPILE_PARALLEL: ON
-- SLIC3R_MSVC_PDB: ON
-- SLIC3R_PCH: ON
-- SLIC3R_PERL_XS: OFF
-- SLIC3R_PROFILE: OFF
-- SLIC3R_STATIC: OFF
-- SLIC3R_WX_STABLE: OFF
-- SLIC3R_STATIC: OFF
-- CMAKE_PREFIX_PATH: (default)
-- Boost::boost exists
--   TBB_FOUND               = TRUE
--   TBB_INCLUDE_DIRS        = /usr/include
--   TBB_DEFINITIONS         =  
--   TBB_LIBRARIES           = /usr/lib/x86_64-linux-gnu/libtbb.so
--   TBB_DEFINITIONS_DEBUG   = TBB_USE_DEBUG=1
--   TBB_LIBRARIES_DEBUG     =  
--   TBB_DEFINITIONS_RELEASE =  
--   TBB_LIBRARIES_RELEASE   = /usr/lib/x86_64-linux-gnu/libtbb.so
-- Could NOT find Eigen3 (missing: EIGEN3_INCLUDE_DIR EIGEN3_VERSION_OK) (Required is at least version "3.3")
-- Could NOT find PNG (missing: PNG_LIBRARY PNG_PNG_INCLUDE_DIR)  
-- Could NOT find GLEW (missing: GLEW_INCLUDE_DIRS GLEW_LIBRARIES)  
-- GLEW not found, using bundled version.
-- Could NOT find cereal (missing: cereal_DIR)
-- Found NLopt in '/usr/lib/x86_64-linux-gnu'.
-- Using NLopt include directory '/usr/include'.
-- Using NLopt library '/usr/lib/x86_64-linux-gnu/libnlopt.so'.
-- Found OpenVDB: /usr/include (found suitable version "6.2.1", minimum required is "5.0") found components: openvdb  
CMake Warning at cmake/modules/OpenVDBUtils.cmake:129 (message):
 vdb_print not found! OPENVDB_PRINT-NOTFOUND
Call Stack (most recent call first):
 cmake/modules/FindOpenVDB.cmake:296 (OPENVDB_ABI_VERSION_FROM_PRINT)
 CMakeLists.txt:444 (find_package)


CMake Warning at cmake/modules/FindOpenVDB.cmake:303 (message):
 Unable to determine OpenVDB ABI version from OpenVDB installation.  The
 library major version "6" will be inferred.  If this is not correct, use
 add_definitions(-DOPENVDB_ABI_VERSION_NUMBER=N)
Call Stack (most recent call first):
 CMakeLists.txt:444 (find_package)


-- Falling back to IlmBase found by pkg-config...
-- Found Boost: /usr/lib/x86_64-linux-gnu/cmake/Boost-1.71.0/BoostConfig.cmake (found version "1.71.0") found components: iostreams system  
-- Performing Test HAVE_CXX_ATOMICS64_WITHOUT_LIB
-- Performing Test HAVE_CXX_ATOMICS64_WITHOUT_LIB - Success
-- Performing Test LLVM_HAS_ATOMICS
-- Performing Test LLVM_HAS_ATOMICS - Success
-- OpenVDB libraries: /usr/lib/x86_64-linux-gnu/libopenvdb.so
-- Miniz NOT found in system, using bundled version...
-- qhull Version: 7.2.0 (static linking)
-- IGL NOT found, using bundled version...
CMake Error at src/libslic3r/CMakeLists.txt:248 (find_package):
 By not providing "FindCGAL.cmake" in CMAKE_MODULE_PATH this project has
 asked CMake to find a package configuration file provided by "CGAL", but
 CMake did not find one.

 Could not find a package configuration file provided by "CGAL" with any of
 the following names:

   CGALConfig.cmake
   cgal-config.cmake

 Add the installation prefix of "CGAL" to CMAKE_PREFIX_PATH or set
 "CGAL_DIR" to a directory containing one of the above files.  If "CGAL"
 provides a separate development package or SDK, be sure it has been
 installed.


-- Configuring incomplete, errors occurred!
See also "/home/cole/Prusa/PrusaSlicer-master/Build/CMakeFiles/CMakeOutput.log".
See also "/home/cole/Prusa/PrusaSlicer-master/Build/CMakeFiles/CMakeError.log".

Best Answer by sdooweloc314:

Good News bad News. 

Good News is that I got past my CGAL error turns out I just needed to grab a different version. Too many different ones out there even on the official repos lol.

Bad News is that I am now stuck on wxWidgets. I have tried installing 3.0 and using the stable flag but got errors that

" Could NOT find wxWidgets (missing: wxWidgets_LIBRARIES
wxWidgets_INCLUDE_DIRS) (Required is at least version "3.0")"

Tried installing every different flavor of 3.1 and not using the stable flag but then I just get the "Could not find wxWidgets 3.1" message 

Posted : 15/07/2020 1:21 am
Area51
(@area51)
Prominent Member

When I compile the alpha on Linux Mint 19.3 (based on Ubuntu 18.04) the following installs is nessesary:

 # Install basic build tools:
sudo apt install build-essential
sudo apt install cmake

# Installing needed libraries
sudo apt install libgl1-mesa-dev
sudo apt install libglu1-mesa-dev
sudo apt install zlib1g-dev
sudo apt install libgtk2.0-dev # (Alternative for libgtk2.0-dev: libglib2.0-dev? Have not tried it)
sudo apt install libudev-dev
sudo apt install libdbus-1-dev

Could be that you are missing a library - I had trouble compiling and the error codes is kind of cryptic.

Have a look at my designs on Thingiverse or on PrusaPrinters ;)...
Posted : 15/07/2020 3:12 am
sdooweloc314
(@sdooweloc314)
Active Member

@area51

Thank you for the suggestion. I tried grabbing all of those packages but still getting the same error.

Posted : 15/07/2020 3:18 am
Area51
(@area51)
Prominent Member

@sdooweloc314

Could be an Ubuntu 20.04 specific problem. At the moment I have no Ubuntu 20.04 running to test on... Maybe other users here in the forum have tried to compile on that version.

Have a look at my designs on Thingiverse or on PrusaPrinters ;)...
Posted : 15/07/2020 3:30 pm
sdooweloc314
(@sdooweloc314)
Active Member

@area51

It could be. I am trying on my Arch based laptop now and it got past that section so something is either screwy with my install or with Ubuntu 20.04. Might try uninstalling and reinstalling CGAL after work

Posted : 15/07/2020 10:05 pm
sdooweloc314
(@sdooweloc314)
Active Member

Good News bad News. 

Good News is that I got past my CGAL error turns out I just needed to grab a different version. Too many different ones out there even on the official repos lol.

Bad News is that I am now stuck on wxWidgets. I have tried installing 3.0 and using the stable flag but got errors that

" Could NOT find wxWidgets (missing: wxWidgets_LIBRARIES
wxWidgets_INCLUDE_DIRS) (Required is at least version "3.0")"

Tried installing every different flavor of 3.1 and not using the stable flag but then I just get the "Could not find wxWidgets 3.1" message 

Posted : 16/07/2020 12:38 am
sdooweloc314
(@sdooweloc314)
Active Member

Well somehow I fixed it by purging all wxWidgets related things from my system and reinstalling each version individually while uninstalling the version when it didnt work and eventually one worked. 

 

I will be closing this as a result.

Posted : 17/07/2020 12:47 am
jsw
 jsw
(@jsw)
Noble Member

Could you please post exactly which one worked?

Posted : 17/07/2020 1:08 am
Area51
(@area51)
Prominent Member

@sdooweloc314

Happy that you got it to work.

Maybe you could list the libraries (like my list) you ended up installing to make it work - would be a great help for others trying to compile the alpha version on Ubuntu 20.04 LTS.

Have a look at my designs on Thingiverse or on PrusaPrinters ;)...
Posted : 17/07/2020 1:52 am
jsw liked
giles.bathgate
(@giles-bathgate)
New Member

I think you just need to install

libwxgtk3.0-gtk3-dev

and build with: 

cmake -DSLIC3R_WX_STABLE=1 -DSLIC3R_GTK=3 ..
This post was modified 8 months ago by giles.bathgate
Posted : 07/09/2020 7:07 pm
Anachronist
(@anachronist)
Estimable Member
Posted by: @giles-bathgate

I think you just need to install

libwxgtk3.0-gtk3-dev

and build with: 

cmake -DSLIC3R_WX_STABLE=1 -DSLIC3R_GTK=3 ..

Of all the advice in this thread, that last bit did it for me. Much appreciated.

-Alex

Posted : 21/02/2021 9:16 pm
Anachronist
(@anachronist)
Estimable Member

Now that cmake works, and I built the application with make, where is the executable? I can't find one, even though the last line output from make is

[100%] Built target PrusaSlicer"

'make install' tries to install it in a system directory, and I just want to test some modifications locally in my build directory from where I ran make.

 

This post was modified 3 months ago by Anachronist
Posted : 21/02/2021 10:02 pm
Share:

Please Login or Register