Elephant Foot Compensation Not Working
 
Notifications
Clear all

Elephant Foot Compensation Not Working  

  RSS
t5montecarlo
(@t5montecarlo)
Eminent Member
Elephant Foot Compensation Not Working

I am using PrusaSlicer 2.3 and Mk3S Firmware 3.9.3, though I had the same issue before updating PrusaSlicer and the firmware.

From another posting, I see that changes in the Elephant Foot Compensation will appear in the graphic of the sliced model.

No matter what value I choose for the elephant foot compensation, the image in PrusaSlicer and the printed model still have an elephant foot. Please see the 3 images, where I have chosen 0.0, 0.4, and 1.0 as values in the elephant foot compensation field, and the sliced model does not show the compensation. All 3 sliced images are the same, but you will see some subtle differences in values shown in the Legend in the upper left corner.

  1. Are there any conflicting settings that would cause the elephant foot compensation to be ignored?
  2. Please help me to understand why changes to the Elephant Foot Compensation don't appear in the sliced or printed model.
  3. Have I exposed a bug?

I have included an STL of the model, which is just a small portion of the bottom of the full model. There is already a chamfer on the bottom of the model, and the elephant foot creates a sharp edge when it prints because it sticks out.

My settings began with the standard settings for 0.15 mm Quality MK3, using the grey galaxy silver filament that came with the printer.  The following are changes from the base settings:

  • I changed perimeters between 2 and 4, with no change.
  • Minimum shell thickness has been changed, but I didn't change it directly; currently at 0.6. Was it changed automatically due to a change I made to another setting?
  • Detect bridging perimeters is enabled.
  • Seam position is set to Random.
  • Infill is set to 100%. The remaining Infill settings were changed automatically, when setting Infill to 100%.
  • I reduced all of the Speed For Print Moves by 80% (I don't know how to change the speed with a single setting).
  • Elephant Foot compensation changed to various values.
  • Label Objects is showing as a change, currently as deselected, but perhaps that is due to the updated version of PrusaSlicer?

The Filament setting is set to Prusament PLA.

The Printer setting is set to Original Prusa i3MK3S & MK3S+.

2 Perimeters and 0.0 Elephant Foot Compensation

2 Perimeters and 0.4 Elephant Foot Compensation

2 Perimeters and 1.0 Elephant Foot Compensation

 

 

This topic was modified 8 months ago by t5montecarlo
Prusa i3 MK3S Kit in Lack Enclosure...
Posted : 16/01/2021 8:18 pm
t5montecarlo
(@t5montecarlo)
Eminent Member
Topic starter answered:
RE: Elephant Foot Compensation Not Working

Update:

I no longer think there is a setting conflict, rather I have discovered that PrusaSlicer doesn't want to apply Elephant Foot Compensation to this model. The cause is the debossed text on the bottom of the model. If I cut the model (in PrusaSlicer) in such a way that the debossed text is no longer part of the model, the Elephant Foot Compensation is applied.

Have I found a bug?

Prusa i3 MK3S Kit in Lack Enclosure...
Posted : 18/01/2021 4:38 pm
t5montecarlo
(@t5montecarlo)
Eminent Member
Topic starter answered:
RE: Elephant Foot Compensation Not Working

Is this a bug?

The Elephant Foot Compensation feature won't work with the standard Benchy, either, which has debossed lettering on the bottom.

Prusa i3 MK3S Kit in Lack Enclosure...
Posted : 18/01/2021 10:37 pm
t5montecarlo
(@t5montecarlo)
Eminent Member
Topic starter answered:
RE: Elephant Foot Compensation Not Working When Bottom Layer Contains Engraved/Debossed Text

With the model I attached earlier, and with Benchy, PrusaSlicer is unable to make the first layer smaller when Elephant Foot Compensation is enabled.

Have I discovered a bug?

Prusa i3 MK3S Kit in Lack Enclosure...
Posted : 28/01/2021 1:45 am
Share: