Drastic over extrusion  

  RSS
M.J. Caboose
(@m-j-caboose)
Active Member

Hi there,

after I had several months without severe issues on  my MK3/S this weekend I had 3 times to disassemble the extruder to remove stuck PLA filament. Then I figured out, that the jam happened at the identical position of the model I was printing. In the third run I watched the printer when the exact position came again, and on the sudden the printer tries to push a huge amount of filament through the nozzle and after a few centimeters jammed again.

In the upper left corner you can see the jamming already ... the extruder motor still tries to push through the filament but fails.

There is no reason for this overextrusion I currently can think of.

Reslicing the object does not help ... same behaviour ...
The over extrusion already is visible in the G-Code Viewer as well as the slicer itself ...

The maximum extrusion set in the filament settings of the slicer is 15mm³/s though ... But with an 0.4 ruby nozzle this seems way to fast.

Nevertheless it leaves such an ammount of PLA on the print, that everything else is jamming into it. So I don't see the reason for it any other than an issue with the model. Did anybody else have similar experiences?

I attached the 3mf file in case somebody has fun analyzing the issue. The problem first occurs on layer 12 (1.3mm) at tool position x:127.95 y:101.63 according to the GCODE Viewer ....

And another question: Is it possible in the GCODE viewer to sync the position in the code with the position of the toolhead in the viewer? This would help to identify such effects on the code ...

This is no show stopper, but I will check all my GCODEs for max. extrusion volume to avoid jamming.

 

Best wishes,

Armin

- Made by me -...
Posted : 04/05/2021 12:10 pm
Neophyl
(@neophyl)
Famed Member

Not sure why that top solid infill is so wide when the extrusion width is set to be thinner than your normal extrusion at 0.4mm.  Its doing that width all over the place too on the slice.   Its 1mm wide according to the preview, no wonder its such a high volumetric.  Why its doing that with infill set to 0% I cant figure out.  Possibly a software bug with that combination of settings.  Changing to other settings like concentric infill at 95% results in more normal extrusion widths.  Personally if you really want it solid then setting rectilinear to 100% on infill still makes it slice as you want (as theres no infill anyway as your top/bottom layers cover the entire model) and it slices with correct widths.

However the max volumetric limits are a guide only, if you are having trouble actually extruding at that rate with your ruby nozzle then just set a lower value in either the filament profile or the print one.  15 is optimistic any way, my normal max for PLA is set to 12.  That's with a nozzle x.

Also a bit of unsolicited advice 🙂  Set your extruders min Layer height to 0.1 temporarily and then use the adaptive slicing.  No need to print all of what is basically a flat area at such a low layer height and if you set the extruders min to 0.1 it will only go down to that thickness on the adaptive.

Posted : 04/05/2021 3:12 pm
M.J. Caboose
(@m-j-caboose)
Active Member

The 0% infill was an error from my side though ... Since I am using semi-transparent filament I planned to set the bottom layer count to 30 ... but forgot.

It really seems to be an issue with some wired settings I was using ... I had several projects with identical settings and all showed the same problem. After starting from a basic filament profile and adapting one setting after the other until I got the main settings for the print everything worked out fine.

At the end it seemed to be a strange (and with the 0% infill unrealistic) setting that caused the problem ... Since now I am aware of this issue I can check the max. extrusion amount before exporting the GCODE ... as sonn as there is something above 5 or 6 mm³/s for 0.4 nozzle and PLA I can recheck before printing.

The hint with the adaptive printing as a good one 🙂  ... That'll save quite some time. Thanks.

- Made by me -...
Posted : 04/05/2021 8:19 pm
Neophyl
(@neophyl)
Famed Member

You can also choose to show the extrusion width on the preview. It seems this particular bug is using a 1mm wide extrusion when it expresses. Iirc 1mm is the maximum slicer does for some reason which is another reason I think it’s a bug. 

Posted : 04/05/2021 8:45 pm
bobstro
(@bobstro)
Illustrious Member

If you want to determine the maximum volumetric rate you can use with a specific nozzle, hotend, and filament combination, I've got some notes on a simplified process here. It will show you the maximum, but not necessarily the best, MVS setting you can use. I haven't heard much about the appropriate settings for a Ruby nozzle. PLA really doesn't like to be pushed hard, and I've limited mine to 11.5mm^3/s through a 0.4mm nozzle. 

Have you tried using monotonic top infill? It produces smoother top layers and may give you better results than concentric.

Even with top and bottom layers reduced, your print is essentially a slab, so infill shouldn't affect much.

@Neophyl - You can set extrusion widths > 1mm but PrusaSlicer insists on asking if you really mean a percentage rather than value. It's annoying when you're working with larger nozzle sizes. You have to answer "No" to indicate you mean what you input.

My notes and disclaimers on 3D printing and miscellaneous other tech projects
He is intelligent, but not experienced. His pattern indicates two dimensional thinking. -- Spock in Star Trek: The Wrath of Khan...
Posted : 04/05/2021 9:23 pm
Share:

Please Login or Register