Avoid solid infill near sloping walls
 

Avoid solid infill near sloping walls  

  RSS
gangyuan.j
(@gangyuan-j)
Active Member

3d benchy slice

 

3D benchy sliced with default 0.2mm Normal settings.

As shown in the image, there is a thin layer of solid infill near the sloping wall. Which setting can I change to remove the solid infill? Can I replace them with regular internal infill? They create a lot of vibration during printing.

 

Thanks

Posted : 06/04/2020 5:39 am
bobstro
(@bobstro)
Illustrious Member

Take a look at Print Settings->Layers and perimeters->Quality->Extra perimeters if necessary. Looking at your pic, I suspect it's enabled. Do be aware that disabling it may cause problems with sloping surfaces as it supports the overlaying layers.

My notes and disclaimers on 3D printing and miscellaneous other tech projects
He is intelligent, but not experienced. His pattern indicates two dimensional thinking. -- Spock in Star Trek: The Wrath of Khan...
Posted : 06/04/2020 6:35 am
gangyuan.j
(@gangyuan-j)
Active Member

@bobstro

No it is not enabled. I am using the default settings came with PrusaSlicer.

Just for the sake of trying, enabling it didn't help either.

Posted : 06/04/2020 8:03 am
ostrowski.rafal0
(@ostrowski-rafal0)
New Member

Hey, I am seeing same extra solid infill next to the walls of my models.

In my case the infill is added next to the "almost horizontal" walls (hard angle to print).

Would love to know how to get rid of that since with 3 perimeters set I am pretty sure the printer (mk3s) would handle the print with no issue.

Thanks for any help !

Posted : 03/08/2020 10:00 am
gangyuan.j
(@gangyuan-j)
Active Member

@ostrowski-rafal0

At the end I just gave up. The reason I was frustrated is because the vibration made my print fail much more easily. At the end, i realize it was because my set screw on the y axis motor was loose. After tightening it, I was able to print even this these weird infills. That been said, I did got an answer to my another post for the same question https://forum.prusaprinters.org/forum/prusaslicer/weird-solid-infill-for-chamfer/#post-233770

Maybe you can have a try and let us know if it helps?

Posted : 06/08/2020 8:39 pm
jerry.s3 liked
bobstro
(@bobstro)
Illustrious Member
Posted by: @ostrowski-rafal0

[...] In my case the infill is added next to the "almost horizontal" walls (hard angle to print).

Would love to know how to get rid of that since with 3 perimeters set I am pretty sure the printer (mk3s) would handle the print with no issue.

Flip the view around and see if those layers correspond to the blue overhang layers on the bottom. If so, that's the slicer warning you that those layers may be problematic. You can disable Print Settings->Layers and perimeters->Quality->Extra perimeters if needed to give it a try but the quality may be poor. You may also need support underneath to support those overhangs.

My notes and disclaimers on 3D printing and miscellaneous other tech projects
He is intelligent, but not experienced. His pattern indicates two dimensional thinking. -- Spock in Star Trek: The Wrath of Khan...
Posted : 06/08/2020 9:35 pm
Neophyl
(@neophyl)
Noble Member

So far I have found no way to stop that in either Prusa Slicer of Super Slicer. If the slope is too much it adds them. 

Posted : 06/08/2020 10:29 pm
gangyuan.j
(@gangyuan-j)
Active Member

@bobstro @neophyl

 

Thanks for the reply. That is what I originally thought too: it is meant to support the slope. But if you have a look at my original longer question here https://forum.prusaprinters.org/forum/prusaslicer/weird-solid-infill-for-chamfer/#post-206188

If I set the slope region to full 100% infill, (which got rid of the wiggled lines), but right after the 100% infill region, the wiggled lines will show up even that part is a vertical wall. I think that is a bug.

Posted : 06/08/2020 10:43 pm
Neophyl
(@neophyl)
Noble Member

@gangyuan-j

Quite probably.  The wiggly line is solid infill from the colour in the preview window so setting infill to zero does get rid of it.  Unfortunately it also gets rid of the normal infill which is , erm less than desirable as an option.  I would check on the github site for an existing issue and if not then open one and include all the details and pics you did in that other post thread.

https://github.com/prusa3d/PrusaSlicer/issues?q=is%3Aissue+is%3Aopen+sort%3Aupdated-desc

Posted : 07/08/2020 7:00 am
lafrad
(@lafrad)
New Member

I've just been bitten by this issue...    have a hemisphere on top of a print, and the wiggling got so violent that it detected a crash, and came back 1mm offset in the Y direction...   Not gonna work for what I'm doing... just sucks to find this issue 22 hours in :-/   

I've tried all the settings in this thread and cannot get it to generate the gcode without this violent shake....

Posted : 21/09/2020 11:42 pm
lafrad
(@lafrad)
New Member

Looks like a bug report is here: https://github.com/prusa3d/PrusaSlicer/issues/223

Posted : 22/09/2020 12:12 am
Area51
(@area51)
Honorable Member

To avoid a crash detection and dampening the wriggle, the Speed for print moves: Solid infill and Acceleration control: Infill could be lowered to slow down solid infill. Both settings is found in Print settings -> Speed in advanced mode.

It will not solve the problem, but maybe make it possible to print the model without a crash.

Have a look at my designs on Thingiverse or on PrusaPrinters ;)...
Posted : 22/09/2020 12:30 am
lafrad liked
gangyuan.j
(@gangyuan-j)
Active Member

@lafrad

Sorry to hear that. I know the pain... The fix for mine was to tighten all the set screws on motor shafts. You can also lower the printing speed and/or use 100 infill to mitigate the problem temporarily. 

Posted : 23/09/2020 12:03 am
Share:

Please Login or Register