Clear all

MMU2S problems  

New Member
MMU2S problems

after 7 years of operating a home built Prusa i2 and gaining a bit experience with tinkering by modifying it I was lately heading for a MK3s kit from Prusa, because the print quality I have seen from others convinced me. 

More out of curiosity I have also purchased the MMU2S kit. 

While the MK3s works great (in single color), the MMU2S turned out to be very problematic so far (looking at the forum I see that I am not alone with this experience!)

The 2-color sheep printed for about 20 mins, then the troubles started with a fail to load the next filament. It was pushed almost up to the extruder, but then was unable to push it through the bondtech gears. 

Since then I detected at least two other independent problems with the MMU2s, although I've put great care into the assembly and checked all  "usual suspects", such as IR sensor and FINDA calibration, orientation of PTFE tubes, IDLER motor shaft screws, IDLER screw tensions on MMUs and extruder, flashing the latest software on printer and MMU2s boards. I would be grateful for any hints that allowed me to tame this beast 🙂

Problem 1: after reset,  the MMU2s idler does only turn into the correct position when no filament is on the bondtech gear. If a filament is already inserted in slot 1, the idler rotation stops too early (unable to rotate further?), leading to falsely spitting out the filament in the neighboring slot 2. 

Problem 2: I shifted the filament through the selector unit such that the FINDA status changed to 1. Then I shifted the filament a few cm further into the PTFE tube. I heated up the extruder and selected "feed filament to nozzle". Then, sometimes the MMU2s pulley motor would shift the filament only about 10 cm towards extruder inside the PTFE tube, followed by pulling it back entirely. Sometimes the motor would immediately start with retracting the filament rather than pushing it into forward. Strangely, the printer doesn't seem to recognize this and after some useless extruder motor action asks if the "correct color was printed".  I've checked the IR sensor many times. Could this be a software bug?




Posted : 30/12/2020 11:56 am
New Member
Topic starter answered:
RE: MMU2S problems

OK, I think I solved the issues: 

1) one fault was indeed the IR sensor, although I've calibrated it twice before and it was seemingly working fine. So it's definitely worth finetuning again if the filament is not pushed fully towards the extruder. 

2) After fixing this I was facing countless filament jams like many other users: when retracting, when feeding forward, etc... I've noticed that it was always the same type of filament that was causing the problems: eSUN PLA, light blue.  I've tried a combination of Prusa's own Galaxy silver PLA and gold from Filamentum. Finally the two-color sheep was printing flawlessly. 

The eSUN filament is several years old. I am wondering if ageing does cause the problems? Maybe absorbing humidity over time and then swelling too much?




Posted : 01/01/2021 1:05 pm