MMU2 Looses (software) connection/communication to Mk3 Midprint
 

MMU2 Looses (software) connection/communication to Mk3 Midprint  

  RSS
martin.s60
(@martin-s60)
Active Member

I've only recently managed to get my MMU2 calibrated and I've run into a problem with my first main print.

I've printing something using the MMU2 in single mode -just to iron out issues, and about 2hrs into the first print the MMU2 lost connection with my Mk3.

By this I mean that the Mk3 suddenly is running in original software mode, not MMU2 software mode. This means that the extruders in the MMU2 stop moving -jamming the filament. So my Mk3 tried to keep pulling filament and cannot as it's trapped by the MMU2. I wasn't at the printer so when I got back the print had finished but it was an underextruded mess since the last few layers had no filament extruded. The screen said that the print had successfully finished.

I pulled out the orange PTFE tube from the main extruder head to see what had caused the issue and found the filament was still inside. So I tried to unload it and it didn't give me the MMU2 load/unload options, only the original Mk3 ones. Unloading it was just as the original Mk3 -it tried to push it out of the extruder head gears and that's all -the MMU didn't budge -still jamming the filament.

I reset my Mk3 (pressed the big X) and tried again -same result. No connection to MMU2.

So I powered it off, manually unloaded it, then powered it back on.

Now I get the MMU2 options again, so I load my filament back in, and start a print again -works fine....

So -has anyone else had this happen? Any idea of the cause? How can I stop it happening again?

Thanks

Posted : 09/12/2018 9:00 pm
andre.l9
(@andre-l9)
Estimable Member

I had this issue 3 times since I got my MMU in october, no idea where it came from, but look here https://github.com/prusa3d/Prusa-Firmware/issues/1377

Posted : 09/12/2018 9:40 pm
Share:

Please Login or Register