Filament unload: tips are too big and get stuck in the extruder
 

Filament unload: tips are too big and get stuck in the extruder  

  RSS
Newk
 Newk
(@newk)
Active Member

Hello,

I've had the MMU2S for quite some time and I hate the product by now. It is really not reliable at all. It ruins your reputation, Prusa.

The newest problem of months and months of ups and downs is one I really can't figure out at all anymore.

Filament tips like this get stuck in the extruder while unloading. The problem is worse with PLA than it is with PETG. It kind of seems like the gears squeeze the soft filament tip and then chew on it. Second theory is that the extruder gears work against the mmu motor while unloading because of some software error or something.

I've put countless hours into trying to fix this again:

  • I disassembled the hotend many times to clean it, check the oriantation of the stepper motor gears and so on...
  • I've changed the ptfe tube in the hotend two times and checked if there is any play between the tube and the hotend
  • I've changed the nozzle two times
  • I've cleaned the hotend fully
  • I've tried different filaments
  • I've flashed the firmware of the printer and the mmu

Does anyone have any advice?

This topic was modified 3 weeks ago by Newk
Posted : 18/04/2021 9:41 am
tsamisa@cytanet.com.cy
(@tsamisacytanet-com-cy)
Trusted Member

I had a similar problem. I live in a country with a hot summer (40 C) and the mmu and heat creep was negatively affecting mmu2s and overall the printer functionality. I guess prusa didn't keep in account that not every countries working temperatures are the same as in Czech Republic. Any way about the problem that you are facing it came down to the following for me.

1. Reduce printing speed by 5 to 10 percent. This really helped.

2. Heat creep is an issue with their extruder design. Gears connected directly to the motor overheat and cause the filament to soften. At first i printed an attachment for the extruder motor that would allow an additional fan to be mounted. Similar to the the small one that is located to the site of their extruder. There is a free slot in their board that accommodate this. But the fan is always on. The situation was improved but not solved. So i changed the default extruder to a geared bondtech one that did a hell of a difference. If i'm not mistaken prusa remedied this problematic extruder design in their mini.

3.I found after a mishap with the cooling fan that if the heatsink is not properly cooled then the filament expands and get stuck in the heatbreak which in the case of prusa is a custom design to help with mmu2s functionality. Next time i will need to change it ill try the default one from e3d that it doesn't get narrower in the middle.

All the above was a result of heat. I dont see the tip of your filament to be "bloaded" so my guess is heat creep. Are there any strong grinding marks that caused thinning on your filament? If not then try to tight the extruder screw a bit to add more grip. 

Posted : 18/04/2021 10:19 am
Newk liked
Newk
 Newk
(@newk)
Active Member

Thanks for your reply!

I'm testing the functionality with the buildin programms for "load to nozzle" and "unload filament". This does not allow me to make the change you mentioned in 1.

Heat creep was never a problem. I have done lots of big MMU prints.  I've tried everything with the extruder screw already. I can normally troubleshoot the MMU and extruder easily, but this bad tip thing is out of my understanding.

On the left you see the old mk3s design and on the right there is the newer mk3s+ one.

What someone needs to explain to me is this change in the +-Upgrade. The old extruder body and motor plate did have a bigger hole for the filament. It seems to have been purposly made smaller. In this area my filament gets stuck.

It may not be the cause of my problem because, yes, I have these bad tips all of a sudden but it certainly doesn't help with the MMU when your filament will be changed all the time...

Posted : 19/04/2021 7:30 am
HarrySatt
(@harrysatt)
Eminent Member

Hi there

Which filament are you using. I run the MMU2 with PETG but with slightly higher nozzle temperature (250) than the standard values in the slicer. For me it works fine. Maybe fiddling around with 2nd layer temp helps

Regards, Harald

Posted : 07/05/2021 9:05 am
Share:

Please Login or Register