Blade-holder is no longer holding the blade  

  RSS
abailey
(@abailey)
New Member

On a recent print I had the MMU beeping at me and upon inspection, the blade had come loose of the holder and had been forced down, cutting into, the mmu2-front-PTFE-holder part, and jamming the selector from moving. After taking it apart and refitting the blade using the very slight indent, putting it back, resuming the print, it got caught again and the blade slipped out of the holder. As a result of the blade coming out, the single layer used to guide the locating of the blade has been worn away and there is now easy movement of the blade even when screwed down tight.

So, in general the blade has done very little work over the last year or so, cutting off perhaps five pieces. And I was able to resume the print with no issues. It doesn't feel necessary when I am supervising a print, but thru this process of resolving it, twice some filament got out of say hole 1 while the selector was shifting or at say hole 4 and I discovered why the blade was included.

Apart from printing a new mmu2-front-PTFE-holder and selector part, is there a better solution?

Posted : 26/03/2020 7:40 pm
Lichtjaeger
(@lichtjaeger)
Prominent Member

Do you use the old R1 (or M1) parts or did you upgrade to the new R2 parts (look for the dates)?

IMO the new parts are holding the blade way better.

Posted : 26/03/2020 8:03 pm
abailey
(@abailey)
New Member

We got the MMU2 in May '19 and haven't upgraded any parts, so I'd assume R1. Based on the link you provided, I should reprint the selector, front PTFE and blade holder parts. Any other recommended upgrades?

Posted : 26/03/2020 9:39 pm
Karl Herbert
(@karl-herbert)
Noble Member

@abailey

https://grabcad.com/library/mmu2-mmu2s-multi-material-unit-v2-3-1

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 27/03/2020 1:28 am
Share:

Please Login or Register