Notifications
Clear all

All five flashing red/green.  

  RSS
Garion
(@garion)
New Member
All five flashing red/green.

Hi all.. My MMU, when it works, works great.. So I dont have an issue with tension or sensors. But I have the somewhat common issue of the "all five LEDs flashing red and green" on a regular basis.

Sometimes it happens trying to load a filament after startup. I power on the printer, let the MMU go through its 2 cycles of booting (why? I dont know, thats what it does), then via the printer menu (MK3S), I try to load a filament, in this case, filament 2. The MMU does its thing to align the idler, moves the selector past 5, then back to one, then to 2, as expected, then all the leds blink. It does this 3 times.

Most the posts about this say its a power problem.. My connections are nice and tight, the 'tongs' are the right way, etc.

So I decided to mod the firmware for when it detects the error. In the tmc2130_read_gstat function, I send the result to the USB serial, along with DRV_STATUS if needed. You can see my changes here: https://github.com/garionphx/MM-control-01/pull/1/files

Heres the results. Mostly getting "reset since last read" errors,  though on the 2 axis (the ilder), gets some odd results. First column is the axis (0=pully, 1=selector, and 2=idler). Next column is the result from reading GSTAT, displaying only the first 3 bits. If there's a 3rd column, its the result from reading the DRV_STATUS (if bit 1 was set in GSTAT). 
0: 01
1: 01
2: 07 fffc07ff
0: 01
1: 01
2: 07 ffffffff
0: 01
1: 01
2: 01

Why are am I getting these resets? Could it be a design flaw? 

Posted : 22/11/2020 12:13 am
Dutch
(@dutch)
Active Member
RE: All five flashing red/green.

leeching topic, as i have often green/red blinking all 5 as well.

 

...
Posted : 22/11/2020 10:02 am
Herbert
(@herbert-2)
Active Member
RE: All five flashing red/green.

are you in stealth mode ? Since i turn to normal mode i hade no more issus, with red and green flashing LED´s

mfg Herbert...
Posted : 23/11/2020 9:16 am
Garion
(@garion)
New Member
Topic starter answered:
RE: All five flashing red/green.
Posted by: @herbert-2

are you in stealth mode ? Since i turn to normal mode i hade no more issus, with red and green flashing LED´s

Normal mode.

Posted : 23/11/2020 10:55 pm
lcdguy
(@lcdguy)
Eminent Member
RE: All five flashing red/green.

i was also getting these a lot when running the printer on 3.9.2

I since downgraded to 3.9.1 and also replugged both the ir sensor and mmu2s cable on einsy to ensure they were nice and tight, hasn't happened again since. Maybe something to try and see if you get a different result.

Posted : 04/12/2020 1:22 pm
Heine Mau
(@heine-mau)
Active Member
RE: All five flashing red/green.

Brilliant idea 🙂  That is EXACTLY what we need.

It is sooo frustrating to reset the MMU 10 times and not now if it will work this time or in 10 more resets....

 

So i connected the MMU to my pc and fired up a terminal program on that port - and the it started working rather well. No new FW, simply a connection to a PC.

it might be a faulty powersupply design on the MMU that gives you the resets (as you suggest)

As the MMU has a pretty solid +24V supply, i am pretty sure that this is an faulty (weak) power supply design on the MMU board.

 

Posted : 18/01/2021 1:23 am
Share: