Locking up Mk 3S after removal of MMU2S  

Eminent Member

Had an interesting occurrence today which I have resolved though I’m curious if anyone else has had the problem. 

Basically I removed the MMU2S due to endless problems despite several months of mods and upgrades failures and bizarre Unexplainable actions by the MMU2S.  My removal technique was as described by a number of people - simply disconnect the power cable to the MMU2S and feed the filament directly into the extruded head. 

It worked well for a few days. Then this morning ( after finishing a long print during the night ) it had the opening screen on the LCD but was locked.  Nothing  would change with any button presses. Same screen returned with turning off and on, depowering etc. 

Since it was due to upgrade FW to 3.9.0 I tried that. prusaSlicer could tell the i3 was attached via com port 3 but failed to connect with the flash. Eventually I reconnected the MMU2S and it now booted up normally. 

so with the MMU2S attached I retried to Flash the FW and it worked straight off, first time no problem.  

Then with the new FW insitu I removed the MMU2S power cord and it runs normally as an Mk 3S again.  ( Wondering how long it will take before it locks up again)


Anyway just a bit of info for anyone who is considering removing the MMU2S. 

Posted : 17/06/2020 6:23 am

Please Login or Register