Notifications
Clear all

idler stepper motor loosing steps?  

  RSS
qczek
(@qczek)
New Member
idler stepper motor loosing steps?

Hi,

I just build MMU2S and in the middle of maiden colour print one filament load failed. I checked how it's end and it was ok, trying several times pressing middle button did not resolve the issue. I remove two screws with spring from idler body to check what is wrong, and everything was ok, i would be able to push filament manually, no problem. I closed it and noticed that during loading the bearing which should press filament is in wrong position, cause idler is in wrong position, let say 3 degs too up...

I reset the printer and choose filament load, to check if it's connected to idler position... and it's the filament was loaded without problem.

So it looks that sometimes idler stepper motor lose steps.... simplest solution is to zero it's position every time loaad/unload problem occur. 

What do you think, can you implement it in next firmware release?

Kris

 

Posted : 28/06/2019 3:28 pm
gnat
 gnat
(@gnat)
Noble Member
RE: idler stepper motor loosing steps?

Yes some of us have noticed the MMU "losing it's mind" and the idler and selector get out of sync. Rather than resetting the whole printer (and terminating the print) you can use the reset button next to the USB port on the MMU to reset just the MMU itself. Many times that will get it back on track and you can continue with the current print.

As to the actual cause, I haven't seen anyone report digging into it to try to figure out where the issue might be.

MMU tips and troubleshooting
Stop SL1 tank leaks with a simple o-ring...
Posted : 28/06/2019 3:52 pm
Badgeman
(@badgeman)
New Member
RE: idler stepper motor loosing steps?

Unfortunately i have the exact same issue. It started after having several successfull prints, and now it ruins every single print. If i manually change filaments etc. there is never an issue.

 

Furthermore, as soon as the filament is started to load and triggers the FINDA (LED changs from red to off), the filament is pulled backwards and stops again if it is outside of the FINDA... It is repeated, when i push any button of the MMU.

Posted : 28/06/2019 7:28 pm
Nikolai
(@nikolai)
Noble Member
RE: idler stepper motor loosing steps?

There are multiple different issues possible.

  • Mechanical: Motor is spinning correct but the idler is not following. Sometimes the bolts are not tight enough or wrong mounted. Or once motor heats up, it slips through. Or there is too much mechanical resistance ...
  • Electrical: Like some wires loosing connection or broken wires
  • Firmware: Issues were reported were MMU2 and the printer are out of sync. Or MMU2 is loosing a correct state.

I would start in the described order to search for issues. Especially if it's not working constantly and very often then most likely there is some kind of mechanical issue.

Often linked posts:
Going small with MMU2
Real Multi Material
My prints on Instagram...
Posted : 28/06/2019 8:52 pm
CybrSage liked
Badgeman
(@badgeman)
New Member
RE: idler stepper motor loosing steps?

Good news everyone, I was able to solve the issue.

Reinstalling again the firmware from printer and MMU and then (important!) a power cycle helped to solve the issue. Finally I am printing again. Thanks!

Posted : 28/06/2019 10:23 pm
CybrSage liked
Share: