Notifications
Clear all

Firmware 1.0.5 for the MMU2S and MMU2 unit  

Page 1 / 2
  RSS
Jakub Dolezal
(@jakub-dolezal-2)
Admin
Firmware 1.0.5 for the MMU2S and MMU2 unit

Hi guys,
this is an upgrade of the firmware for the MMU2 control board inside the multi-material unit. This is a final stable version.

What is new?
-> MK3S and MK2.5S improvement

MK3S and MK2.5S improvement:
This FW version improves MMU2S unit function when used with MK3S and MK2.5S printers with IR sensor. Especially T-code filament loading phase reliability was improved. It is now possible to resume print after MMU load fail detected by printer also by MMU button.
---

Supported printers:
Original Prusa i3 MK3S MMU2S
Original Prusa i3 MK2.5S MMU2S

Original Prusa i3 MK3 MMU2
Original Prusa i3 MK2.5 MMU2

Download link:
https://www.prusa3d.com/drivers/

Firmware flashing guide:
https://manual.prusa3d.com/Guide/Upgrading+the+firmware+v1.5/66
Note: Use Slic3r PE 1.41.2 or latest to flash the MMU2 control board

Please report any bug here:
https://github.com/prusa3d/MM-control-01/issues

We wish you a successful calibration and look forward to your feedback!

Assembly manuals / Knowledge Base
The guy behind Prusa assembly manuals......
Posted : 04/03/2019 2:22 pm
BunchaHooey
(@bunchahooey)
Eminent Member
Re: Firmware 1.0.5 for the MMU2S and MMU2 unit

So, I just installed 1.0.5, now my MMU keeps loading and loading and loading. I loads up to the nozzle and just doesn't stop. It does this after homing Z, so all that plastic oozed out, smashed against the magnetic bed and covered my extruder, which was really fun to clean. I tried again and SAME THING! What is going on!?

...
Posted : 04/03/2019 10:39 pm
FaultyLine
(@faultyline)
Trusted Member
Re: Firmware 1.0.5 for the MMU2S and MMU2 unit

Ooffff, that's unfortunate. Did you post that on the GitHub forums for the developers to read? I take it you've already tried to reflash the MMU2 board?

...
Posted : 05/03/2019 7:09 am
PJR
 PJR
(@pjr)
Moderator
Re: Firmware 1.0.5 for the MMU2S and MMU2 unit


So, I just installed 1.0.5, now my MMU keeps loading and loading and loading. I loads up to the nozzle and just doesn't stop. It does this after homing Z, so all that plastic oozed out, smashed against the magnetic bed and covered my extruder, which was really fun to clean. I tried again and SAME THING! What is going on!?

That indicates that the IR sensor is not being triggered by the Bondtech idler door. Check the status of the IR sensor on the LCD; make sure the status changes when filament is pushed into the Bondtech.

I presume you wired up the IR sensor correctly?

Peter

Please note: I do not have any affiliation with Prusa Research. Any advices given are offered in good faith. It is your responsibility to ensure that by following my advice you do not suffer or cause injury, damage…...
Posted : 05/03/2019 10:35 am
BunchaHooey
(@bunchahooey)
Eminent Member
Re: Firmware 1.0.5 for the MMU2S and MMU2 unit

Thanks for all of your replies! Now, is my face red 😳 ... I installed the MMU2S firmware, which was, of course, incorrect. Once I put in the correct non-s firmware it started working again. I am wondering why it behaved the way it did though since the filament sensor was disabled in the firmware, but that's neither here nor there.

...
Posted : 05/03/2019 2:54 pm
PJR
 PJR
(@pjr)
Moderator
Re: Firmware 1.0.5 for the MMU2S and MMU2 unit


I am wondering why it behaved the way it did though since the filament sensor was disabled in the firmware

The "S" version relies on the IR sensor to stop the MMU feed. If it's not there, the feed simply will not stop.

Peter

Please note: I do not have any affiliation with Prusa Research. Any advices given are offered in good faith. It is your responsibility to ensure that by following my advice you do not suffer or cause injury, damage…...
Posted : 05/03/2019 4:07 pm
BunchaHooey
(@bunchahooey)
Eminent Member
Re: Firmware 1.0.5 for the MMU2S and MMU2 unit

Well since I polluted the forum with a non-issue I feel it's necessary to actually contribute now.

I LOVE the auto-preheat when unloading filament! This saves me another trip to the printer and quite a bit of waiting. I do wish there was an option for allowing cool down after the unload is complete, because in this case I still need to wait around for the unload and then manually select 'cooldown' from the preheat menu. Perhaps after selecting the 'preheat' setting an optional dialog could appear that asks 'Cooldown after unload? Y/N'. The dialog could default to either 'Yes' or 'No' if no user input is provided. The default could be pre-set, or you could provide an option for this somewhere, or even disable the dialog entirely.

Anything that prevents yet another trip to the printer is a huge plus in my book, so thanks for this feature.

...
Posted : 05/03/2019 5:24 pm
richard.l
(@richard-l)
Moderator
Re: Firmware 1.0.5 for the MMU2S and MMU2 unit

Can I ask a, why was the auto-preheat added to the Filament Load procedure? It makes sense on the Load to Nozzle function but when loading the filament in the MMU2 it never even reaches the extruder. There are many more times than not that I will load filament and not print for more than an hour, mainly to make sure I have the correct colors loaded for my print so I can then tell Slic3R what extruders to use.

...
Posted : 05/03/2019 6:15 pm
IgnacioHR
(@ignaciohr)
Eminent Member
Re: Firmware 1.0.5 for the MMU2S and MMU2 unit


Can I ask a, why was the auto-preheat added to the Filament Load procedure? It makes sense on the Load to Nozzle function but when loading the filament in the MMU2 it never even reaches the extruder. There are many more times than not that I will load filament and not print for more than an hour, mainly to make sure I have the correct colors loaded for my print so I can then tell Slic3R what extruders to use.

+1

I'm on the same page, pre-heat when loading to the mmu2 is just a waste of energy

Posted : 06/03/2019 12:06 am
sean.k10
(@sean-k10)
Active Member
Re: Firmware 1.0.5 for the MMU2S and MMU2 unit

I have tried to update my mk3/mmu2 to the last 2 firmware releases 3.5.2/1.04 and 3.6/1.05 on both occasions the printer fails with the same symptoms and I have had to revert to the previous Firmware 3.5.1/1.03 and the printer works fine. With the update everything calibrates fine and I start a print , during the first couple of layers the printer just resets and stops, it is as though the printer has just been turned on. I have tried several different models with the same result each time. There are no error messages.

Posted : 08/03/2019 1:22 pm
Protoncek
(@protoncek)
Reputable Member
Re: Firmware 1.0.5 for the MMU2S and MMU2 unit


Can I ask a, why was the auto-preheat added to the Filament Load procedure? It makes sense on the Load to Nozzle function but when loading the filament in the MMU2 it never even reaches the extruder. There are many more times than not that I will load filament and not print for more than an hour, mainly to make sure I have the correct colors loaded for my print so I can then tell Slic3R what extruders to use.

I guess because many (and i mean MANY) of Prusa owners don't have MMU extension unit, but just plain single-color printer...

I love this function, too. Quite a few clicks quicker.

Posted : 18/03/2019 11:21 am
Pontalunatic
(@pontalunatic)
Active Member
Re: Firmware 1.0.5 for the MMU2S and MMU2 unit

How do you check the status of the IR sensor? I had to backtrack to 3.5.1 and 1.03 to stop the load filament process ramming gobs of filament thru the nozzle in 3.0.6. That earlier firmware combo made this go away likely because the filament sensor is being ignored in those. I would like to install the 3.7.0 and 1.05 but I can't have this happening all over again. If I do have a problem in my sensor does anyone know how to fix it or debug the problem?

Posted : 18/03/2019 12:17 pm
PJR
 PJR
(@pjr)
Moderator
Re: Firmware 1.0.5 for the MMU2S and MMU2 unit


How do you check the status of the IR sensor?

LCD Menu/Support. Scroll down to "Sensor Info" and click.

Peter

Please note: I do not have any affiliation with Prusa Research. Any advices given are offered in good faith. It is your responsibility to ensure that by following my advice you do not suffer or cause injury, damage…...
Posted : 18/03/2019 1:53 pm
Pontalunatic
(@pontalunatic)
Active Member
Re: Firmware 1.0.5 for the MMU2S and MMU2 unit

Thanks. I had to reload 3.6.0 / 1.05 to get the menu for those in my boat. That confirmed it has to do with the sensor and this firmware because in 3.5.1 / 1.03 it does not do this. I confirmed that my sensor is not triggering when the filament is present (Finda is though).

It sounds like a few had this same thing. What was done to fix it? Bad sensor or mechanical? I can see the tab on the door lever is between the "U" shaped sensor opening. I tried increasing tension as I had it pretty light to not grind filament during load. I recall there was very little rotation of that lever because of its length from the pivot I wondered about this when I assembled the upgrade. I do recall a mention of this producing little motion. I also recall thinking about how sketchy the board and cover fit together. It's held with one central screw and hardly a ridge to locate.

I am a little uncertain about how the board connects to the controller. The installation instructions I was using online didn't have a picture so I placed it where the original optical sensor was. Perhaps I have it plugged in backwards there. If anyone has a picture/schematic of a working plug orientation could you post it.

Posted : 19/03/2019 12:22 pm
PJR
 PJR
(@pjr)
Moderator
Re: Firmware 1.0.5 for the MMU2S and MMU2 unit


I am a little uncertain about how the board connects to the controller. The installation instructions I was using online didn't have a picture so I placed it where the original optical sensor was. Perhaps I have it plugged in backwards there. If anyone has a picture/schematic of a working plug orientation could you post it.

Step 24 in the manual; second picture:

And IR trigger calibration here: https://prusa3d.com/downloads/manual/prusa3d_manual_mmu2s_eng_1_00.pdf?2

Peter

Please note: I do not have any affiliation with Prusa Research. Any advices given are offered in good faith. It is your responsibility to ensure that by following my advice you do not suffer or cause injury, damage…...
Posted : 19/03/2019 5:30 pm
Pontalunatic
(@pontalunatic)
Active Member
Re: Firmware 1.0.5 for the MMU2S and MMU2 unit

Thanks. I'm going to have to see if I printed one of those fool-proof rings with all the other parts. I recall having some leftover printed parts because the g-code files (the one with all the relevant parts all at once) supported the MK2.5S and ones without MMU2. Maybe I disregarded that part for one of those. It's a good addition to fool-proof plugging things - that slot being too large for the connectors. I'll confirm my wiring looks like that and that the wires are correct. If not I suppose I either have a bad sensor or I don't know what else.

Posted : 20/03/2019 2:26 pm
Dutchy
(@dutchy)
Eminent Member
Re: Firmware 1.0.5 for the MMU2S and MMU2 unit

Hi,

I'd like to do single color print but I want to select the channel I want not just channel 1.

Posted : 22/03/2019 4:15 pm
toaf
 toaf
(@toaf)
Noble Member
Re: Firmware 1.0.5 for the MMU2S and MMU2 unit

any chance they can turn on the 2nd filament sensor with just the mmu2 (not S) seems a shame to have to wait longer for this basic function. I understand some people have issues with the sensor, but some of us don't. unless its a memory issue or something...that I could understand.

I have a Prusa,therefore I research....
Posted : 25/03/2019 7:01 am
Pintie
(@pintie)
Eminent Member
Re: Firmware 1.0.5 for the MMU2S and MMU2 unit

where can i find the FW 1.0.5 for MMU2S ?

in the ZIP from here https://www.prusa3d.com/drivers/

there is only the 1.0.5 for MMU2 not MMU2s

but it still works.
i now have mk3s+mmu2s with 3.7.0-RC1 + 1.0.5 and everything seems to work like it should

Posted : 27/03/2019 5:40 pm
TOTO
 TOTO
(@toto-2)
Eminent Member
Re: Firmware 1.0.5 for the MMU2S and MMU2 unit

Are there (there are) several sub-versions of the 1.05 firmware?
I've just flashed the 3.7.0-2201 (released April 1) to my printer and did the same with the also included 1.05 for the MMU.
Version of the MMU was 1.0.5-300 prior to the update. Now it's showing 1.0.5-297.
Where can I get/download the 1.0.5-300 or newer version?

Posted : 02/04/2019 6:50 am
Page 1 / 2
Share: