Notifications
Clear all

Firmware 1.0.3 for the MMU2 unit  

Page 2 / 3
  RSS
thomas.c4
(@thomas-c4)
Active Member
Re: Firmware 1.0.3 for the MMU2 unit

Is this speed change only happening when a filament change occurs? Meaning, it doesn't happen when a synchronized layer is printed on the wipe tower for scaffolding purposes but only during purge/prime events?

Couldn't you use the "after filament change" or "before filament change" box in the specific extruder's settings to enter an M220 Sx (x = the percentage of speed you want that extruder to print)?

Not sure if you would use before or after because I'm not sure where this automatic change occurs. Shouldn't be terribly difficult to see in the output gcode though. Just open with wordpad and find M220.

Tom Cole...
Posted : 23/12/2018 3:53 pm
Incalculable
(@incalculable)
Eminent Member
Re: Firmware 1.0.3 for the MMU2 unit

Hi all,

For me 1.0.3 does not work on a mk2.5 with MMU 2.0.

Upon startup I do have no homing at all. After selecting „Load filament“ the selector drives all the way to the left, grinds there and stops. This results in the selector position being too far left, so when I then try to load filament it blocks at selector entry.

I tried a factory reset, reflashing etc, but no help.

I now downgraded to 1.0.2 and have no problem what so ever.

Am I the only one with this problem? Any suggestions?

Rgds Vinc

...
Posted : 23/12/2018 5:00 pm
JuanCholo
(@juancholo)
Reputable Member
Re: Firmware 1.0.3 for the MMU2 unit

1.0.3 is no longer homing the MMU2 on startup. when i start to use the MMU2 then it does a homing routine.

“One does not simply use a picture as signature on Prusa forums”...
Posted : 24/12/2018 2:57 am
Nikolai
(@nikolai)
Noble Member
Re: Firmware 1.0.3 for the MMU2 unit


1.0.3 is no longer homing the MMU2 on startup. when i start to use the MMU2 then it does a homing routine.

It depends. Sometimes it homes the revolver but not the selector during start-up. Then if I start to print, it homes the selector. Maybe a dev. can shade a light in the new homing logic.

Often linked posts:
Going small with MMU2
Real Multi Material
My prints on Instagram...
Posted : 24/12/2018 3:08 am
Feliceg29
(@feliceg29)
New Member
Re: Firmware 1.0.3 for the MMU2 unit

My MMU2 is doing the same thing No calibration on power up or reboot. It does a partial calibration at a load filament call. Is this what it should do? It's a lot quieter now

...
Posted : 24/12/2018 4:35 am
joreal
(@joreal)
Estimable Member
Re: Firmware 1.0.3 for the MMU2 unit

I noticed my selector shifted to the left by around 1mm after updating. I can say it shifted because I put dot marks (1.0.2) on my MMU to indicate the current input. I did not encounter any problem during loading probably due to the enlargement of hole I made. I will see tomorrow when I print something.

...
Posted : 24/12/2018 9:16 am
Incalculable
(@incalculable)
Eminent Member
Re: Firmware 1.0.3 for the MMU2 unit

Hi Joreal,

Yes, this shift to the left causes the problem. Can the selector position be calibrated? I can’t find it in the troubleshooting section...

Previously the selector homes to the right and went left to final position.
Now using 1.0.3 it always goes left, grinds, and stops 1mm to far to the left, causing jams..?!

...
Posted : 24/12/2018 9:29 am
joreal
(@joreal)
Estimable Member
Re: Firmware 1.0.3 for the MMU2 unit

To give other people idea how much shift after update, I attached this one:

...
Posted : 24/12/2018 2:13 pm
Colin
(@colin-4)
Estimable Member
Re: Firmware 1.0.3 for the MMU2 unit

I wonder if this explains the loading issues I've had since I upgraded to 1.0.3. I've gone back to 3.5.0 and 1.0.2 for now.

Posted : 24/12/2018 2:18 pm
joreal
(@joreal)
Estimable Member
Re: Firmware 1.0.3 for the MMU2 unit

I did not encounter any jamming with this shifted selector. Probably because I enlarged the input hole of my selector.

...
Posted : 24/12/2018 3:03 pm
Incalculable
(@incalculable)
Eminent Member
Re: Firmware 1.0.3 for the MMU2 unit

Its nevertheless incorrect behavior of the system, as the selector should be lined up with the holes..

...
Posted : 24/12/2018 3:22 pm
joreal
(@joreal)
Estimable Member
Re: Firmware 1.0.3 for the MMU2 unit

I agree with you but mine is really running without jam until now. I'm expecting my filament will jam into the input of my selector. Mine is very strange. Im printing key chains for Christmas giveaway. 0.2 layer height. First 3mm uses filament 1 and 4 then beyond that are filament 2 and 3.

My selector still shifted during print.

By the way, BEFORE I used 2.0mm drill bit to enlarge the input hole of my MMU selector. This might be the reason why my selector can tolerate such shifting.

Before I started this keychains, I printed out 4 color cubes to check my MMU. Totally ZERO jam.

...
Posted : 24/12/2018 4:54 pm
Mirar
(@mirar)
Estimable Member
Re: Firmware 1.0.3 for the MMU2 unit

I will experiment with this when I get home to the printer. What's a safe way of triggering the issue?

Posted : 24/12/2018 10:17 pm
Incalculable
(@incalculable)
Eminent Member
Re: Firmware 1.0.3 for the MMU2 unit

Just mark selector position after homing, install firmware version 1.0.3 on the MMU, load filament (MMU will home) and compare selector position to previously marked position. Mine is more to the left causing filament to jam in the selector.

...
Posted : 25/12/2018 12:21 am
heiko.s
(@heiko-s)
New Member
Re: Firmware 1.0.3 for the MMU2 unit

following the models and assemble them in openscad there is a gap of 1.0mm in design



translate([0,-30,0])
import("mmu2-pulley-body.stl");

translate([0,-30,24])
rotate([0,180,0])
import("mmu2-idler-body.stl");

translate([-57+1,-35,0])
rotate([-90,0,0])
import("mmu2-selector-finda.stl");

Made a spacer for this issue https://www.thingiverse.com/thing:3311839
Have some filament strings from the 1st material. Now I print a 1.0mm spacer at the moment for next try.

...
Posted : 25/12/2018 5:15 pm
cyrille.p
(@cyrille-p)
Estimable Member
Re: Firmware 1.0.3 for the MMU2 unit


Just mark selector position after homing, install firmware version 1.0.3 on the MMU, load filament (MMU will home) and compare selector position to previously marked position. Mine is more to the left causing filament to jam in the selector.

I have the same problem, the filament doesn't want to load into the selector. There was no problem with 1.0.2.
MK2.5+MMU2

My youtube channel about the Prusa I3 MK2 https://www.youtube.com/channel/UCz-zQZcKcvEDdd9C9hOKYWg...
Posted : 28/12/2018 2:43 pm
cyrille.p
(@cyrille-p)
Estimable Member
Re: Firmware 1.0.3 for the MMU2 unit

For the moment (and in the waiting of an update), I put a 1.5mm drill bit between the selector and the mmu case during the calibration of my mmu2. It does the job.

My youtube channel about the Prusa I3 MK2 https://www.youtube.com/channel/UCz-zQZcKcvEDdd9C9hOKYWg...
Posted : 28/12/2018 4:25 pm
hommelm
(@hommelm)
New Member
Re: Firmware 1.0.3 for the MMU2 unit

Hello all,

over Christmas i assembled my MMU 2.0.
I installed the unit now on my Printer which is a I3 MK3 and flashed all the Firmware to the newest.
I can load the Filament at all 5 Position. But i can not adjust the lenght from the Filament to the
Extruder. So i can nothing print because the Filament does not reach the Extruder.

Please can somboy help me out with this Problem.
I read the Installation Guide man times but it will not work, so i'am a litte it confused.

Posted : 31/12/2018 5:58 pm
Nikolai
(@nikolai)
Noble Member
Re: Firmware 1.0.3 for the MMU2 unit


Hello all,

over Christmas i assembled my MMU 2.0.
I installed the unit now on my Printer which is a I3 MK3 and flashed all the Firmware to the newest.
I can load the Filament at all 5 Position. But i can not adjust the lenght from the Filament to the
Extruder. So i can nothing print because the Filament does not reach the Extruder.

Please can somboy help me out with this Problem.
I read the Installation Guide man times but it will not work, so i'am a litte it confused.

Hello Michael,

Welcome to the community. I would suggest you contact Prusa support live chat. They can guide you step by step how to configure the tube length for each filament.
It is also better to open up a new thread for a new issue. Not many people are looking into existing old thread.

Often linked posts:
Going small with MMU2
Real Multi Material
My prints on Instagram...
Posted : 31/12/2018 6:49 pm
joe.w6
(@joe-w6)
Eminent Member
Re: Firmware 1.0.3 for the MMU2 unit

Speed issue on wipe tower is one of the biggest issues I have too when printing with PETG 🙁
Also it would be nice to get the sensor working because printing air is not fun and gets very expensive!

Posted : 04/01/2019 8:06 am
Page 2 / 3
Share: