Typical MMU startup noise? (video/sound) with 'a side of' MMU2 upgrade woes...
 

Typical MMU startup noise? (video/sound) with 'a side of' MMU2 upgrade woes...  

  RSS
michael.b103
(@michael-b103)
Active Member

WoWza! I hope that video upload/embed worked. First time posting 😀...

Does your MMU2 make the sound (in the video that I hope uploaded OK) when you turn on your power supply? The sound seems to be emanating from the filament selector rocking back and forth. No, there's no debris in there. I've taken it apart several times trying to find the issue, but...

My MMU2 is not working! I am not sure if it is related to the noise in the video (I might have 2 or more problems).

I have a Prusa i3 MK3 that I recently upgraded with the MMU2s.  Since the upgrade, it has printed multiple materials OK for a few days, but now I'm having issues. 

In addition to the aforementioned noise, when I try to print using the MMU2, I get this error:

MMU load failed.

Here's the scenario:

  • I can 'load' any of the 5 filaments into the MMU ok. 
  • When I try to print using multiple materials, I get the MMU load failed error. 
  • When printing a print that uses any one of the 5 filaments first, I get the same error.
  • When loading any given filament into the MMU, the filament slides easily through the long Bowden tubes, past the Bondtech gears, all the way to the short (~25mm) internal PTFE tubes. The filament path seems to be free.
  • What happens when I try to print is any of the 5 loaded filaments start moving through the MMU2, then the filament goes back and forth several times (~3-6mm) inside the MMU. I can see/feel the filament moving on the spool side of the long Bowden tubes. 
  • Then I get the error.
  • Note that the filament never makes it to the single Bowden tube on the extruder side. It just hovers there in the MMU, moving back and forth, and then the error appears on the LCD.

Here's what I've tried to troubleshoot the issue:

  • The Bondtech gears are clean and aligned, and the set-screws are tight.
  • The filament path and Bowden tubes are clear and the filament moves freely.
  • I have taken apart the MMU a few times to check for debris in the filament path and the filament selector, but I cannot find any.
  • I have checked the FINDA sensor/steel ball repeatedly and the sensor seems to be functioning correctly. To check it I unscrew the short Bowden tube leaving the MMU and stick a piece of filament into the hole. The sensor diagnostic indicates '0' or '1' as expected. I have also checked for shorts in the FINDA sensor wire by moving it around during the sensor check. The sensor output diagnostics do not waver while moving the cable.
  • I have played with the tension on the MMU door by adjusting the 40mm spring-loaded screws.
  • I have tried the load filament to extruder option and am having the same issue.

Is it the noise? Is it something else? What am I missing?

I am using PrusaSlicer Version 2.1.1 for windows 64.

I am using firmware for the MK3S upgrade, dated October 24, 2019, v3.81 / v1.0.6.

Thanks in advance! 🙂 

This topic was modified 1 year ago by michael.b103
Posted : 19/02/2020 12:12 am
michael.b103
(@michael-b103)
Active Member

I neglected to mention that the prints that are now failing have printed before successfully. Ergo, it doesn't seem to be a gcode problem.

Posted : 19/02/2020 1:43 am
michael.b103
(@michael-b103)
Active Member

I mistakenly mentioned the selector as the part making noise (in the video that probably didn't work) in the prior post. I believe I meant the idler instead. I'm checking out this Prusa help guide to address the idler noise issue.

I'm trying the video upload again. To do this, I chose the 'Add Media' button, selected an mp4 file on my computer, selected to embed this video into the current post. I think I'm doing it wrong. How can I upload my video so others can see it? (moderator or someone else please offer advice...) 

I could not find 'forum help' but will search for this again. 

Thanks.

 

This post was modified 1 year ago 3 times by michael.b103
Posted : 19/02/2020 4:00 pm
michael.b103
(@michael-b103)
Active Member

Here's a video link on YouTube if that helps get the video out there.

I did this because I can't figure out how to add a video and every time I try to troubleshoot the video upload, my forum edit times out... 🙁

This post was modified 1 year ago by michael.b103
Posted : 19/02/2020 6:07 pm
mc_ott
(@mc_ott)
Active Member

I am also new to MMU2S, 2 weeks in, and I hear the same 5 clicking noises, and the selector moves left-right-left. I am hoping that is the startup routine. I think  the clicking noises are due to the rotation of the bearings shaft. I have no issues at that stage but I have all kind of filament loading issues during printing multicolour prints. I am using Octoprint to connect to the printer and print always with PETG, which creates more strings than PLA. I did not have issues with startup loading, on that I cannot help, but I read somewhere, sometimes reinstalling the latest firmware may help.

Posted : 22/02/2020 3:09 pm
vintagepc
(@vintagepc)
Noble Member

This is normal. It is homing the idler drum. 

Posted : 22/02/2020 5:49 pm
Stephen
(@stephen-6)
New Member

Yeah, mine does that too.Very anoying. After a while it will make the two screws that hold the idler drum to the stepper come loos and will no longer feed filiment from spools 2 - 5 only spool 1. They need to be checked often and tightened. To reduce the problem always shut down the printer with filiment 5 selected. It wont stop it but will reduce it a bit.

Posted : 05/03/2020 10:52 am
vintagepc
(@vintagepc)
Noble Member

I recall seeing a firmware mod from one of the main PR contributors that had sensorless homing enabled on the MMU idler to stop it doing that... Hopefully it becomes mainstream at some point.

Posted : 05/03/2020 2:26 pm
Share:

Please Login or Register