Notifications
Clear all

Octoprint issues - layer skipping, print pausing  

Page 3 / 3
  RSS
Mike Daneman
(@mike-daneman)
Estimable Member
RE: Octoprint issues - layer skipping, print pausing

For anyone interested, there's a very active discussion of this issue happening on the DLP github with even Gina (developer of Octoprint) getting involved.  For me, version 1.19.1 seems to have solved the issue, but some people seem to still get it.  A new development version 1.20.1 seems to be helping further.

https://github.com/OllisGit/OctoPrint-DisplayLayerProgress/issues/124

 

Posted : 22/04/2020 4:31 pm
NickRno77
(@nickrno77)
Trusted Member
RE: Octoprint issues - layer skipping, print pausing
Posted by: @axion

Some more information:

Every time there was a shift it happened on the Y axis. My printer is right next to my computer, so I can monitor it. Every time the shifting occurred there was a loud ca-chunk  sound, then it would shift 1 to 2mm; it is the same sound as when you run the XYZ setup to find home and it is testing the boundaries; so it sounds like a collision. The crazy thing is I saw it do this and the print head makes no impact when the shifting and sound occur. I thought there was something wrong with the rods, belt, or motor. I first tried adding more lubricant then I disassembled the Y axis and re-assembled, looking for problems (scratches in rods, filament pieces in belts, tightening screws, tightening belts, etc); nothing changed. 

I’m getting the exact same thing on X and Y randomly on this job. The last failure was last night without octoprint turned on, no power to Pi, I did have the usb cable connected though. I’m getting random pauses as well. I just did another print using octoprint and octolapse, I heard a fairly loud click, looked at print, the layer shifted about 1 mm in Y ? 

This post was modified 2 years ago 2 times by NickRno77
Posted : 02/06/2020 8:44 pm
karl-herbert
(@karl-herbert)
Illustrious Member
RE: Octoprint issues - layer skipping, print pausing

@nickrno77

Serial logging in octoprint can cause such problems - Try to deactivate serial logging!

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 02/06/2020 9:45 pm
PsychProd
(@psychprod)
Active Member
RE: Octoprint issues - layer skipping, print pausing

@mdaneman

I'm only a couple days into my Prusa i3 MK3S and was surprised to see layer shifts on my 3rd print (bag clips for the wife).  Just like you, was on the x-axis and happened a couple times in the print.

I too was running the Dashboard plugin which seems to require the DisplayLayerProgress plugin be installed as well.  I disabled those two and printed another bag clip... no shift this time.

Still too early to claim problem solved... but the idea that OctoPrint plugins could be injecting code into the gcode the printer is executing?  That never occurred to me!  I've been experiencing horrible layer shifts on my CR10 all last year and it really stopped me from printing on it (and buying a Prusa), now I'm wondering if it was OctoPrint plugins plaguing me the whole time.

Thanks for your detective work and posting about it here.

-b

Posted : 28/08/2020 10:57 pm
Page 3 / 3
Share: