Raspberry Pi Zero W not connecting via GPIO to Mk3S  

  RSS
Multi3D
(@multi3d)
New Member

Hi, I have recently got a Prusa I3 Mk3s and wanted to extend it with a Raspberry Zero W as in the Prusa online tutorial. Unfortunately, this does not work I have in the settings the Rpi port Activated and downloaded on the side of Prusa the PrusaPrint firmware. But he does not connect. He probably finds the port and the baud rate but then gets a time out. It does not help to set the time out time high. I have already tried a new Raspberry Pi Zero W, but the same problem even with a built-in instructions Octoprint does not work. A connection via USB with my PC, he builds on and can be controlled.

I hope someone can help me.

Posted : 11/07/2019 5:29 pm
Robert-mm200
(@robert-rmm200)
Noble Member

Octoprint, for one, does not recommend using the Pi Zero in this application. It is simply too weak.

Try a 3 B+ or a 4. You will be much happier.

Posted : 12/07/2019 4:58 pm
Just3D
(@just3d)
Eminent Member

Don´t know what Octoprint says, but a Zero W with Prusa´s modified Octoprint and a regular Pi camera work brilliantly with my i3MK3s, including a webcam livestream and wireless upload of files to the printer. I can´t help with ports and baud rates, though, as I use the Zero W through its wireless connection. 

Posted : 12/07/2019 6:54 pm
Robert-mm200
(@robert-rmm200)
Noble Member

Here is a little more information on the Pi Zero from the Octoprint download page:

https://octoprint.org/download/

Posted : 12/07/2019 7:35 pm
Share:

Please Login or Register