Octoprint-related layer shifts  

  RSS
mdaneman
(@mdaneman)
Estimable Member

I'm having a constant X-axis layer shift issue when printing from Octoprint with some plugins.  Sometimes it's one layer shift per print, sometime it 3 to 5 shifts. I've done some pretty extensive testing and am very certain of the data below:

a. Printing from SD - no layer shifts

b. Printing from Octoprint in Safe mode - no layer shifts

c. Printing from Octoprint with some plugins (Dashboard, DisplayLayerProgress, Bed Leveler, Firmware updater, Change Filament, DeleteAfterPrint, FileManager, Gcode Editor, OctoPod, PrusaMeshLeveling, Themeify, TouchUI) - Layer shifts

d. Printing form Octoprint with just the standard plugins + Themeify+TouchUI - I think no layer shift, but need to do more prints

e. I have zero crashes reported by the printer, my bearings are smooth and well lubricated (in fact I loaded all bearings with grease and totally replaced my X-axis rods and bearings (one X rod had a groove worn into it) when I initial started getting shifts, thinking it may be related to the printer).

The funny thing is that I've been printing with some of these plugins for months with no layer shift issue and the plugins I had left turned-on for test (c) were not ones that should be messing with gcode data or sucking up significant processor cycles (I turned off PrintTimeGenius & CancelObjects, whcih I initially thought may be to blame).  Any idea why the issue would suddenly pop-up?  How can Octoprint cause a layer shift?  I thought that all the extruder moves were in absolute coordinates, so even if the printer misses a move command, the next command should put it back where it's supposed to be and not cause all the following layers to be shifted.

Posted : 18/12/2019 9:20 pm
mdaneman
(@mdaneman)
Estimable Member

No one is chiming in, but I'm really curious how Octoprint can cause a layer shift (i.e. how does it physically happen).  I'm kind of baffled as to how it can occure, even with commands missed by the printer.

p.s. I've confirmed that scenario (d) still works - no layer shifts so far in 5 prints (though 2 of them were pretty short).

Posted : 20/12/2019 11:44 pm
geri77at
(@geri77at)
New Member

@mdaneman

i have the same issue, with or without Octoprint, Prusa support could not help me

Posted : 14/02/2020 2:57 pm
mdaneman
(@mdaneman)
Estimable Member
Posted by: @geri77at

@mdaneman

i have the same issue, with or without Octoprint, Prusa support could not help me

If getting shift even when printing from SD, then it’s likely a hardware issue. Are you getting a shift in only one axis or randomly in both? Do you see crashes when the shifts happen (you can check the crash count on the LCD menu)? Do you get shifts consistently at the same height or random?

I’m sure you probably checked most of this stuff, but the things to look at are:

ensure the set screws in pulleys (bobbins) for both x and y belts are tight and that one of each pair of set screws is sitting on the flat part of the rod  

ensure you belts are tight and not damaged in any way  

ensure the bearings  are moving smoothly in the rods and that you don’t have any grooves worn into the rods  - that may mean you need to change those rods and bearings  

  

Posted : 14/02/2020 3:29 pm
Franc
(@franc)
New Member

Having this exact issue for a few weeks now. Have tried a ton but no real results, only thing that guarantees no shifts is printing from SD card. The shifts seem far more likely to happen the taller the print, and more likely to be Y shifts.

Posted : 18/02/2020 9:26 am
towlerg
(@towlerg)
Honorable Member

"Printing from Octoprint in Safe mode - no layer shifts" doesn't that rather point to a defective plugin?

"The funny thing is that I've been printing with some of these plugins for months" I guess you try removing the more recent plugins till you find the perpetrator. Also look at plugins that were updated in that period.

You don't say what hardware you're using to run Octoprint.

The Octoprint board is very friendly, why not post your problem there?

 

 

Posted : 18/02/2020 12:34 pm
nicoseeleib
(@nicoseeleib)
New Member

Hi,
To help you, see this post: here

The issue seems to be DisplayLayerInformation for Dashboard.
Will try, to remove it as well, as I do have the same issues!

Posted : 27/02/2020 8:18 am
Rich3D
(@rich3d)
Active Member

I had this issue occasionally as well. Re-slicing and uploading to Octoprint seemed to resolve the issue.

 

I was unable to find any issue with the original Gcode, but I did not bother to check the Gcode that was already stored on the Pi.

 

My guess was that something was corrupted during the file transfer. My layer shifts were consistently in the same place (Hopefully I uploaded the video correctly? :))

 

[video width="640" height="480" mp4="https://forum.prusaprinters.org/wp-content/uploads/2020/02/LayerShiftTimeLapse-1.mp4"][/video]

 

 

I usually transfer my files over the internet to my Pi,  I haven't had any issues when I transferred them directly to the SD card and printed from that.

Rich 3D
https://3dnewb.com...
Posted : 27/02/2020 1:51 pm
geri77at
(@geri77at)
New Member

@mdaneman

everything checked, the next issue that comes in now is that the printer stops sometimes uner printing, sometimes the print runs thru, but most of the time the prints fail, it's terrible with this printer, my other one prints every print perfect, with or without octopint

Posted : 28/02/2020 5:24 pm
Sembazuru
(@sembazuru)
Prominent Member

Are you using octolapse? I've been having some odd layer shifts that are related to what direction I have the octolapse stablization go. I think I may have solved it by following Teaching Tech's instruction to use a g-code trigger (he suggested G4 P1 for a 1ms pause that is unnoticeable if octolapse isn't running) in the after layer change g-code. Then I was having extrusion issues related to octolapse setting my extruder to absolute mode so I also added G90 and M83 to make sure that octolapse wasn't changing either my absolute travel or relative extruder modes.

Not sure if my problems (and solutions) apply to your experience.

See my (limited) designs on:
PrusaPrinters - https://www.prusaprinters.org/social/1448-sembazuru/prints
Thingiverse - https://www.thingiverse.com/Sembazuru/designs...
Posted : 01/03/2020 3:21 am
Share:

Please Login or Register