Octopi RP 3 Won't Connect but RP Zero Does????  

  RSS
bluemonkeydev
(@bluemonkeydev)
Active Member

I have spent 3+ hours on this, need more advice.

I started with a Pi Zero and it worked just fine but it was WAY too slow.

Switched to the PI3, but it won't connect. It's is plugged in via the USB cable.

This is the error I get:

Changing monitoring state from "Offline" to "Opening serial connection"
Connecting to port /dev/ttyACM0, baudrate 115200
Changing monitoring state from "Opening serial connection" to "Connecting"
Connected to: Serial<id=0x6863b8b0, open=True>(port='/dev/ttyACM0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Recv: start
Send: N0 M110 N0*125
There was a timeout while trying to connect to the printer
Changing monitoring state from "Connecting" to "Offline"
Connection closed, closing down monitor

Things I've tried:

  • 2 different Raspberry Pis
  • 3 different USB Cables
  • Rebuilt the SD Card 2x
  • Put the SD card in the Pi Zero (works fine); Same card in Pi 3 (won't connect)
  • Adjusted time-outs
  • Check the "Wait for start on connect" box

One thing that is interesting, when I connect to "ttyACM0", the 3d printer REBOOTS. Is that normal and/or expected? Does it every time. Seems wrong.

I have searched HIGH & LOW for any ideas but came up short.

HELP, I am out of ideas...

Best Answer by JoanTabb:

Did you turn off the internal RasPi port using the LCD controls? when you connected the other RasPi's 

regards Joan

This topic was modified 1 month ago 3 times by bluemonkeydev
Posted : 13/01/2021 3:42 am
JoanTabb
(@joantabb)
Moderator

Did you turn off the internal RasPi port using the LCD controls? when you connected the other RasPi's 

regards Joan

I try to make safe suggestions,You should understand the context and ensure you are happy that they are safe before attempting to apply my suggestions, what you do, is YOUR responsibility. Location Halifax UK...
Posted : 13/01/2021 6:03 am
towlerg
(@towlerg)
Prominent Member

You've obviously tried a bunch of stuff, did you try posting problem on OctoPrint forum? There's some really helpful, knowledgeable guys on that board. FWIW I connect to Auto which translates to \dev\ttyUSB0.

Posted : 13/01/2021 11:22 am
cwbullet
(@cwbullet)
Illustrious Member
Posted by: @bluemonkeydev

I have spent 3+ hours on this, need more advice.

I started with a Pi Zero and it worked just fine but it was WAY too slow.

Switched to the PI3, but it won't connect. It's is plugged in via the USB cable.

This is the error I get:

Changing monitoring state from "Offline" to "Opening serial connection"
Connecting to port /dev/ttyACM0, baudrate 115200
Changing monitoring state from "Opening serial connection" to "Connecting"
Connected to: Serial<id=0x6863b8b0, open=True>(port='/dev/ttyACM0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Recv: start
Send: N0 M110 N0*125
There was a timeout while trying to connect to the printer
Changing monitoring state from "Connecting" to "Offline"
Connection closed, closing down monitor

Things I've tried:

  • 2 different Raspberry Pis
  • 3 different USB Cables
  • Rebuilt the SD Card 2x
  • Put the SD card in the Pi Zero (works fine); Same card in Pi 3 (won't connect)
  • Adjusted time-outs
  • Check the "Wait for start on connect" box

One thing that is interesting, when I connect to "ttyACM0", the 3d printer REBOOTS. Is that normal and/or expected? Does it every time. Seems wrong.

I have searched HIGH & LOW for any ideas but came up short.

HELP, I am out of ideas...

I had a similar problem a few months ago.  I got to whits end and try everything.  I reinstalled the Rasbian and Octoprint and it started working again.  

--------------------
Chuck H
3D Printer Review Blog...
Posted : 13/01/2021 12:10 pm
bluemonkeydev
(@bluemonkeydev)
Active Member

@joantabb

OMG... How-Did-I-Miss-THAT?

I swear I read over that guide a dozen times. And every time, I thought the instructions said to turn the RPi port "ON". But you are spot on, it said to turn it "OFF".

> When using USB to connect to the printer, deactivate the RPi port (LCD menu -> Settings -> RPi Port and set it to "Off"). If you use RPi Zero over GPIO, RPi port should be 'On'.

THANK YOU

Posted : 13/01/2021 1:51 pm
bluemonkeydev
(@bluemonkeydev)
Active Member

@towlerg

Thank you - I did try that as well. Turns out I DID miss read the instructions on this step, after reading it a dozen times, I still THOUGHT it was supposed to be "ON"... Nope, "OFF".

> When using USB to connect to the printer, deactivate the RPi port (LCD menu -> Settings -> RPi Port and set it to "Off"). If you use RPi Zero over GPIO, RPi port should be 'On'.

Posted : 13/01/2021 1:52 pm
karl-herbert
(@karl-herbert)
Illustrious Member

@bluemonkeydev

I can confirm this: Using a USB cable always means RPi off, no matter if you use Octoprint or Pronterface. I once had the same experience and spent hours looking for an error.

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 13/01/2021 3:10 pm
JoanTabb
(@joantabb)
Moderator

Another Satisfied Customer...   🙂    Yeah, tripped me up too...   I couldn't understand how the USB port worked fine for firmware upgrades but not for serial communication...  

regards Joan

I try to make safe suggestions,You should understand the context and ensure you are happy that they are safe before attempting to apply my suggestions, what you do, is YOUR responsibility. Location Halifax UK...
Posted : 13/01/2021 3:17 pm
bluemonkeydev
(@bluemonkeydev)
Active Member

@karl-herbert

I'm glad I'm not alone 🙂 Thanks for the reply!

Posted : 13/01/2021 6:00 pm
cwbullet
(@cwbullet)
Illustrious Member

I hope I did not reinstall to reset the RPI switch.  

--------------------
Chuck H
3D Printer Review Blog...
Posted : 13/01/2021 6:12 pm
bluemonkeydev
(@bluemonkeydev)
Active Member
Posted by: @cwbullet

I hope I did not reinstall to reset the RPI switch.  

I know - right? I reinstalled 2x! (but yeah, you probably did if you had RPi set to "ON")

Can't fault anyone but myself, the instructions DO say to set it to "OFF".

Posted : 13/01/2021 10:34 pm
Share:

Please Login or Register