[Closed] Stable Slic3r builds  

Page 5 / 6
  RSS
christophe.p
(@christophe-p)
Member Moderator

Hi Vojtech,

I think I have a strange bug:

If I slice a model with 0.35 fast setting, with no raft, Preview show 1st layer is 0.2, 2d layer is 0.55, 3rd layer is 0.9. That's fine.
If I slice a model with 0.35 fast setting, with 1 layer raft and 0 mm for Contact Z distance, Preview show 1st layer (raft) is 0.2, 2d layer is 0.55, 3rd layer is 0.9. That's fine.
If I slice a model with 0.35 fast setting, with 1 layer raft and 0.1 mm for Contact Z distance, Preview show 1st layer is 0.2 (raft), 2d layer is 0.70, 3rd layer is 1.05.

I'm a bit confused.
Shouldn't the 2d layer and 3rd layer be 0.65 and 1.00 instead, or is it the preview that is not aligned with the real layer width ?

I'm like Jon Snow, I know nothing....
Posted : 20/12/2016 12:37 pm
bubnikv
(@bubnikv)
Member Admin

Christophe,

Indeed, Slic3r does not align the support layers with the print layers, it tries to print the support layers with a thicker line than the object. Sometimes this strategy works and the print is faster, sometimes it is counter-productive and many thin support layers are generated. I am currently testing new supports, which will behave differently and there will be an option to synchronize the support layers with the object print layers due to the multi material printing.

Vojtech

...
Posted : 20/12/2016 1:10 pm
christophe.p
(@christophe-p)
Member Moderator

Hi Vojtech,

in fact here I think it's a bit different, let me explain deeper. I included the 3 gcode files generated.

Here is the code of sliced version with no raft:
[...]
M83 ; use relative distances for extrusion
G1 E-0.80000 F2100.00000
G1 Z0.200 F6000.000
G1 X102.639 Y98.629 F6000.000
G1 E0.80000 F2100.00000
M204 S1000
G1 F2100
G1 X103.705 Y97.616 E0.04612
[...]
G1 X143.484 Y101.233 E-0.18631
G1 E-0.04000 F2100.00000
==> G1 Z0.550 F6000.000
G1 X144.260 Y100.915 F6000.000
[...]

Here is the code of sliced version with 1 layer raft, with standard 0.1 Z contact:
[...]
M83 ; use relative distances for extrusion
G1 E-0.80000 F2100.00000
G1 Z0.200 F6000.000
G1 X102.511 Y96.632 F6000.000
G1 E0.80000 F2100.00000
M204 S1000
G1 F2100
G1 X103.987 Y96.203 E0.04819
[...]
G1 X146.136 Y109.434 E-0.56672
G1 E-0.04000 F2100.00000
==> G1 Z0.700 F6000.000
G1 X144.271 Y109.178 F6000.000
[...]

Here is the code of sliced version with 1 layer raft, with 0 Z contact:
[...]
M83 ; use relative distances for extrusion
G1 E-0.80000 F2100.00000
G1 Z0.200 F6000.000
G1 X102.517 Y96.620 F6000.000
G1 E0.80000 F2100.00000
M204 S1000
G1 F2100
G1 X103.993 Y96.191 E0.04819
[...]
G1 X146.136 Y109.447 E-0.56130
G1 E-0.04000 F2100.00000
==> G1 Z0.550 F6000.000
G1 X144.260 Y109.179 F6000.000
[...]

There are no additional raft layer inserted, and the thick of the lines remain the same (If I understand well the setting G1 E-0.04000 F2100.00000 of the first layer and the G1 E-0.80000 F2100.00000 of the raft layer). So the layers seems generated the same way, but in the second case, the mdel start with a gap of 0.15 between the raft and the object where it should be 0.1 if this setting would be applied from "Contact Z distance" support parameter. In the third case, a 0 gap is properlly applied.

Is what I try to point clear that way ?

That said, the first raft is not exactly following the support settings, it's always the same schema of unerlying lines.

By The way since you are working heavily on support generation, did you find a way to define area where support generation should be forced, and where support generation should be cancelled ? It would let workaround so many situations !

And if you need a beta-tester for the support, I'm In ! 🙂

I'm like Jon Snow, I know nothing....
Posted : 21/12/2016 3:42 pm
bubnikv
(@bubnikv)
Member Admin

> By The way since you are working heavily on support generation, did you find a way to define area where support generation should be forced, and where support generation should be cancelled ? It would let workaround so many situations !

It is on my list, but I am still not sure how to handle the user interface.

> And if you need a beta-tester for the support, I'm In ! 🙂

I am taking a computer programming detox until 2nd of January. After that I will finalize the new automatic support generator, so there will be probably some betas in the at the end of January.

Merry Christmas,
Vojtech

...
Posted : 22/12/2016 1:10 pm
bubnikv
(@bubnikv)
Member Admin

> There are no additional raft layer inserted, and the thick of the lines remain the same (If I understand well the setting G1 E-0.04000 F2100.00000 of the first layer and the G1 E-0.80000 F2100.00000 of the raft layer). So the layers seems generated the same way, but in the second case, the mdel start with a gap of 0.15 between the raft and the object where it should be 0.1 if this setting would be applied from "Contact Z distance" support parameter. In the third case, a 0 gap is properlly applied.
>
> Is what I try to point clear that way ?

I think you made yourself clear. But due to the supports being rewritten completely, I will not spend time with the old supports. I will wait for the bug reports against the new supports 🙂

...
Posted : 22/12/2016 1:13 pm
christophe.p
(@christophe-p)
Member Moderator

> By The way since you are working heavily on support generation, did you find a way to define area where support generation should be forced, and where support generation should be cancelled ? It would let workaround so many situations !

It is on my list, but I am still not sure how to handle the user interface.

> And if you need a beta-tester for the support, I'm In ! 🙂

I am taking a computer programming detox until 2nd of January. After that I will finalize the new automatic support generator, so there will be probably some betas in the at the end of January.

Merry Christmas,
Vojtech

Regarding the user interface, I can see 2 ways to do it. If the force/cancel area is done on the build plate only, then a flat image of the projection of the objects where you can paint area with a brush (red for cancel zone, green for force zone) should be a natural option, seems easy to implement and to understand.

If the zone should be applied on the object itself, it can be tricky, maybe using something like the Meshmixer selection tool ...

Merry X-mas and happy new year for you too 🙂

I'm like Jon Snow, I know nothing....
Posted : 30/12/2016 11:56 pm
joerund.r
(@joerund-r)
New Member

Hello.

I have installed slic3r prusa edition 1.31.6.
But I am having trouble with preview mode. It will not show the model in preview mode??
My printer prints just fine when exported files to sd card but it would be nice to view the model in preview mode especially when supports are used.

Anybody got any tips for me??
Thank you

JR

...
Posted : 19/01/2017 6:59 pm
christophe.p
(@christophe-p)
Member Moderator

Hi JR,

the preview only show the simulated gcode once the model is sliced.

So you need to click on the button "Slice now" or activate "background processing" in the preferences so that you can see the result in Preview.

I'm like Jon Snow, I know nothing....
Posted : 19/01/2017 9:09 pm
joerund.r
(@joerund-r)
New Member

Oh man! Thank you! I had gotten so used to S3D... just press the preview button.
I remember now, thank you!

JR

...
Posted : 20/01/2017 6:22 am
herve.t
(@herve-t)
Active Member

Here is alternative OSX build done by bit different process http://www.prusa3d.com/downloads/dev/slic3r/Slic3r-alt.dmg this one should work.

We will do builds for 10.9+, as Sound is trying to keep it compatible from 10.6+ and this makes it unstable on 5 generations newer system.

After trying all others versions...it is, for me, the only version i can run on Mac 10.8.5. (and the "old" 1.2.9 version)

...
Posted : 29/01/2017 12:24 am
chris.p8
(@chris-p8)
Trusted Member

Probably a silly question - I already have Slic3r (1.2.9) for using on my Fisher Delta and since I have just ordered a Prusa i3 I thought I would have a look at the 'custom' build of Slic3r for the Prusa - when I run it I am getting all the settings/configuration from the other version of Slic3r I have installed??

Should I uninstall this? I thought they would work independently? I would prefer to have one version for both printers really (you can define settings for more than one printer in Slic3r) Will the Prusa build changes make it ineffective for use on the Fisher?

Regards

Chris Parsons

...
Posted : 09/02/2017 10:50 am
chris.p8
(@chris-p8)
Trusted Member

Apologies - ignore my last post!

I had installed Slic3r from the development ZIP file, not the drivers executable - and have removed and reinstalled it and now it makes a lot more sense, there are desktop shortcuts that start up a version preconfigured for a Prusa - and the version looks to be a replacement for 1.2.9 so I will use this as an alternative

I have to say, so far I am impressed, a new version of Slic3r AND a load of impressive models - the Spitfire, wow!

Now I can't wait for the Prusa kit to be delivered 🙂

Chris

...
Posted : 09/02/2017 12:12 pm
christophe.p
(@christophe-p)
Member Moderator

Hi Chris,

you should be able to use the same slicer for both printer,

When you look at the link, you can see it use the command line:

"C:\Program Files\Prusa3D\Slic3rPE\slic3r.exe" --DataDir "C:\Users\Public\Documents\Prusa3D\Slic3r settings MK2"

The --DataDir provide a folder where the settings are stored. It may be possible to had a specific printer in the subfoler C:\Users\Public\Documents\Prusa3D\Slic3r settings MK2\printer as a new ini file, but it's possible that the filament and profile settigns store some settings dependant of your printer. I would recommend instead to have a complete folder in "C:\Users\Public\Documents\Prusa3D\Fisher Delta", to copy all your existing configuration file in this folder, maintaining the same folder structure, and to create a new shortcut having as command line:

"C:\Program Files\Prusa3D\Slic3rPE\slic3r.exe" --DataDir "C:\Users\Public\Documents\Prusa3D\Fisher Delta"

You will then have an icon to leunch the PR slic3r for the mk2, and another for your printer.

I'm like Jon Snow, I know nothing....
Posted : 09/02/2017 1:08 pm
dan.s7
(@dan-s7)
New Member

Hi Josef
I just ordered a printer from you guys. I am totally new to this field. Can you please tell me what software you recommend for designing and what else I need when the printer gets here.
I have some Ideas for your product I wold like to share with you. Can you please give me your email-address so I can write directly to you. Mine is dan.stutz@me.com

Kind regards
Dan

...
Posted : 08/03/2017 9:32 am
marc.n
(@marc-n)
Active Member

I have version 1.33.8-prusa3d-win64 installed but the following message shows up when try to use the Layer editor:

Cannot compile an OpenGL Shader, therefore the Variable Layer Editing will be disabled.
Fragement shader compilation failed:
No errors.

I've tried reinstalling the software but it didn't help. I must be missing something. Any suggestions?

Cheers, Marc

...
Posted : 25/03/2017 7:10 pm
bubnikv
(@bubnikv)
Member Admin

There are some issues with the current implementation on some computers. We are finalizing an alpha, which should solve this issue on most not so old systems and hardware.

...
Posted : 26/03/2017 9:41 am
christoph.b
(@christoph-b)
Active Member

Hello,

I installed the newest slic3r prusa edition to test the new variable layer height function which seems very promisable. I managed to test the slicing and adjusting of the layer height on a few test objects but after that slicer crashed (froze) and now whenever I click the "Edit layers" button nothing happens! I so much would like to use this feature - how can I get it back? Do I re-install slic3er? I am on Windows10.

Thanks for any help on this one.

BR,

Christoph

Make it as simple as possible and as complex as required....
Posted : 28/03/2017 2:39 pm
bubnikv
(@bubnikv)
Member Admin

Christoph,

there is a settings at the printer page, which lets you disable / enable the feature. It probably got disabled somehow.

Vojtech

...
Posted : 28/03/2017 2:41 pm
christoph.b
(@christoph-b)
Active Member

Hello vojtech.b3,

unfortunately this is not the case. The checkmark is on "enabled". But when I click on the "edit layer" button slicer freezes and the computers processor gets hot (the fan starts making more noise) at some point I have to kill the process.

Any other suggestions?

BR,

Christoph

Make it as simple as possible and as complex as required....
Posted : 11/04/2017 1:35 pm
bubnikv
(@bubnikv)
Member Admin

> unfortunately this is not the case. The checkmark is on "enabled". But when I click on the "edit layer" button slicer freezes and the computers processor gets hot (the fan starts making more noise) at some point I have to kill the process.

What version of Slic3r are you using? Did you try the latest beta?
https://github.com/prusa3d/Slic3r/releases/tag/version_1.34.1

Also there are some issues with the latest Windows 10 update rolled out, which messes up the Intel graphics driver.

http://shop.prusa3d.com/forum/software-f13/slic3r-mk2-broken-after-plater-gt-gt-dlp-projector-t3997.html

...
Posted : 11/04/2017 3:55 pm
Page 5 / 6
Share:

Please Login or Register