Front fan only on when M106 S255 Set or manual 255
 
Notifications
Clear all

Front fan only on when M106 S255 Set or manual 255  

  RSS
robert.t2
(@robert-t2)
Active Member
Front fan only on when M106 S255 Set or manual 255

I'm going to go out on a limb and say no one has seen this problem before besides me. Here goes....

The front fan on my i3 mk2 died, I hooked it up to the bench power supply to confirm. I bought a new one after a conversation with Prusa support to make sure I have the specification correct. After installing the self test passed with ease.

Then came the trouble. My original Slic3r settings were with with "fan always on" and 60% for the entire print job with PETG at 230/80. This worked in the past however after the first finished the fan didn't flip on as expected. I check slicer settings and inspected the gcode. It should work and so I started the print job again and observed that the tune -> fan was indeed set for 153(60%).

I turned it up to 200 and click but no fan. Up to 230 and still not fan 240... 250 and no fan. Finally at 255 that fan came on but as soon as I dropped it to 254 the fan went off. The only other thing I've done since adding the new fan was upgrade to 3.0.11 firmware because I thought it might help. Same issue either the original firmware or new.

Just for fun I ran a Benchy print job and left the fan at 255 and it was not a surprise that I got a thermal runaway notice and failed print. The print job itself was near perfect right up until it failed sadly. I then manually adjust the fan as the job progressed by waiting to the last possible temperature drop before shutdown and then turning the fan off. I did this for as long as I could stand it but finally had to quit. Again, print job was nearly perfect up to the time I quit.

But in the months since I've had the printer I've several problems and whacky-ness like I quit a print job once and the printer head/hot end et. al. jumped 80 mm then slammed it self into the right side of the printer. If I were a betting man I'd say the electronic might be the problem. Anyway, Prusa support has not responded to any of my email requests for help on this issue(I'm sure they are busy). It's already too late for the project I was trying to finish, that's a mess that can't be fixed and I've order a printer from another company. Still with all the work I've put into this it would be nice to figure out what happen.

...
Posted : 01/06/2017 6:17 am
PJR
 PJR
(@pjr)
Moderator
Re: Front fan only on when M106 S255 Set or manual 255

Some fans will simply not work with a PWM positive rail...

This is the fan you need: http://e3d-online.com/50x50x15mm-12v-DC-Side-Blow-Fan?search=fan and that comes with a sufficiently long cable and does work with PWM.

Peter

Please note: I do not have any affiliation with Prusa Research. Any advices given are offered in good faith. It is your responsibility to ensure that by following my advice you do not suffer or cause injury, damage…...
Posted : 01/06/2017 8:49 am
robert.t2
(@robert-t2)
Active Member
Topic starter answered:
Re: Front fan only on when M106 S255 Set or manual 255

What is the technical reason why? If you don't mind me asking? That fan I have plugged in now adjust speed to variable voltage/current inputs. But I will go buy the recommended part and try it. I'm just curious..

...
Posted : 01/06/2017 5:43 pm
PJR
 PJR
(@pjr)
Moderator
Re: Front fan only on when M106 S255 Set or manual 255

Basically, this post: http://shop.prusa3d.com/forum/improvements-f14/alternative-nozzle-cooling-t4395-s10.html#p33768 plus my own experience with some fans which do work with analogue voltage control and not digital. I think for some reason the interrupted power upsets the control circuitry.

Peter

Please note: I do not have any affiliation with Prusa Research. Any advices given are offered in good faith. It is your responsibility to ensure that by following my advice you do not suffer or cause injury, damage…...
Posted : 01/06/2017 5:53 pm
robert.t2
(@robert-t2)
Active Member
Topic starter answered:
Re: Front fan only on when M106 S255 Set or manual 255

Sweet thanks! I totally forgot that we're dealing with atmel based and therefore PWM. That never occurred to me when buying the fans. 🙁

On another subject and reading into you 2017 posts on smootieboard. Looks like there is no good way right now to upgrade the i3 mk2? Do you know if there is a discussion/forum post somewhere on a complete guide to upgrading or is this just a pipe dream for now?

...
Posted : 01/06/2017 7:21 pm
PJR
 PJR
(@pjr)
Moderator
Re: Front fan only on when M106 S255 Set or manual 255

On another subject and reading into you 2017 posts on smootieboard. Looks like there is no good way right now to upgrade the i3 mk2? Do you know if there is a discussion/forum post somewhere on a complete guide to upgrading or is this just a pipe dream for now?

Well, in theory, it should be possible to upgrade to an Arduino Due and RAMPS-FD; the only hardware issue with that would be the lack of digipots to control motor current (which is necessary with MM upgrade).

The key is that you will need to retain the PR Marlin firmware in order to keep all the functionality.

I have a Due board, but so far, I simply haven't had the time to do any work on it.

Peter

Please note: I do not have any affiliation with Prusa Research. Any advices given are offered in good faith. It is your responsibility to ensure that by following my advice you do not suffer or cause injury, damage…...
Posted : 02/06/2017 10:52 am
Share: