Slic3r Prusa Edition Mac Missing Options?
 

Slic3r Prusa Edition Mac Missing Options?  

  RSS
rob.a
(@rob-a)
New Member

Hi everyone!

I downloaded the Slic3r Prusa Edition (released a few days ago) for my MacBook (running macOS Sierra). It seems to be missing some menu options, such as "Print Settings", "Filament" and "Printer", located on the right-hand side of the UI on a normal Windows installation. Are these options located elsewhere on the Mac install? I don't see them anywhere. It's quite possible that I'm supposed to do something special with installation on Mac, but the README didn't have any info. Windows had a nice executable, but on Mac I just double-clicked the Slic3r application which was contained in the zip file.

I've attached a screenshot from my Mac, as well as one from the Windows installation of the same version.

Mac Slic3r Prusa Edition (No options on right-hand side of UI)

Windows Slic3r Prusa Edition (All the lovely options)

Thanks in advance for any advice!

-Rob

...
Posted : 30/11/2016 3:48 pm
JohnOCFII
(@johnocfii)
Estimable Member

I can see all the options on my Mac. Did you import the configuration bundle?

https://3dprinting.community/login #Community Discussion for 3D Printing...
Posted : 05/12/2016 1:02 am
christopher.a2
(@christopher-a2)
New Member

I had the same problem,

solution:
1. Download the Mac Driver package from http://www.prusa3d.com/drivers/
2. unzip
3. move slic3r.app to your applications folder
4. open slic3r
5. From the application menu select: File->Load Config Bundle
6. Navigate to the driver package folder from step 2
7. select the 175mm_Slic3r_prusa3d_1_7_5.ini
8. open
9. restart slic3r

ps I'm not sure what the other .ini files are, If somebody knows please shed some light

...
Posted : 24/12/2016 6:33 pm
paul.d10
(@paul-d10)
New Member

Hey Rob,

You've probably solved this by now but maybe others will appreciate this solution.

After launch, the mac version does not find the configuration files (.ini) supplied with the Prusa drivers/Slic3r bundle download ( http://www.prusa3d.com/drivers/ ). In Windows 10 there was no problem, but on Mac (OS 10.10.3 Yosemite) the configuration was not loaded.

As suggested by christopher.a2, you can launch Slic3r and do File/Load Config, then open the correct .ini file* included in the Prusa drivers/Slic3r bundle download. However, when I tried this it didn't load properly and none of the default settings changed, etc.

The work around:
1) go to https://github.com/prusa3d/Slic3r-settings.git and download the Slic3r-settings folder
2) unzip
3) find the folder that corresponds to your printer*, copy the folders and files within
4) go to /Users/.../Library/Application Support/Slic3r and paste in those files and folders (replacing the 'filament', 'print', and 'printer' folders with the new folders downloaded from GitHub)
5) launch Slic3r, and everything should work

Proof:

*There seems to be some confusion within the community as to the naming convention of the configuration files. There are two versions of the original Prusa (3mm and 175mm), the MK2 is only available as 175mm so those settings are refered to only as MK2. You only need to load one configuration for your printer.

...
Posted : 20/04/2017 8:22 am
Share:

Please Login or Register