UPDATED! Slic3r PE over extrusion and cooling solved
 
Notifications
Clear all

UPDATED! Slic3r PE over extrusion and cooling solved  

Page 1 / 3
  RSS
josefprusa
(@josefprusa)
Admin
UPDATED! Slic3r PE over extrusion and cooling solved

Hello everyone.
I finally have my team together so I was able to investigate the issues of overextrusion.
Long story short, there were.
MK2S were naturally bit underextruding with lower esteps than actual, thats when we briefly introduced the feature to calibrate the esteps, suddenly the print quality became worse as it overextruded. And it is actually very similar to MK3 situation. (We decided to not include the feature anyways)

All Bondtechs have exactly the same esteps and are calibrated very well, but the thing is that Slic3r naturally overextrudes a little. By coincidence about the same 5% as the MK2 were underextruding. It is caused by different calculation method of the volume compared to simple rectangular area model supposedly to make the Slic3r generated files more accurate. But I am not sure specifically how, my mind is too burned out to understand after the investigation why we overextrude taking couple days.

Anyhow, doing extrusion multiplier calibration did the trick. You take very precise filament and print single perimeter cube. Then with micrometer you measure the thickness of the wall. You divide the preset number with the measured result and you get percentage correction. Turns out it is 0.95 or 95%. I think I seen someone figured the same number here on the forum but now I know why and can put it in the settings.

There was one other thing adding to over extrusion especially on thin wall objects and that was ridiculously high infill perimeter overlap of 35%. That is just stupid mistake and I did revert it to 25% from MK2S immediately in 2.1.1 release.

Print cooling settings were improved to match the cooling of MK2. But remember the MK2 was cooling from one side only on the MK3 we cool from 3 sides.

Lesson learned, I cannot delegate print settings completely just yet and get back into it myself 😳

One more thing I want to ask you, 0.35mm FAST print settings aren't actually speeding the prints on the MK3 compared to 0.20mm NORMAL settings. Let me explain, stock E3D V6 can extrude 15mm^3/s reliably. As the infill is printed at 200mm/s even with the 0.2mm NORMAL settings the flow is 16.28mm^3/s causing the speed to drop a tiny bit (Interesting fact, 0.35mm settings on MK2 use 13.12mm^3/s, so they are slower compared to 0.2mm on MK3). The 0.35mm FAST settings would actually consume 43.74mm^3/s, but they are capped to the same limit of E3D V6. All in all, 0.35mm FAST prints not much faster than 0.20mm NORMAL but produces non exceptional prints. Do you want to keep this setting or can I just delete it? We originally kept it for the historical reasons. I would rename the 0.20mm to FAST instead of NORMAL.

I baked the new drivers for windows with the tweaked settings and resliced models. Feel free to try it out already! I will put the on the Drivers page tomorrow.

EDIT 3.1. 21:52 CET - In the original link, some settings were missing, so if you downloaded in the last hour, please re-download and reinstall 😳

EDIT 5.1. 21:52 CET Thank you for the tests, New Drivers 2.1.3 are released NOW! https://www.prusa3d.com/drivers/

Founder and owner / Majitel a zakladatel...
Posted : 03/01/2018 8:55 pm
Greybeard3D
(@greybeard3d)
Estimable Member
Re: Slic3r PE over extrusion and cooling solved

Thanks Joe. Any chance the extrusion issue may also apply to the MMU since it uses bondtech as well?

Posted : 03/01/2018 9:22 pm
stahlfabrik
(@stahlfabrik)
Honorable Member
Re: Slic3r PE over extrusion and cooling solved

Great news! Great job!

Well the .3 question is a tough one. In the first place I would put quality: Do not tune the settings for speed but for quality first, then speed. If then the .3 is still slower than .2 I also wonder what the point in keeping it would be:-) But maybe someone wants the ruff layers for aesthetics or mechanical reasons. So some will be happy to keep them around! (maybe just get rid of the adjectives in profile names at all)

Best rergards!

Oh and for my tests using this thing: https://www.thingiverse.com/thing:1622868 0.9 was the extrusion multiplier for me with Prusa PLA. I do not know which test method leads to the truth:-)

Oh 2:-) Do not forget to put the replaced models in the Mac package this time please!!

Posted : 03/01/2018 9:52 pm
david.s86
(@david-s86)
Eminent Member
Re: Slic3r PE over extrusion and cooling solved

So what you're saying, Jo, is that we need to hook up a volcano to one of these machines to unlock it's true speed potential? 😉

Posted : 03/01/2018 9:53 pm
josefprusa
(@josefprusa)
Admin
Topic starter answered:
Re: Slic3r PE over extrusion and cooling solved

EDIT 3.1. 21:52 CET - In the original link, some settings were missing, so if you downloaded in the last hour, please re-download and reinstall 😳

Founder and owner / Majitel a zakladatel...
Posted : 03/01/2018 9:57 pm
josefprusa
(@josefprusa)
Admin
Topic starter answered:
Re: Slic3r PE over extrusion and cooling solved


Thanks Joe. Any chance the extrusion issue may also apply to the MMU since it uses bondtech as well?

You can try it out easily yourself by adding M221 S95 to the start gcode. I am last at the office and too exhausted to test it today. We will run test tomorrow 🙂

Founder and owner / Majitel a zakladatel...
Posted : 03/01/2018 9:58 pm
daniel.e10
(@daniel-e10)
Trusted Member
Re: Slic3r PE over extrusion and cooling solved

Hello Jo

I did this test a couple of days ago but got some strange behaviour on the G-Code.

https://shop.prusa3d.com/forum/original-prusa-i3-mk3-f30/slic3r-stange-behaviour-t12724.html

Did you got the same thing what I mentioned in this article?

Maybe that is a Slic3r bug what I found. I have the same behaviour on another part as well.

I have also a video of that if it is necessary.

Posted : 03/01/2018 10:08 pm
ormandj
(@ormandj)
Active Member
Re: Slic3r PE over extrusion and cooling solved

Thank you for the update. This mirrors most of the settings I had changed to get better quality prints.

I also noticed some issues with PET, is this material also being looked at? If you print a four sided single wall open top cube and measure with the default settings, the sides will all be different dimensions. Turning off auto fan and setting it to fixed (I think I was using 50%) after first layer made it consistent at least for me. I still had a lot of whiskers but the parts started coming out better.

I also had to slightly adjust my steps value with the extruder when tested over 100mm of filament, but it wasn't terribly off, I ended up at 564.35 from default of 560.

The last major quality issue seems to be the ringing, it's there in PLA and PETG, and uniform. All of my X and Y rods have scoring and grind a bit on movement so support has sent me replacements, but the ringing seems to be impacting nearly everyone. If it's speed related, then maybe some profiles that are quality first speed second would be great!

Thank you again, I'll test the updated profile on PLA soon.

Posted : 03/01/2018 11:23 pm
Area51
(@area51)
Re: Slic3r PE over extrusion and cooling solved

Will the new driver pack include settings for printing TPU, SemiFlex and Flexfill?
The previous settings update had the filament definition, but was missing the print speed setting.
The K factor for the flexible filament was also set to only 10 - I think it should be higher.

Have a look at my designs on Thingiverse or on PrusaPrinters ;)...
Posted : 04/01/2018 1:59 am
Olef
 Olef
(@olef)
Honorable Member
Re: Slic3r PE over extrusion and cooling solved

Thank you, Josef!

Posted : 04/01/2018 3:15 am
gorkish
(@gorkish)
Eminent Member
Re: Slic3r PE over extrusion and cooling solved

I worked up a routine for doing extrusion multiplier calibration, and according to my records at least a couple hundred have accessed it so far. Here is the link to my calculator you can use to dial it in very exactly if you are willing to print a couple of sample parts: https://goo.gl/kbuZMi This uses a test part from thingiverse that can be used without measurement by trial and error -- so long as you know what the fit is supposed to feel like, you can also do it this way.

On my own MK3 with the previous 35% overlap, a 0.93x in PLA was about right however I was also lowering outer perimeter extrusion width to 0.4mm which I suppose had partially the same effect. It radically improved the quality of prints but overall i still had outer perimeter issues. I suspect with the new settings I will dial it in around the 0.94 range.

Posted : 04/01/2018 4:56 am
reid.b
(@reid-b)
Reputable Member
Re: Slic3r PE over extrusion and cooling solved

I wonder if some of the ringing might be caused by the new Trinamic2130 drivers? Perhaps there is some form of resonance n the motors caused by current ripple or back EMF?

Posted : 04/01/2018 6:00 am
LaPointe
(@lapointe)
Moderator
Re: Slic3r PE over extrusion and cooling solved

I have never used the 0.35 profile on my MK2S and I don't plan to use it with my incoming MK3.

Thank you for your communication about this by the way.

Posted : 04/01/2018 10:01 am
Peter
(@peter-12)
Estimable Member
Re: Slic3r PE over extrusion and cooling solved

Does this mean you have switched your farm back to 0.2 layer heights?

Posted : 04/01/2018 10:33 am
RH_Dreambox
(@rh_dreambox)
Prominent Member
Re: Slic3r PE over extrusion and cooling solved

Does this mean you have switched your farm back to 0.2 layer heights?
+1

Bear MK3 with Bondtech extruder...
Posted : 04/01/2018 11:52 am
Protoncek
(@protoncek)
Reputable Member
Re: Slic3r PE over extrusion and cooling solved

I just did some tests: first i marked 100mm of filament and extruded it: that was spot on, then i printed single wall test cube sliced with newest Slic3r and 0.1mm height and i've got perfect 0.45mm walls. Sadly i never made such tests before so i can't tell how my printer was performing with earlier slic3r versions (it's MK3). I didn't change anything in slic3r. However, i must say that i never noticed any signs of over/underextrusion, not on MK2 and not now. Maybe i'm just lucky... 😀

Regarding 0.35 setting: i don't use it, never did, so my vote goes for deletion...

(oh, and FW is latest beta)

Posted : 04/01/2018 12:29 pm
luther.b
(@luther-b)
Active Member
Re: Slic3r PE over extrusion and cooling solved

Does this mean that If I have more than one brand of printer, all with Esteps properly set, they would all nominally need a .95 extrusion multiplier?

If so, that would sound like a bug in slic3r, or if the extrusion calculation is maintained for backwards compatibility, the extrusion multiplier default and help text might need changing.

Or am I misunderstanding the sense of the thread?

Posted : 04/01/2018 3:48 pm
Craig Trader
(@craig-trader-2)
Eminent Member
Re: Slic3r PE over extrusion and cooling solved


I baked the new drivers for windows with the tweaked settings and resliced models. https://www.prusa3d.com/downloads/drivers/prusa3d_win_2_1_2.exe Feel free to try it out already! I will put the on the Drivers page tomorrow.

EDIT 3.1. 21:52 CET - In the original link, some settings were missing, so if you downloaded in the last hour, please re-download and reinstall 😳

For the benefit on the non-Windows users in the audience, could you:

(1) Clearly indicate what versions of the Firmware and Slic3rPE are associated with a driver release.
(2) Build release images (including the AppImage for Linux) for all releases?
(3) Update the Slic3r PE build instructions to include *all* build steps, for people who don't normally build Perl applications from source.

At the moment, there are only source releases for Slic3rPE 1.38_6 and 1.39_0.

Thanks.

- Craig -

I solve problems, usually with computers ......
Posted : 04/01/2018 4:52 pm
tj.b
 tj.b
(@tj-b)
Re: Slic3r PE over extrusion and cooling solved

When are you going to be releasing the version for MacOS? I am having this issue and live in a household where windows isn't a thing!

...
Posted : 04/01/2018 6:06 pm
martin.m25
(@martin-m25)
Estimable Member
Re: Slic3r PE over extrusion and cooling solved

Hi Josef,

Do you want to keep this setting or can I just delete it? We originally kept it for the historical reasons. I would rename the 0.20mm to FAST instead of NORMAL.

I messed up my MK2S with this FAST profile pretty badly (extruder completely jammed, had to take it apart), also found out about the extrusion volume flow limit and wondered why this crap profile was in there in the first place? I thought as it is called Slic3r "PE" the PE would guarantee to have working stuff in there...

So to answer your question, please delete the FAST profile and also all others you personally don't recommend using. My personal focus is on getting good prints out of this machine and not fiddling with printer profiles. For others this might be different, but at least you could mark "experimental" profiles (or outdated ones) as such. Better have only two profiles that work perfectly than five half-working ones.

Also, for larger prints I would like to see an upgrade kit to a high flow hotend (like the volcano). Once you move from printing figurines to real world parts, print times with the standard hotend go to tens of hours quickly. Some users here (me included) are working or thinking on a volcano version, but this is tricky and an officially supported one would be fantastic!

Keep up the good work!

- Martin

- Martin...
Posted : 04/01/2018 7:44 pm
Page 1 / 3
Share: