Notifications
Clear all

Question for people with the R2/B6 parts  

  RSS
HeySideburns
(@heysideburns)
Trusted Member
Question for people with the R2/B6 parts

Did the new X-Axis fix any issues you were having with belt alignment? Specifically, did it fix the tilted idler pulley?

...
Posted : 27/02/2018 11:22 pm
reid.b
(@reid-b)
Reputable Member
Re: Question for people with the R2/B6 parts

No tilt on mine, looks very true. But.... I still can't get the alignment correct on both ends. It's as if the X-Axis carriage is not lined up properly with the X-end motor and the X-end idler. It tends to run to one side on the motor pulley, and the other side on the idler. Not much mind you, as I did my best to find the best compromise by all means (adjust depth of belt in carriage, move end-parts to the end of their allowable 'slop', etc.) I was not able to get it true enough to the point it never touches the side of one pulley or the other.

Posted : 28/02/2018 4:44 am
Ira S
(@ira-s)
Trusted Member
Re: Question for people with the R2/B6 parts

Ditto. I have the latest X-Axis parts and the belt still rides against the rim of the pulley. Causes belt deflection/tilting each time the carriage changes direction. Also a little noise from the pulley when the carriage is making very small & fast movements. Not concerned with the noise (it wouldn't be audible except for how quiet the MK3 is). And the deflection doesn't seem to effect print quality. But I'm sure it will eventually cause belt wear.

Is there a way to get support from PR on this other than posting in the forum?

Posted : 02/03/2018 7:43 pm
Zaf9670
(@zaf9670)
Active Member
Re: Question for people with the R2/B6 parts


Is there a way to get support from PR on this other than posting in the forum?

You can go to the X-carriage part on GitHub and post something there about your issues. You could also put a comment on the manual for the X-carriage assembly to see if anyone comes back with help/advice/fixes for your issue.

Posted : 13/03/2018 5:00 am
christian.b20
(@christian-b20)
Active Member
Re: Question for people with the R2/B6 parts

Contacted Prusa this morning via Chat. They told me it's easy to fix... I should loosen the pulley and change the position a bit. Will try this later today when I'm back home. But I already played around with it as far as I remember.
At the moment it looks like this:
I also pulled the belt a bit back from the x-carriage:

Posted : 13/03/2018 10:36 am
Ira S
(@ira-s)
Trusted Member
Re: Question for people with the R2/B6 parts

Contacted Prusa this morning via Chat. They told me it's easy to fix... I should loosen the pulley and change the position a bit. Will try this later today when I'm back home. But I already played around with it as far as I remember.
At the moment it looks like this:
I also pulled the belt a bit back from the x-carriage:

I'm confused about their answer: If they're talking about moving the sprocket pulley on the stepper, I've already tried that. It just moves the problem to the other end of the assembly. In order to get the belt to ride correctly on the idler pulley the stepper pulley needs to be moved to where the belt rides on the edge of the stepper pulley. Not a solution.

I've already tried pushing the belt attachment points on the extruder assembly as far "back" as possible, but no joy there either.

Posted : 13/03/2018 2:28 pm
JuanCholo
(@juancholo)
Reputable Member
Re: Question for people with the R2/B6 parts

after doing the upgrade on my machine, i feel there was a slight improvement however the alignment of the belt is still incorrect. there will have to be another change to the parts in the future to address it. something is off in the cad or 3d modeling files. i also push my belt all the way back and it seems like it needs to go another 1-2mm to get the alignment right.

“One does not simply use a picture as signature on Prusa forums”...
Posted : 13/03/2018 2:44 pm
Share: