Worked great for years, now horrible stringing.  

  RSS
John M.
(@john-m-2)
Active Member

The printer has worked fine for years. More than fine, I love this thing. Could always expect an 8/10 print or better using stock settings for most prints. I've had to adjust settings over the years for various prints but I always go back to stock. This stringing problem started at some point last year. I tried some fixes but then took a break for several months. Now I'm back to try and figure it out. Here's what I've tried so far...

 

Tests Pics (some of the recent ones anyway)
Update to latest firmware
Replaced third part extruder fan with OEM
Reduce temp from stock settings

 

Filament
New spool, fresh out of the vacuumed plastic
Spool out of my dry box
Some spools that have been sitting in my office (I live in Florida/USA)
If I move a spool from my MK3s to my Mini, the model turns out fine

 

Hotend
Replaced nozzle
Checked for clogs
Replaced extruder fan with OEM
Feeder gears are lined up, bolt is tight, etc.
Tension on the feeding gears seems to be fine

 

Other
Firmware is up to date
PrusaSlicer is latest version
I've tried multiple models
Temps ranging from 195-220
Various retraction settings
Calibration wizard has been completed many times
The machine has been cleaned and bearings lubricated.
All bolts have been checked to make sure tight, but not to tight.

 

I purchased the MK3 kit and upgraded to the MK3s. Eventually, purchased a Mini. I've owned a couple of other printers but none that match the quality of Prusa. I don't recall a specific time when this stringing issue first started. The extruder fan has stopped working several times. The last time I replaced it with a non-OEM part from Amazon. But with the stringing issue, I bought an OEM fan from Prusa but that hasn't fixed the issue. I can fix some of the stringing problems by messing with the slicer settings. However, stock settings have always been great so I feel there's something else that needs to be fixed so I can get it back to printing like a champ.

Posted : 21/02/2021 6:33 pm
Diem
 Diem
(@diem)
Honorable Member

First try unplugging and replugging all connectors.  Make sure all the signals are getting through.

Cheerio,

Posted : 22/02/2021 2:25 am
Brisma
(@brisma)
New Member

IMO the only problem is the thermistor damaged. I known that seems strange but try to print PLA at 170/180°C, you will get better results and this will confirms the termistor is reading the wrong temperature 🙂

If confirmed you have just to change the thermistor (and eventually the cartridge), it's normal 🙂

Posted : 22/02/2021 1:35 pm
Xanthe liked
bobstro
(@bobstro)
Illustrious Member

If you've replaced any hotend components, doing a PID tune is always a good idea. Also make sure the fan duct is aligned properly and not blowing on the heater block. 

My notes and disclaimers on 3D printing and miscellaneous other tech projects
He is intelligent, but not experienced. His pattern indicates two dimensional thinking. -- Spock in Star Trek: The Wrath of Khan...
Posted : 22/02/2021 2:45 pm
John M.
(@john-m-2)
Active Member

Thank you to everyone that has made suggestions. I really appreciate it. Here's the progress:

  • Made sure all cables were seated well (fan cable that I just replaced was loose)
  • Replaced thermistor
  • Performed a full Wizard run

Still stringing. No noticeable change.

It's running through a PID calibration now. Will run another test print afterwards.

Posted : 23/02/2021 3:12 am
John M.
(@john-m-2)
Active Member

PID calibration completed. Still stringing. No noticeable change... I'm at a loss. I thought the thermistor would've been the fix. Didn't occur to me. Can't be the heating cartridge since two thermistors are registering the same heat. I'm honestly not sure what else it could be...

Posted : 23/02/2021 6:34 am
Diem
 Diem
(@diem)
Honorable Member

You have checked the fan-duct alignment?

Cheerio,

Posted : 23/02/2021 9:07 am
John M.
(@john-m-2)
Active Member

@diem

I don't think that's the issue. I've had to remove it on a couple of these attempts to fix. Even if it was on there wrong at some point, seems like I would've put it back right eventually. I did assemble it right at the start and with the MKS upgrade. Who knows. I'm grasping at straws. I'll double check tonight. Can't hurt/might help.

Posted : 23/02/2021 2:44 pm
John M.
(@john-m-2)
Active Member

Everything seems to be aligned cooling wise. After the steps I've taken, there may be marginal improvement but no where near where it was before the stringing problem. I'm at a loss. I'm not sure what else to try...

Posted : 02/03/2021 5:17 am
Xanthe
(@xanthe)
Eminent Member

This is clutching at straws, but,

I assume you have a genuine 0.4mm E3D brass nozzle fitted (you said you'd replaced it).

Try increasing the Z lift on retraction, try increasing the travel speed if it's <180 mm/s, and increasing the travel acceleration.
If these can be done (i.e. they're not already at or near maximum), this can start to lead in the right direction for analysis.

If you updated the firmware, try reverting it to the previous version.

This post was modified 2 months ago by Xanthe
Posted : 02/03/2021 10:46 am
John M.
(@john-m-2)
Active Member

It appears as though the stinging problem is fixed. I did another test robot and there was only the ever-so-slightest string or two. Easily cleared without even a single pass from a heat gun. Sadly, I'm not sure what the problem was. The reason it's fixed is because I ordered an assembled hotend from PRUSA. I replaced that, and only that, in it's entirety. After a Active Z Calibration or two, I'm back in business. My suspicion is that it was an 'Amazon special' nozzle. I should've known better.

Thank you to everyone who offered suggestions. It is much appreciated. I love my MK3s and Mini. The Mini is my top suggestion for an entry level printer when I'm asked. My next goal is to get the MMU2 working. My boss gave me the one he bought but couldn't get working right. I'm also thinking about the + upgrade. Anyone have any feedback on it?

Posted : 12/03/2021 3:17 pm
Share:

Please Login or Register