Upgrading MMU2S to 1.0.5 with PrusaSlicer ?..  

  RSS
alexsunny734
(@alexsunny734)
New Member

Hello,

 

I just flashed the main board, no problems.  When I try to flash the MMU2S, this is all I get out of AVRDude...

Flashing Original Prusa MMU 2.0 Control, looking for VID/PID 0x2c99/3 or 0x2c99/4 ...
Found VID/PID 0x2c99/4 at `COM3`, rebooting the device ...
Error: open: Access is denied

So it obviously found COM3, and opened it already in order to read the VID/PID...but then Access is denied?  I've tried this with Slic3r PE itself, same issue.  I've done reboots, I've done uninstalls, I've done just about everything I can think of, which now includes coming to the forums.  Has anyone seen this behavior before?

While I'm sitting here still playing with it, I did notice something else.  Just after rebooting the Prusa, I can see a new COM port open up for 'Original Prusa i3 MK3 Multi Material 2.0 bootloader' on a wholly separate port, which dissapears after a few moments and shows 'Original Prusa i3 MK3 Multi Material 2.0 upgrade' instead.  Trying to flash during that brief moment gave me different results in AVR, but still no flashing (still reported the open as denied, however it got a lot further in the process).

 

thanks

alexsunny

Posted : 21/10/2020 10:39 am
JoanTabb
(@joantabb)
Moderator

Hi AlexSunny, 

I believe the latest firmware for MMU2S is version 1.06

Would you be better trying to upload that? 


do you unplug the USB lead from the Printer when you are updating the MMU2S? 

I can't remember which update it was, but for one of them, I found that pressing the MMU2S reset button, was needed to coax he loader to work. 

regards Joan

I try to make safe suggestions,You should understand the context and ensure you are happy that they are safe before attempting to apply my suggestions, what you do, is YOUR responsibility. Location Halifax UK...
Posted : 21/10/2020 10:29 pm
Share:

Please Login or Register