Clear all

[Solved] Unable to calibrate after error "z-levelling enforced"  

Trusted Member
Unable to calibrate after error "z-levelling enforced"

A few weeks ago I received an error message 'Z-level enforced'. After the printer tried a couple of times to calibrate the z-level I gave up and did a calibrate XYZ which solved the problem and I could print again. Yesterday the same error message appeared again (if I am not mistaken both times it happened after I had not used the printer for at least a week, in case this should play a role).

This time I used the Wizard and received an error message about the 'X-axis length'. The hotend moved to the right but stopped about 5cm from the right endstop, nothing blocked it. I switched off the printer, moved the hotend all the way to the right. Started calibrating again. X-axis length error, this time the hotend stopped a few cm before it reached the left endstop. 

I chatted with a support rep and tried a few suggestions (tighten belt, auto home from the menu) but nothing solved the problem. Due to an appointment I had to stop the chat.

I have made 3 videos that might help in pinpointing the problem.

This video shows the X-Axis length error:

this one the auto home attempt:

and this one the Z-clibration attempt:

The thermistor cable (temp solution) that can be seen does not interfere with any movements of the hot end.

Posted : 13/07/2019 9:29 am
Trusted Member
Topic starter answered:
RE: Unable to calibrate after error "z-levelling enforced"

I just did a 3rd factory reset (All Data) and to my big surprise that seems to have done it, at least for the moment, who knows. I can print again.

It does not explain the Z-level enforced message, but hopefully that won't show up again.

Posted : 13/07/2019 7:06 pm