Troubles starting Pi Zero with PrusaPrint  

  RSS
Mordraug
(@mordraug)
Active Member

Hello,

I was using PrusaPrint on my Pi Zero W for about a month so far and it used to run great. One day I turned on printer and noticed that I can't connect to octopi, quick check on router confirmed that it's not connected to network. I reflashed sdcard with clean prusaprint image and reconnected raspberry to printer but it still wouldn't connect.

I noticed however that after I powered it on it did connect briefly to network then disconnected. It gave me an idea to disable rpi port on my printer, power it off and on again and I could open octoprint panel just fine. After I turned rpi port back on and connected manually through octoprint panel, octoprint worked as it should (save for displaying ip address on printers screen).

So apparently if I have rpi serial port enabled while turning on printer it somehow crashes it, causing raspberry to disconnect form wifi. Any idea what goes on?

Posted : 19/11/2020 12:17 am
cwbullet
(@cwbullet)
Illustrious Member

What is Prusaprint?

--------------------
Chuck H
3D Printer Review Blog...
Posted : 24/11/2020 12:24 am
Mordraug
(@mordraug)
Active Member

@cwbullet

Modified octoprint version by Prusa. Afaik it's just octoprint preconfigured to work acceptable on Pi Zero out of the box. 

Posted : 24/11/2020 1:04 am
Print My World
(@print-my-world)
Eminent Member

I actually remember reading this somewhere. I'll try to dig up the article, but it was to power your pi before printer, and shut off printer before pi.

Posted : 24/11/2020 1:11 am
cwbullet
(@cwbullet)
Illustrious Member

@mordraug

I have never been able to get a zero to work my Mk3s.  I am nor sure It is possible with the mini.  

--------------------
Chuck H
3D Printer Review Blog...
Posted : 24/11/2020 1:38 am
Mordraug
(@mordraug)
Active Member

@print-my-world

That would probably work as well, I was able to kinda work around it by disabling autoconnect on octoprint and just manually clicking connect after it all starts. Seems to be working. 

I'm more interesting in why this happens and why did it work normally before and suddenly stopped tho. 

Posted : 24/11/2020 5:39 am
Print My World
(@print-my-world)
Eminent Member

Found it https://community.octoprint.org/t/put-tape-on-the-5v-pin-why-and-how/13574 . Fix is simple too.

Posted : 24/11/2020 8:31 am
towlerg
(@towlerg)
Prominent Member

I was going to point out that the use of the zero to run OctoPrint is discouraged in the strongest possible terms but it seems some people are determined.

 

Posted : 24/11/2020 9:46 am
cwbullet
(@cwbullet)
Illustrious Member

@towlerg

I have to agree.  Most experience problems.  

--------------------
Chuck H
3D Printer Review Blog...
Posted : 24/11/2020 1:37 pm
Mordraug
(@mordraug)
Active Member

@print-my-world

This seems to apply to raspberries connected through usb tho. Im using gpio serial connection in dedicated slot. 

Posted : 24/11/2020 1:47 pm
Mordraug
(@mordraug)
Active Member

In case someone have the same problem, I finally found a solution that works for me.

tl;dr: I turned off wifi power saving on raspberry (see this guide: https://dontpressthat.wordpress.com/2017/11/03/prevent-raspberry-pi-dropping-wifi/) and it works better than ever before.

 

I was sure that poor performance even in ssh before was due to pi zero not having enough juice, but checked usage during operation using htop and it was barely above idle (I'm not using cam tho, just using it monitor temps and send gcode). So I looked more into wifi logs especially when it failed to connect at all and noticed "wlan0: carrier lost" entries, googling which led me to link above. After applying this, everything runs butter smooth. Since I apparently have quite a lot of free cpu I might try to look into gopro control to get some nice timelapses. ^^

Posted : 06/12/2020 4:26 am
Share:

Please Login or Register