Notifications
Clear all

Start up  

  RSS
Barry Windsor
(@barry-windsor)
Active Member
Start up

My prusa mk3s has suddenly reversed itself!

 I print from sd card.......select file........print........bed heats to 170 degrees........does bed levelling........printer head goes to right hand side of plater .....heats the rest of the way to 215 degrees........then starts printing from the right.

It always used to heat straight up to 215 degrees, pause at left of plater then print.

Any suggestions anyone?

Many thanks.

By the way I am on the latest firmware.

Posted : 22/03/2021 12:05 pm
Clarmrrsn
(@clarmrrsn)
Honorable Member
RE: Start up

Has anything changed with your Slicer?

Does it do this with all prints?

Can you try one of the original Prusa GCode test print files to see how that prints?

Tank you very much!...
Posted : 22/03/2021 12:12 pm
Barry Windsor
(@barry-windsor)
Active Member
Topic starter answered:
RE: Start up

Hello,

Thanks for the rapid reply.

I am using the latest slicer and yes it does this for all prints.

Please be patient, I am 82 yrs old! How do I do a gcode test? 
Barry.

Posted : 22/03/2021 12:18 pm
Neophyl
(@neophyl)
Famed Member
RE: Start up

Barry I think that is normal now.  Its the 2 stage startup routine.  It preheats to 170 so the filament doesn't ooze out while its doing the mesh levelling etc.

It then returns to the front left corner and then heats the rest of the way up.  A configuration update from Prusa is probably the cause.  If you are using system defaults then when Prusa update them it causes changes.   If you check your Printer Settings>Start gcode, the command sequence it uses will be in there.

As such anything sliced since the update will have the new gcode start included and anything you print that was sliced before the update should print using the old sequence.

Posted : 22/03/2021 12:47 pm
Barry Windsor
(@barry-windsor)
Active Member
Topic starter answered:
RE: Start up

Hello Neophyl,

You state it returns to the front left hand corner then completes the heat up.

mine is going to the right hand corner.

should I delete slicer then reinstall ?

Posted : 22/03/2021 12:56 pm
Neophyl
(@neophyl)
Famed Member
RE: Start up

@barry-windsor

Can I just check what printer you are actually using ?  I made the presumption you are using a MK3 based printer as you posted in the MK3 forum.  A MK3 will home at the front left corner.  If you have a different printer then it could home in a different spot.

I don't own a Mini but I think they home front right.  In fact that would explain things, if you have a Mini selected as your printer type then the start gcode for that printer does have the 2 stage warmup too.

I don't use the MK3 defaults as I have my own custom start routine so I dont definitively know if Prusa have gotten around to adding the 2 stage to the MK3 defaults but your issue could be as simple as having the wrong printer selected.

Posted : 22/03/2021 1:12 pm
Barry Windsor
(@barry-windsor)
Active Member
Topic starter answered:
RE: Start up

Hello,

 I have a mk3s

Posted : 22/03/2021 1:15 pm
Neophyl
(@neophyl)
Famed Member
RE: Start up

@barry-windsor

So what printer is selected when you slice the stl file ?  Also the gcode files you are printing from the SD card, are they ones you sliced yourself or ones you downloaded from somewhere ?

The best way to debug these issues is for you to save the project that is giving you the issue.  By using File>Save Project As.  This will save a .3mf type file.  The 3mf file will contain the model file and a copy of all your settings used for slicing.  Take the 3mf file and zip it into an archive.  Then attach the zip archive here.  It must be zipped for the forum to allow the file to be attached.

With the project file we can see exactly what settings you have.

Posted : 22/03/2021 3:03 pm
Share: