Notifications
Clear all

SD Cards no longer working after firmware update.  

  RSS
Loose Goose DX
(@loose-goose-dx)
New Member
SD Cards no longer working after firmware update.

I've recently flashed my firmware to version 3.9.1 on my i3 MK3S. Since then I can no longer get SD cards to work. It will recognize when a card is entered and removed, but the file browser is empty, and the main menu says "No SD card." I have tried reformatting the SD card (it is the one that came with my printer) in FAT32, as well as trying another SD card and formatting it, but the problem persists. I have also tried inserting the card only part way, until the printer tries to load the card, but this does not work either.

Best Answer by Loose Goose DX:

Sorry I wasn't able to post sooner, but I found out the problem. Turns out using Windows disk management to format the SD card wasn't cutting it, even under FAT 32. I used the SD card formatter from SDCard.org and it works fine now!

Posted : 20/10/2020 3:29 am
vintagepc
(@vintagepc)
RE: SD Cards no longer working after firmware update.

Sounds more like a coincidental failure of the card slot. 

Does it start working again if you go back to the previous version?

Posted : 20/10/2020 3:57 pm
Loose Goose DX
(@loose-goose-dx)
New Member
Topic starter answered:
RE: SD Cards no longer working after firmware update.
Posted by: @vintagepc

Sounds more like a coincidental failure of the card slot. 

Does it start working again if you go back to the previous version?

Looks like you are correct, downgrading the firmware did not fix the problem.

Posted : 20/10/2020 8:15 pm
vintagepc liked
vintagepc
(@vintagepc)
RE: SD Cards no longer working after firmware update.

Double check the LCD cables are not damaged and securely seated on both ends. 

If it's still under warranty, you can talk to live chat and they'll probably send you a replacement module. 

Posted : 21/10/2020 11:52 am
Loose Goose DX
(@loose-goose-dx)
New Member
Topic starter answered:
RE: SD Cards no longer working after firmware update.

Sorry I wasn't able to post sooner, but I found out the problem. Turns out using Windows disk management to format the SD card wasn't cutting it, even under FAT 32. I used the SD card formatter from SDCard.org and it works fine now!

Posted : 23/10/2020 4:36 am
Share: