PrusaSlicer, Octoprint, and travel_speed / speed_travel
 

PrusaSlicer, Octoprint, and travel_speed / speed_travel  

  RSS
chip.c
(@chip-c)
New Member

Good Evening,

I'm running the latest PrusaSlicer 2.2.0, and the latest OctoPrint 1.4.2.  OctoPrint has this nice new little addon that is supposed to check for instances of {travel_speed} and warn you that it should be {speed_travel}.  Now for starters the PrusaSlicer puts out time_speed=180 at the bottom of my gcode files, but it's commented out.  I can't find where that is being inserted.  It's not in the start_scripts, or end_scripts or any other scripts I can find.  I'm hoping someone on here has run into this issue and can tell me how to fix it correctly.

Thanks

Posted : 13/11/2020 11:37 pm
Neophyl
(@neophyl)
Noble Member

The comments that it inserts at the bottom of the gcode are not used during printing.  Its basically a copy of all the settings used to slice that gcode.  Which is why they are commented out.  It allows you, in Prusa Slicer to load in the settings from any sliced gcode file and then use them in your current file.  

If you look at the actual content of the gcode you will see feed moves such as G1 X?? F????  the F is the feedrate and it will change depending on if its a travel move or not or whatever the settings for that type of move are set at in slicer. 

There should be any gcodes that need changing if you have selected the correct gcode flavour for your printer.  The whole point of that selection is to make sure the slicer uses the correct command for the firmware type.

Posted : 14/11/2020 12:22 am
Share:

Please Login or Register