Prusa slicer 2.30  

  RSS
medic56
(@medic56)
Active Member

So I have tried to update the slicer from 2.20 on a mac and it keeps going back to the 2.20 even tho the drivers I'm installing are 2.30. I have deleted the app and tried refresh but it always reverts to 2.20. Am I doing something wrong?

Posted : 05/07/2020 3:26 pm
Halcón Designs
(@halcon-designs)
Eminent Member

2.3.0 of apps and drivers contains PrusaSlicer 2.2.0. PrusaSlicer 2.2.0 is the latest stable release. 2.3.0 is on the PrusaSlicer Github currently in alpha0 phase.

Posted : 05/07/2020 3:38 pm
medic56
(@medic56)
Active Member

@halcon-designs

I'm sorry I was really referring to the drivers I guess. With the hollowing of prints and stuff. I have downloaded the latest drivers but the features don't appear to be there.

Posted : 05/07/2020 3:41 pm
Neophyl
(@neophyl)
Noble Member

At the moment its very confusing due to the similar version numbers.  When developing software ALL parts of the process usually get their own individual version number.  So Prusa Slicer is currently at version 2.2.0.  The other drivers inside the package will also have their own individual version number(s).  All  those bits and pieces are then put together into a package file.  That package file ALSO has its own version number, so that it can be tracked too.  Due to circumstances the package version is now 2.3.0. 

This similar version number is confusing a lot of people. Especially as the pre-alpha, not yet available unless you build it your self Prusa Slicer is ALSO at version 2.3.0 now.

If you are running released versions of the software then you will NOT be able to get Prusa Slicer 2.3.0 as it has not been released as yet.

Posted : 05/07/2020 5:16 pm
medic56
(@medic56)
Active Member

@neophyl

Thank you so much! I watched the video and thought it was available. I thought I was doing something wrong.

Posted : 05/07/2020 5:58 pm
peter.m26
(@peter-m26)
Honorable Member

Keep the firmware and prusaslicer version together, update both at the same time, and do not update the software only.

Posted : 05/07/2020 6:06 pm
bobstro
(@bobstro)
Illustrious Member
Posted by: @peter-m26

Keep the firmware and prusaslicer version together, update both at the same time, and do not update the software only.

There are several programs and data files in the bundle. Not all will be updated at the same time. 

My notes and disclaimers on 3D printing and miscellaneous other tech projects
He is intelligent, but not experienced. His pattern indicates two dimensional thinking. -- Spock in Star Trek: The Wrath of Khan...
Posted : 05/07/2020 6:50 pm
towlerg
(@towlerg)
Reputable Member

Maybe they should take the slicer out of the drivers bundle, it's confusing and it not as if the slicer is in some "lock step" with the drivers.

Posted : 06/07/2020 11:31 am
bobstro
(@bobstro)
Illustrious Member

I can see why they don't want to align the version numbers -- changing PrusaSlicer version numbers when nothing's changed would lead to chaos -- but perhaps including some differentiator in the version number itself might work. A numeric code (e.g. all PrusaSlicer versions start with 1000) or simply an alpha designator (e.g. PS2.30) might help. It's interesting that this hasn't been an issue until now with the announcement of the PrusaSlicer 2.3 Alpha that everyone is after and coincidental numbering of the "driver" package to 2.3.

 

My notes and disclaimers on 3D printing and miscellaneous other tech projects
He is intelligent, but not experienced. His pattern indicates two dimensional thinking. -- Spock in Star Trek: The Wrath of Khan...
Posted : 06/07/2020 6:40 pm
Share:

Please Login or Register