Prusa i3 MK3S is not able to print flex material  

  RSS
dimitri.l3
(@dimitri-l3)
Eminent Member

Hello

I'm failing to print Flexfil 98A over and over again. I've been trying for 3 weeks now. I think I tried every trick in the book.
Here is what i did:

Printing with the stock extruder:

After a short time of printing, the filament gets jolted after the extruder gears and cloggs up the hole before the PTFE tube. This also happens after loosing the idler pressure. (see image below)

Stock Extruder

As a consequence I printed and installed the MK3s extruder for flexibe filaments by Petehagoras ( https://www.thingiverse.com/thing:2905638 ). This mod eliminated the issue of deforming filament next to the gears. See picture below:

Soft filament extruder

At first it seemed to solve the problem, but after a few minutes into printing, something somewhere in the extruder/hotend assebmly makes the filament to get stuck again and again. I completly dissasebled the hotend, heatbreak, PFTE tube, made sure everything is clean and put it back together and making sure that there is no gap in between any component where liquified matieral could get trapped and clog the filament path.

But it did not help much. The extruder got stuck again and again after a few minutes of succesful printing. I tried every possible setting I got recommenden. Printsspeeds from 10 mm/s - 40 mm/s, temperatures from 220C to 240C, loose idler, no retractions, dryed filament, perpendicular unwinding of the spool and everithing combined together.

See below a testprint where i tried different speeds. The symptomes are always the same. first few layers OK, then major underextrusion and the extrudermotor that is skipping steps. After the few failed layers, I manually unloaded the filament, snapped off the part that was in the extruder an loaded it again. I slowed down the printspeed and let it print again. See picture below:

Flexfil 98A printing Issues

 

I read from people who have no trouble printing much more flexible material with this mod at even higher speeds without any issues. I have no idea what I'm doing wrong or what I could do differently. I already put too many hours into fixing this problem with trial and error. Do you have any ideas what could have gone wrong?

Another something I noticed:

The prusaSlicer does output retractions before every travel movement, even though retraction leght is set to zero and retract on layer change is disabled. I have no idea where the setting is for the retractions that still exist in the GCode and how to completly disable them. See picture below, the grey dots are retractions:

retractions

Posted : 19/12/2019 4:07 pm
Robert-mm200
(@robert-rmm200)
Noble Member

Only thing I can suggest is try Cura if you think PrusaSlicer is embedding retractions.

Posted : 19/12/2019 5:39 pm
mdaneman
(@mdaneman)
Estimable Member

@dimitri-l3

At what speed are you printing?  Your speed should be at 30mm/s or less.  Also you should set your retraction to zero.

I was able to print NinjaFlex TPU successfully using the stock MK3S extruder with these settings.

Posted : 19/12/2019 11:46 pm
dimitri.l3
(@dimitri-l3)
Eminent Member

@robert-rmm200

Hi robert, i just realised that there was a retraction set in the Filament Override tab in the Filament options. I set it to zero and give it another go.

filament options

 

@mdaneman

I tried everything in between 10mm/s and 50mm/s. Retractions are now set all to zero.

I'm glad that you could print NinjaFlex. Hearing other people saying it works, makes me confused if I do a mistake, or if the machine has a failure. 🙃 

Posted : 20/12/2019 9:21 am
ron
 ron
(@ron)
Estimable Member

A new idea: dry the filament.

I have some Ninjatek Armadillo filament (which should be quite easy to print with its very high shore) and I let in the box for now as I had big inconsistencies like you with that filament. Most of the time the filament stopped extruding. I was down to 2.5mm3/s. I don't have time at the moment to push investigation further. 

In vase mode I didn't notice any special issues with my flexible filaments (from shore 70A).

...
Posted : 20/12/2019 11:06 am
dimitri.l3
(@dimitri-l3)
Eminent Member

UPDATE:

Same issues without retractions. Here is the result. Speed was 20 mm/s. 

underextrusions

This is how I dry/store my filament. I already tried 2 seperate spools of Flexfil 98A. It didn't make a difference.

drybox

I have absolutely no clue what to do next. I ordered the Hemera Extruder and hoping for a official MK3S upgarde guide.
I found a upgrade guide for the MK2. I'm thinking of just using the MK2 X-carriage with the Hemera on the MK3S and scrap the filament sensor.

I would like to buy my own 3D printer for at home (this one is in our office), but I'm hesitating to get a Prusa again, because i would primarily use it for TPU  & drone parts.

This post was modified 9 months ago by dimitri.l3
Posted : 20/12/2019 1:50 pm
nikolai.r
(@nikolai-r)
Noble Member

@dimitri-l3

Please attach your project file, so we can verify the settings. Will try to find my profile for NinjaFlex and attach it here, too.

Often linked posts:
Going small with MMU2
Real Multi Material
My prints on Instagram...
Posted : 20/12/2019 7:27 pm
dimitri.l3
(@dimitri-l3)
Eminent Member

@nikolai-r

https://drive.google.com/open?id=1x4dIAWfF9Ed5BxZTaIh5po2WqKpP4BLv

Sure thing. Here is the project file. 

I used this model for the testprint: https://www.prusaprinters.org/prints/4834-pirelli-p-zero-branded-tire-for-openrc-f1-multi-ma

 

I already ordered the Hemera extruder btw. I found the upgrade guide here: https://e3d-online.dozuki.com/Guide/Hemera+Prusa+i3+MK3+Upgrade/135?lang=en

Posted : 23/12/2019 10:25 am
dimitri.l3
(@dimitri-l3)
Eminent Member

https://forum.prusaprinters.org/forum/original-prusa-i3-mk3s-mk3-user-mods-octoprint-enclosures-nozzles-.../hemera-mk3s-upgrade-parts-and-firmware/#post-186042

 

Iswitched to the Hemera extruder. It works beautifully. Here is the modding thread:

Posted : 20/01/2020 7:55 am
ronny
(@ronny)
New Member

Hi Dimitri - I also had the same issue with using Flex (PolyFlex by Polymaker) 

It filament would start to go around the gear insead to going into the PTFE after first few mins of printing. 

I took appart a few of the screws ( 2 from the fan and two from the bottom outside the hot end - and was able to try to lift the PTFE to its much closer to the gear. You might have to lift the full Hot end slightly that seems to have resolved the issue. 

This is just here for anyone else noticing the same issue. 

 

Thanks

Ronny

MK3S no mods, orginal setup using FLEX setting from PrusaSlicr

Posted : 08/02/2020 2:19 am
Share:

Please Login or Register