Power Failure False Positives and Reporting  

  RSS
paul.a3
(@paul-a3)
Active Member

I just ran a print which reported having 8 power failures, however I am sure that this was not the case. There was a jam at some point but I don't believe there were any power failures. Has anyone else encountered this.

The print was run from OctoPrint and I have a MK3S (firmware 3.7.2) with the new Delta PSU. I assume if there were a power failure that there would have been some interruption seen in OctoPrint but this wasn't the case.

...
Posted : 11/08/2019 10:47 am
david.a66
(@david-a66)
Honorable Member

unless there is a bad wire between the power sensor and the controller I suspect there really were 8 sensed power hits. the power sense circuit is a simple opto isolator reading the AC line voltage it will catch 1 cycle dropouts or sags which will not be long enough to drop the supply output ( thats the whole idea - catch the failure early enough to stop the print and move the extruder away from the object being printed before the supply voltage drops too much). if the power line comes back fast enough the print will continue.

Posted : 11/08/2019 12:28 pm
paul.a3
(@paul-a3)
Active Member

Oddly, this has only happened on the most recent print (printing ASA so certainly taxing things more) and all of the hits were on that print and none previously. Had my AC supply been dirty enough to cause this I would have thought earlier prints would have also seen it.

If the printer had re-homed 8 times and immediately resumed I would also have expected to find some evidence of this on the print, as occurs when I do it manually. Though I can’t be 100% sure since I did not watch the entire print. I will recheck the sense cable though to be sure its not that.

...
Posted : 11/08/2019 12:49 pm
Share:

Please Login or Register