Octoprint, Pi4 2gb, MK3S, GPIO pins... can't get the communication to work.
 
Notifications
Clear all

[Solved] Octoprint, Pi4 2gb, MK3S, GPIO pins... can't get the communication to work.  

  RSS
Ofer Krupka
(@ofer-krupka)
Active Member
Octoprint, Pi4 2gb, MK3S, GPIO pins... can't get the communication to work.

Software: Octoprint 0.18.0.

Raspberry Pi 4 Model B 2gb.

Prusa MK3S.

 

I connected it with GPIO pins (cable: ~30cm 36awg).

einsy

In the printer:

 

And this is what I get:

Just can't get it to work.

Posted : 24/12/2020 11:36 pm
Dr bob bob
(@dr-bob-bob)
New Member
RE: Octoprint, Pi4 2gb, MK3S, GPIO pins... can't get the communication to work.

What configuration did you do on the Pi side?  I suspect you will need to follow instructions similar to setting up the gpio on the pi.  https://help.prusa3d.com/en/article/octoprint-configuration-and-install_2182/#configure-rpi-zero-w-gpio

I'm not sure what would be different between the PI 4b and the zero w for those instructions.  Some quick googling says that it should be the same instructions.  Normally, the instructions for using octoprint have you connecting to the printer via USB.  The header for the Zero on the Einsy board is something that I hadn't seen before.  If you are going to use the hardware serial, you should be connecting with something like /dev/ttyAMA0 instead of the normal /dev/ttyUSB0.

Posted : 27/12/2020 7:50 pm
towlerg
(@towlerg)
Noble Member
RE: Octoprint, Pi4 2gb, MK3S, GPIO pins... can't get the communication to work.

I seem to remember reading that Pi 4 has two USARTS (one good one bad, no idea why). Have you tried connecting with USB just to make sure OctoPrint is running correctly?

Posted : 28/12/2020 1:37 pm
Ofer Krupka
(@ofer-krupka)
Active Member
Topic starter answered:
RE: Octoprint, Pi4 2gb, MK3S, GPIO pins... can't get the communication to work.

@towlerg

USB is working.

Got tired of GPIO, my custom made cable is 45cm (measured it), AWG 36.

it's probably picking static noise.

Might try it again with shielded cable in the future.

Thanks guys.

This post was modified 11 months ago by Ofer Krupka
Posted : 28/12/2020 3:32 pm
dimprov
(@dimprov)
Noble Member
RE: Octoprint, Pi4 2gb, MK3S, GPIO pins... can't get the communication to work.
Posted by: @ofer-krupka

AWG 36.

 

I'd wager that's the problem, or at least part of the problem, right there.  And if it's chinese wire, you have to derate it even more because of impurities like iron in it.

This post was modified 11 months ago 2 times by dimprov
Posted : 29/12/2020 5:54 am
Peter in Katy
(@peter-in-katy)
Estimable Member
RE: Octoprint, Pi4 2gb, MK3S, GPIO pins... can't get the communication to work.

You must connect the ground pins between the 2 boards. 

Posted : 29/12/2020 1:44 pm
dimprov liked
Share: